Subject: Re: [P2PSIP] Who is working on an implementation for a P2PSIPproposal?

From: "Jan Seedorf" <[email-masked]>
Date: Thu, 27 Sep 2007 16:29:53 +0200

Dear Mosiuoa and all,

I supervise a thesis at the University of Hamburg where we actually use the the same componenents to build a P2P-SIP prototype: OpenChord as a DHT and JAIN-SIP to build a SIP-to-DHT-Adaptor. It works fine (tested only with softphones so far). Our focus is security: we intend to measure how much delay certain security add-ons (either on the DHT layer or on the application/SIP-layer) add to the total call setup-time. From a security perspective we believe that the real-time demands for VoIP may yield certain DHT-security techniques more suited for P2P-SIP than others. Exploring this area is the core of our work.

Mosiuoa: if you are interested in exchanging experiences etc. send me an e-mail, I am interested in your experiences so far. Specifically, we had some (minor) problems with iterative routing in OpenChord, some of which have been fixed in the latest release.

Kind regards,
Jan

-----Original Message-----
From: Mosiuoa Tsietsi [mailto:[email-masked]]
Sent: Tuesday, September 25, 2007 5:05 PM
To: Adrian Georgescu
Cc: P2PSIP Mailing List
Subject: Re: [P2PSIP] Who is working on an implementation for a P2PSIPproposal?

Hi,

We at Rhodes University in South Africa have implemented a design for a P2P SIP node based on the OpenChord and Bamboo DHTs. Its basically middleware between the application logic and the underlying SIP stack. For proof of concept, we incorporated this layer into a VOIP client from NIST labs which embeds a JAIN stack. We have not been able to push out an ID yet, but are planning to - but alot of the ideas that have been criss-crossing on this list have fed into the implementation i.e. DHT agnosticism (overlay pluggability), SIP-over-P2P, separation of P2P layer from service layer (pluggable services), use of DynDNS for CS SIP-P2P SIP interoperation etc; Hope to submit something soon just to communicate ideas and experiences. 

Mos

On 9/25/07, Adrian Georgescu <[email-masked]> wrote:

	AG Projects is also providing infrastructure solutions for self-
	organizing SIP Proxies by using P2PSIP concepts.
	
	Adrian
	
	On Sep 25, 2007, at 4:32 PM, Bruce Lowekamp wrote:
	
	> SIPeerior has a full P2PSIP that is for sale now and is being used by 
	> real-world customers.
	>
	> There are some slight differences between the commercial version and
	> RELOAD, mostly due to lessons learned from one being incorporated into
	> the other at different times. 
	>
	> Bruce
	>
	>
	> On 9/24/07, Hannes Tschofenig <[email-masked]> wrote:
	>> Let's just ask the group: Who has done implementation work (or is 
	>> planning todo some implementation work) with regard to a proposal
	>> discussed in this group?
	>>
	>> Ciao
	>> Hannes
	>>
	>>
	>> Peter Pan wrote:
	>>> not just "when and how" but also "who and whether", i think: 
	>>>
	>>> may we know who are working on p2psip implementations (both
	>>> private and
	>>> open-source)?
	>>>
	>>> how can we know whether yours are comprehensive (competent, 
	>>> independent,
	>>> interoperable, operational, ... ) or not?
	>
	> _______________________________________________
	> P2PSIP mailing list
	> [email-masked] <mailto:[email-masked]> 
	> https://www1.ietf.org/mailman/listinfo/p2psip

	_______________________________________________
	P2PSIP mailing list
	[email-masked] <mailto:[email-masked]> 
	https://www1.ietf.org/mailman/listinfo/p2psip

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "Yao Wang" <[email-masked]>
Date: Sat, 29 Sep 2007 17:33:13 +0800

Hi, everybody,
	In addition to all the implementations proposed in this list, I'd like to introduce our initial implementation of a P2PSIP. We, at BUPT, have implemented a SIP-using-P2P architecture to make SIP working without central server. 
	Bamboo DHT is adopted as the underlying overlay, and partysip SIP proxy (www.nongnu.org/partysip/) is adopted as SIP sever. The location service of partysip is replaced by RPC of Bamboo DHT. Thus, we modify the partysip SIP proxy to be a SIP-to-P2PSIP adaptor. To run this system, a conventional SIP UA, a modified partysip SIP server, and bamboo DHT should be installed on each computer.
	Our system, named as olyo, supports basic phone services (including audio and video), IM, and etc. More info on olyo can be found at http://code.google.com/p/olyo/
	The olyo is only our initial step. In the next step, we are planning a prototype implementation of P2PSIP stack.	

I totally agree with the view that 
	" We need somebody who recognizes that the “customer” for P2PSIP isn’t the 	IETF, and it’s not the people on this list.  The customer is the user who 	actually chooses it over competing alternatives, be that alternative Skype 	or AT&T or IM or simply not talking at all."
What we are going to do is to promote P2PSIP-based services first in campus, then for commercial use. We try to make P2PSIP be known and accepted by people here in China. Currently, we are sponsored by the some domestic research programs. But we are looking for more cooperation opportunities with partners all over the world. 

Comments and suggestions are always welcomed.

Sincerely yours,
 
Yao Wang 
Mobile Life Lab, BUPT
Beijing, China

-----Original Message-----
From: Jan Seedorf [mailto:[email-masked]] 
Sent: Thursday, September 27, 2007 10:30 PM
To: [email-masked]
Subject: Re: [P2PSIP] Who is working on an implementation for a P2PSIPproposal?

Dear Mosiuoa and all,

Kind regards,
Jan

-----Original Message-----
From: Mosiuoa Tsietsi [mailto:[email-masked]]
Sent: Tuesday, September 25, 2007 5:05 PM
To: Adrian Georgescu
Cc: P2PSIP Mailing List
Subject: Re: [P2PSIP] Who is working on an implementation for a P2PSIPproposal?

Hi,

Mos

	
	Adrian