Subject: Re: [P2PSIP] Who is working on an implementation for a P2PSIPproposal?

From: "Peter Pan" <[email-masked]>
Date: Mon, 24 Sep 2007 20:26:09 -0700

thanks god and you for the prompt response!

in description of the p2psip wg:  "The Peer-to-Peer (P2P) Session Initiation
Protocol working group
(P2PSIP WG) is chartered to develop protocols and mechanisms for the use of
the Session Initiation Protocol (SIP) in settings where ..."

does it mean that the "protocols and mechanisms" to be developed by p2psip
wg are only for the use of sip and not for other signaling protocols like
h.323 or mgcp?

if yes, what special considerations are taken to exclude other signaling
protocols?

if no, wondering why "sip" is in the group name.... :-)

----- Original Message -----
From: "Peter Pan" <[email-masked]>
To: "Philip Matthews" <[email-masked]>; "Hannes Tschofenig"
<[email-masked]>
Cc: "P2PSIP Mailing List" <[email-masked]>
Sent: Monday, September 24, 2007 7:26 PM
Subject: Re: [P2PSIP] Who is working on an implementation for a
P2PSIPproposal?

>
> a quick question: shall p2psip be renamed to p2phip or hipsip :?
>
> ----- Original Message -----
> From: "Philip Matthews" <[email-masked]>
> To: "Hannes Tschofenig" <[email-masked]>
> Cc: "P2PSIP Mailing List" <[email-masked]>
> Sent: Monday, September 24, 2007 6:41 PM
> Subject: Re: [P2PSIP] Who is working on an implementation for a
> P2PSIPproposal?
>
>
> > On 24-Sep-07, at 18:00 , Hannes Tschofenig wrote:
> >
> > > Let's just ask the group: Who has done implementation work (or is
> > > planning todo some implementation work) with regard to a proposal
> > > discussed in this group?
> >
> > The group behind the HIP-HOP proposal has an implementation planned.
> > The approach we are taking is to write a -00 draft of an I-D
> > describing an aspect of the proposal first, and then implement the
> > result. In our opinion, there is a certain discipline that comes from
> > writing an I-D; it forces you to think more about what you are doing.
> > For example, it forces you to argue for your design choices and
> > forces you to think about the security implications of your design.
> > We plan to write an I-D before starting our implementation, and then
> > use the feedback from the implementation to revise the I-D.
> >
> > In our case, we are planning to base our implementation on an
> > existing HIP implementation, since HIP-HOP is an extension to HIP.
> > Initially, this will likely be the Ericsson HIP-for-BSD
> > implementation, though we are also investigating the OpenHIP
> > implementation and may choose to do two implementations. Both of
> > these HIP implementations are available today.
> >
> > The current HIP-HOP document describes a high-level architecture. We
> > are currently working out the details on some of the aspects of this
> > design before writing an I-D.
> >
> > - Philip
> >
> >
> > _______________________________________________
> > P2PSIP mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/p2psip
>

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: Philip Matthews <[email-masked]>
Date: Tue, 25 Sep 2007 09:22:11 -0400

From my own reading of the charter, I believe that the group is  
allowed to work on things that might also be useful to other  
protocols. The restriction is that the work must be relevant to SIP,  
and cannot just be for those other protocols.

Perhaps the chairs or ADs would care to chime in here with a  
clarifying statement.

- Philip

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 25 Sep 2007 14:54:09 -0400

<as chair>
In the creation of this work group, there was concern that if the scope was
too wide, covering too many p2p apps, we would never be done, and we would
not provide something of real value.  The scope was very deliberately
limited to SIP to respond to those concerns.

We're not prohibited from making protocols useful for things other than
creating SIP sessions, but what we do has to be relevant to create such
sessions.  It's not a straight jacket.

So I think Philip is correct.

Brian

> -----Original Message-----
> From: Philip Matthews [mailto:[email-masked]]
> Sent: Tuesday, September 25, 2007 9:22 AM
> To: Peter Pan
> Cc: P2PSIP Mailing List