Subject: [P2PSIP] more comments on draft-bryan-p2psip-reload-03

From: "Beck01, Wolfgang" <[email-masked]>
Date: Tue, 18 Mar 2008 14:20:39 +0100

a couple of random observations:

Forwarding Header Diagram in Section 4.1
- "Route List Length" should be "Destination List Length"
- "all peer-ids are of fixed length for a given overlay"; the diagram
however shows a fixed length of 16 bytes (the same in route_log_entry).
- Resource Id: the length field suggests that resource ids can have
different
lengths in one overlay. Is this correct?
- "Version" in route_log_entry. The diagram suggests a 32 bit aligned
textual version string. Is padding required?

- Is padding/alignment required between forwarding header/common
header/payload/signature?

Regards,

Wolfgang
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: "Beck01, Wolfgang" <[email-masked]>
Date: Wed, 19 Mar 2008 16:43:17 +0100

Is there a requirement that the version string in route_log_entry
can be up to 65536 byte long? Wouldn't be an 8 bit length field
enough for a textual representation of the software version?

Regards,

Wolfgang

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 19 Mar 2008 08:55:04 -0700

At Wed, 19 Mar 2008 16:43:17 +0100,
> enough for a textual representation of the software version?

Probably.

Basically, I just defined a single string type and it had
a two byte length field. I figured we could optimize later.

Best,
-Ekr