Subject: Re: [P2PSIP] Agenda for IETF-71

From: "Brian Rosen" <[email-masked]>
Date: Sat, 1 Mar 2008 10:42:08 -0500

The item "as well as good ideas from other protocols" is where such a
discussion would be held.  I believe we will have sufficient time to discuss
these ideas. 

Protocol authors who believe that their protocol should be considered
instead of the merged protocol should (immediately) request agenda time

Protocol authors who believe their protocol has ideas which should be
included in the chosen protocol and who wish to make that point now should
immediately request agenda time.

If we have specific requests, we will allocate a specific item on the agenda
for them.  In any case, we will block out a part of the agenda for general
discussion on these items.

Brian

> -----Original Message-----
> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: Friday, February 29, 2008 9:28 PM
> To: Brian Rosen; P2PSIP Mailing List
> Subject: RE: [P2PSIP] Agenda for IETF-71
> 
> > Any other items?
> 
> Yes: "Extending the (inclusive) merge of P2PSIP items from other
> authors".
> 
> I hope to write the proposal to the list early next week, so folks can
> discuss and form an opinion.
> 
> Thanks, Henry
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Brian Rosen
> Sent: Friday, February 29, 2008 4:14 PM
> To: 'P2PSIP Mailing List'
> Subject: [P2PSIP] Agenda for IETF-71
> 
> The chairs are behind with agenda, and are being lashed with great zeal
> by
> our Ads for our lack of results.
> 
> Clearly, we will have the following:
> 1. Update on the merged protocol
> 2. Discussion of HIP items, the HIPbone draft in specific, and the
> general
> "are we interested in HIP at all" discussion
> 3. Some time to explore other protocols, to see if we indeed have
> consensus,
> as well as "good ideas" to be added to whatever protocol we start with
> 4. Ted asked for some time to discuss
> draft-hardie-p2poverlay-pointers-00
> 
> Any other items?  Chairs will propose a time allocation.
> 
> Brian
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: "Brian Rosen" <[email-masked]>
Date: Sat, 1 Mar 2008 11:10:09 -0500

I have posted the following agenda to get something up on the server.  

Please consider this a work in progress; we're very much still accepting
suggestions.  

If there is a multi-author slot listed below with a "??" as item leader,
could we have a name to put into the slot please

p2psip - Friday 09:00 - 11:30 (150 minutes)

Agenda Bash        - chairs  -  5 min
Status Update      - chairs  -  5 min

Merged (Reload et. al.) protocol - ?? - 30 min
	draft-bryan-p2psip-reload-03
Open discussion of alternate protocols as alternatives to merged protocol -
20 min
Open discussion of ideas from alternate protocols to be included in
consensus protocol - 30 min
HIP discussions    - ??      - 15 min
	draft-camarillo-hip-bone-01.txt
	draft-hautakorpi-p2psip-with-hip-01.txt
Data Model        - Henning  - 15 min
Security          - ??       - 15 min
	draft-matuszewski-p2psip-security-requirements-02.txt
	draft-song-p2psip-security-eval-00
Overlay Pointers - Ted       - 15 min
  	draft-hardie-p2poverlay-pointers-00

---

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 01 Mar 2008 19:23:27 +0200

Hi Brian,

I don't understand the agenda.

What proposals are actually left after the merger?

Ciao
Hannes

---

From: "Brian Rosen" <[email-masked]>
Date: Sat, 1 Mar 2008 13:08:35 -0500

For example

draft-cirani-p2psip-dsip-dhtkademlia
draft-jiang-p2psip-sep
draft-marocco-p2psip-xpp

Just because a lot of protocols that we have spent some time on have been
merged doesn't mean we don't at least give others an opportunity to advocate
for their ideas.

If the authors don't want to ask that their protocols be considered, we'll
cut down on the agenda time.  We'll be asking for consensus calls at the
meeting (and on the list).  We want to make absolutely certain that we have
given everyone who has worked on a protocol an opportunity to advocate for
it.

Brian

> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Saturday, March 01, 2008 12:23 PM
> To: Brian Rosen
> Cc: 'P2PSIP Mailing List'
> Subject: Re: [P2PSIP] Agenda for IETF-71
> 
> Hi Brian,
>

---

From: jiangxingfeng 36340 <[email-masked]>
Date: Sat, 01 Mar 2008 13:10:24 -0500

> immediately request agenda time.

The authors of SEP(Servie Extensible Peer Protocol)(http://tools.ietf.org/wg/p2psip/draft-jiang-p2psip-sep-01.txt) believe that some features in SEP should be considered in the coming working group draft, such as, general service discovery mechanism, relaying peer concept. So we request a time slot about 10-15 minutes to present these ideas. 

> for them.  In any case, we will block out a part of the agenda for 
> generaldiscussion on these items.
> 
> Brian
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 01 Mar 2008 21:14:51 +0200

Thanks for the quick response.

My impression is that the dice is cast.

Brian Rosen wrote:
>>> Open discussion of alternate protocols as alternatives to merged
>>>       
>> protocol -
>>     
>>> 20 min

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 3 Mar 2008 10:40:53 -0800

I suggest adding three items to the agenda:

1. Including P2PP in the P2PSIP text (formerly Reload-03). We seem to go
here in circles, having claims and counterclaims about including P2PP
text that reflects the code deployed on the net.

2. Including the specifics for the client protocol and other proposals.
There are also claims and counterclaims on this. 

3. Having a new P2PSIP name (such as P2PSIP-01) and an editor who can
volunteer quality time and is neutral to these disputes. There has been
a loud silence on this item.

Could the chair please conduct this discussion?

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Brian Rosen
Sent: Saturday, March 01, 2008 8:10 AM
To: 'P2PSIP Mailing List'
Subject: Re: [P2PSIP] Agenda for IETF-71

suggestions.  

 

20 min

Security          - ??       - 15 min

P2PSIP mailing list

[email-masked]

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Mar 2008 15:15:55 -0500

Henry

You can bring up your concerns on the merge of the protocols in the Q and A
following the presentation on the merge.  We will plan some time for Q and
A.   At the moment, I'm inclined to let the authors work out issues of
wording themselves, and I don't really care too much about pre-RFC
implementations except how they inform our discussion on how various
features work and don't work.  So long as the authors take implementation
experience into account, I don't worry about pre-standard implementation
compatibility.

Clients could be an agenda item, although I’m not quite sure how we
structure agenda time on the subject.  

Editor issues will be discussed between the authors and the chairs if/when a
draft is made into a WG item.  Names are on the table for discussion.

Brian

________________________________________
From: Henry Sinnreich [mailto:[email-masked]] 
Sent: Monday, March 03, 2008 1:41 PM
To: Brian Rosen; P2PSIP Mailing List
Subject: RE: [P2PSIP] Agenda for IETF-71

1. Including P2PP in the P2PSIP text (formerly Reload-03). We seem to go
here in circles, having claims and counterclaims about including P2PP text
that reflects the code deployed on the net.

3. Having a new P2PSIP name (such as P2PSIP-01) and an editor who can
volunteer quality time and is neutral to these disputes. There has been a
loud silence on this item.

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Brian Rosen
Sent: Saturday, March 01, 2008 8:10 AM
To: 'P2PSIP Mailing List'
Subject: Re: [P2PSIP] Agenda for IETF-71

---

From: "Victor Pascual Ávila" <[email-masked]>
Date: Thu, 6 Mar 2008 16:47:33 +0100

Chairs,

On Mon, Mar 3, 2008 at 9:15 PM, Brian Rosen <[email-masked]> wrote:
>  Clients could be an agenda item, although I'm not quite sure how we

Clients could be an agenda item in order to discuss client
role/functions and complement Reload-03.
If you consider it to be an appropriate theme to talk about, we could
prepare a short presentation.

Thank you,
-- 
Victor Pascual Ávila
Research Engineer
Tel.  +34 93 542 2906
Fax. +34 93 542 2517

Research Group on Network Technologies and Strategies (NeTS)
Universitat Pompeu Fabra (UPF)
Pg. de Circumval·lació, 8
Office 358
08003 Barcelona (Spain)
http://nets.upf.edu/
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip