Subject: Re: [P2PSIP] FIND request

From: jiangxingfeng <[email-masked]>
Date: Mon, 09 Feb 2009 10:59:39 +0800

> 
> I was wondering if someone could elaborate on the use case for the FIND request.
> I am not sure what it is being used for exactly.

I think it's related to TURN server discovery procedure. 
> 
> A generic search mechanism may be implemented on top of the DHT which may have
> such indexing capabilities
> and doesn't need to be specified in the draft.

I agree. I think service discovery should be extracted from the base draft. We need a generic service discovery mechanism because p2p system is a collaborating system. 

--
Jiang XingFeng

---

From: "Das, Saumitra" <[email-masked]>
Date: Mon, 9 Feb 2009 22:57:03 -0800

It seems too specific to be in there just for the TURN server discovery in that case. There should be a general 
key-lookup based scheme that the base draft provides.

Other enhancements probably belong in a different draft that looks at enhanced service discovery building on the key lookup.

Best
Saumitra

-----Original Message-----
From: jiangxingfeng [mailto:[email-masked]] 
Sent: Sunday, February 08, 2009 7:00 PM
To: Das, Saumitra; [email-masked]
Subject: RE: [P2PSIP] FIND request

--
Jiang XingFeng

---

From: Salman Abdul Baset <[email-masked]>
Date: Tue, 10 Feb 2009 10:03:25 -0500 (EST)

FIND can be used to explore the overlay instance. It is particular useful 
when updating successor list/neighbor table.

However, there are other techniques of exploring the overlay such as 
obtaining the routing table of a node.

FIND may not be very useful in unstructured overlays.

-s

On Mon, 9 Feb 2009, Das, Saumitra wrote:

> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip
>
>

---

From: "Das, Saumitra" <[email-masked]>
Date: Tue, 10 Feb 2009 12:53:29 -0800

I am just wondering about FIND because I have not heard about it in the context of other DHTs out there such as bamboo, chord etc. Why is so special to 
the RELOAD case. I thought updating lists and neighbor tables can be done use UPDATEs

Best,
Saumitra

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, February 10, 2009 7:03 AM
To: Das, Saumitra
Cc: jiangxingfeng; [email-masked]
Subject: Re: [P2PSIP] FIND request

-s

---

From: Salman Abdul Baset <[email-masked]>
Date: Tue, 10 Feb 2009 16:00:33 -0500 (EST)

FIND is similar to find_successor() operation in Chord.
-s