Subject: [P2PSIP] flag issue in draft-zong-p2psip-drr-00

From: stéphane bryant <[email-masked]>
Date: Fri, 26 Aug 2011 17:18:36 +0200

Hello,

I am currently working on adding wireshark dissectors
for the WG drafts, and i stumbled upon an issue
in draft-zong-p2psip-drr-00:

In section section 6.2.1 (State-keeping Flag) it
defines the flag:
flag : 0x3 IGNORE-STATE-KEEPING

However, this flag enters in conflict with 2
predefined flags for the ForwardingOption structure:
FORWARD_CRITICAL(0x01), DESTINATION_CRITICAL(0x02)

(Unless there is a semantic rule linking them,
 implication or mutual exclusion).

As soon as this issue will be cleared, i will
add the dissector.

Regards,
Stephane

---

From: Roni Even <[email-masked]>
Date: Fri, 26 Aug 2011 19:59:09 +0300

Hi Stephane,

This is a good point the DRR draft should specify what is the behavior if
FORWARD_CRITICAL(0x01) or   DESTINATION_CRITICAL(0x02) also appears in the
message. I think that the right behavior is to obey the
FORWARD_CRITICAL(0x01)/ DESTINATION_CRITICAL(0x02) defined behavior.

"If the FORWARD_CRITICAL flag is set, any node that would forward the
message but does not understand this options MUST reject the request with an
error_Unsupported_Forwarding_Option error response.  If the
DESTINATION_CRITICAL flag is set, any node that generates a response to the
message but does not understand the forwarding option MUST reject the
request with an Error_Unsupported_Forwarding_Option error response."

I think that DRR should recommend that the RESPONSE_COPY flag SHOULD be set
to false while the FORWARD_CRITICAL and DESTINATION_CRITICAL SHOULD be set
to true. (This text appeared in
http://tools.ietf.org/html/draft-ietf-p2psip-base-10#page-47 

Roni Even

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of st?phane bryant
> Sent: Friday, August 26, 2011 6:19 PM
> To: [email-masked]
> Subject: [P2PSIP] flag issue in draft-zong-p2psip-drr-00
> 
> Hello,
> 
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: stéphane bryant <[email-masked]>
Date: Mon, 29 Aug 2011 20:05:34 +0200

Hi Roni,

I guess i was not too clear. What i meant is much simpler:

RESPONSE_COPY=0x03=FORWARD_CRITICAL(0x1)|DESTINATION_CRITICAL(0x2)

Is the flags member defined in ForwardingOptions in section
5.3.2.3 of the draft-ietf-p2psip-base-18 document
bit-based or value-based ? From the definitions in the base
document (0x1, 0x2, 0x4 are being used), it would seem
that it is bit-based.
In such a case, the current RESPONSE_COPY value, 0x03, is problematic.

stephane

---

From: Roni Even <[email-masked]>
Date: Mon, 29 Aug 2011 22:32:53 +0300

Hi Stephane,
Thanks, I assume that it was meant to be bit-based. 

I looked again at the document
It should be defined as 0x8. 
I also stated that we need to have the FORWARD_CRITICAL and
DESTINATION_CRITICAL set to true, but this is not requited since the node
information of the source to where the response should go is in the
forwarding option.

So we just need to change the flag to 0x8

Roni

> From: stephane bryant [mailto:[email-masked]] On Behalf
> Of st?phane bryant
> Sent: Monday, August 29, 2011 9:06 PM
> To: Roni Even
> Cc: [email-masked]; 'Ning Zong'
> Subject: Re: [P2PSIP] flag issue in draft-zong-p2psip-drr-00
> 
> Hi Roni,
>