Subject: [P2PSIP] Slight probability increase that two systems implementing RELOAD do not behave identically

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 25 Aug 2011 11:15:11 -0700

(Sorry for the convoluted title, it seems I can no longer say "Interoperability
problem")

It is about the size of i in section 6.3.4 (and d in section 8).  I remember
Cullen saying that it is 4 bytes, but it seems that the spec was never updated
to reflect that.

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 25 Aug 2011 18:06:26 -0600

On Aug 25, 2011, at 12:15 PM, Marc Petit-Huguenin wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

Uh, I think the resolution was the other way around for one and as you say for the other. Let me separate the two..

First for the size of i, in section 6.3.4. The max value of this is controlled by the max-node-multiple values with is limited in the XML grammar to xsd:int. It never shows up on the wire so I think this is defined as 4 bytes. Given the need to interate through all values up to the limit computing a hash each time, people will need to stick to small values. 

On the other one, d in section 8, I think we decided on 8 bits was enough. Back in draft-ietf-p2psip-base-13 the relax NG for turn-density defined it as and xsd:int which did not match the unit8 in for d in section 8 but we moved the XML grammar to be xsd:unsignedByte  in version 14 of the draft.  

So, I think we decided 4 bytes for the first and 1 byte for the second. I think the doc is consistent with that. Is there a part that is inconsistent where I need to update it. 

Cullen

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 26 Aug 2011 13:00:01 -0700

On 08/25/2011 05:06 PM, Cullen Jennings wrote:
>> -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
>> 
>> (Sorry for the convoluted title, it seems I can no longer say
>> "Interoperability problem")
>> 
>> It is about the size of i in section 6.3.4 (and d in section 8).  I
>> remember Cullen saying that it is 4 bytes, but it seems that the spec was
>> never updated to reflect that.
> 
> First for the size of i, in section 6.3.4. The max value of this is
> controlled by the max-node-multiple values with is limited in the XML grammar
> to xsd:int. It never shows up on the wire so I think this is defined as 4
> bytes. Given the need to interate through all values up to the limit
> computing a hash each time, people will need to stick to small values.
> 
> On the other one, d in section 8, I think we decided on 8 bits was enough.
> Back in draft-ietf-p2psip-base-13 the relax NG for turn-density defined it as
> and xsd:int which did not match the unit8 in for d in section 8 but we moved
> the XML grammar to be xsd:unsignedByte  in version 14 of the draft.
> 
> So, I think we decided 4 bytes for the first and 1 byte for the second. I
> think the doc is consistent with that. Is there a part that is inconsistent
> where I need to update it.

If you are 100% sure that no implementer will ever read the spec differently
than you did here, then the doc does not need update.

- -- 
Marc Petit-Huguenin