Subject: Re: [P2PSIP] structure definition issue in draft-zong-p2psip-drr-00

From: Roni Even <[email-masked]>
Date: Thu, 01 Sep 2011 12:20:57 +0300

Hi Stephane,
Yes you are right I thought this meant the number of elements in the
structure but now I see from the base draft that it is the length of the
structure. 
Since destination may have 1 or 2 elements I think that the following will
be enough. 

struct {
           RouteMode               routemode;
           OverlayLink             transport;
           IpAddressPort          ipaddressport;
           Destination             destination<1..2^8-1>;
   } ExtensiveRoutingModeOption

Regards
Roni

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of st?phane bryant
> Sent: Wednesday, August 31, 2011 10:46 AM
> To: [email-masked]
> Subject: [P2PSIP] structure definition issue in draft-zong-p2psip-drr-
> 00
> 
> Hello,
> 
> In draft-zong-p2psip-drr-00, section 6.2.2. Extensive Routing Mode,
> the ExtensiveRoutingModeOption structure is defined thus:
> 
>  struct {
>            RouteMode               routemode;
>            OverlayLink             transport;
>            IpAddressPort          ipaddressport;
>            Destination             destination<1..2>;
>    } ExtensiveRoutingModeOption;
> 
> however the <x..y> convention for variable length
> fields is designed to represent the length in bytes
> of the field, the range allowing to also derive
> the size of the length field. <1..2> does not work.
> My take is that it should be <0...2^16>.
> 
> I am currently adding new parsing capabilities to
> the wireshark dissector: as soon as this is defined
> i will add capabilities for this draft.
> 
> regards
> stephane bryant
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip

---

From: ZongNing <[email-masked]>
Date: Fri, 02 Sep 2011 05:43:30 +0000

Hi, Stephane and Roni
I will address this in next revision. Thank you for the discussion.

BR,
Ning Zong

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Roni Even
发送时间: 2011年9月1日 17:21
收件人: 'stéphane bryant'; [email-masked]
主题: Re: [P2PSIP] structure definition issue in draft-zong-p2psip-drr-00

Hi Stephane,

struct {
           RouteMode               routemode;
           OverlayLink             transport;

Regards
Roni