Subject: [P2PSIP] Review of draft-ietf-p2psip-service-discovery-03

From: Marc Petit-Huguenin <[email-masked]>
Date: Sat, 05 Nov 2011 11:40:28 -0700

1. Section 2

The Namespace definition uses "voice-mail" as an example of namespace, but
nowhere in the spec it is defined if it is an ASCII string or a Unicode string
and what encoding must be used when using it in RELOAD.

2. Section 4.1

The structure can be extended, but there is no type that can be used for that.
Should we use the length?

3. Section 4.4

I do not understand why the refresh period had to be configured.  Does it matter
if different nodes use different lifetime duration for the entries they store?

4. Section 6.

Shouldn't "service name" be replace by "namespace"?

5. Section 8

Probably a good idea to add the formal definition for the two elements,
something like this (in Compact Relax NG Grammar):

namespace redir = "urn:ietf:params:xml:ns:p2p:service-discovery"

parameter &= element redir:branching-factor { xsd:unsignedInt }

parameter &= element redir:refresh-period { xsd:unsignedInt }

6. Section 10

The XML namespace needs to be formally defined.

Also it will probably be a good idea to define a IANA registry for the ReDir
namespaces.

Nits
- ----

- - Section 1, 4th paragraph, and section 3, 1st paragraph

s/fetch/Fetch/

- - Section 4.1

s/structure/Resource Record/

- - Section 4.6

s/redirServiceProvider/RedirServiceProvider/

s/"nonexistent"/exists=False/

- - Section 10.2

s/kind-ID/Kind-ID/

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: Jouni Mäenpää <[email-masked]>
Date: Mon, 7 Nov 2011 13:11:03 +0100

Hi Marc,

Thanks for the comments! We will address these in the next version of the draft.

Regards,
Jouni 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Marc Petit-Huguenin
Sent: 5. marraskuuta 2011 20:40
To: P2PSIP Mailing List
Subject: [P2PSIP] Review of draft-ietf-p2psip-service-discovery-03

1. Section 2

The Namespace definition uses "voice-mail" as an example of namespace, but nowhere in the spec it is defined if it is an ASCII string or a Unicode string and what encoding must be used when using it in RELOAD.

2. Section 4.1

3. Section 4.4

I do not understand why the refresh period had to be configured.  Does it matter if different nodes use different lifetime duration for the entries they store?

4. Section 6.

5. Section 8

Probably a good idea to add the formal definition for the two elements, something like this (in Compact Relax NG Grammar):

6. Section 10

Also it will probably be a good idea to define a IANA registry for the ReDir namespaces.

Nits
- ----

s/fetch/Fetch/

- - Section 4.1

- - Section 4.6

- - Section 10.2

s/kind-ID/Kind-ID/

- --
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip