Subject: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-16.txt

From: [email-masked]
Date: Fri, 23 Jan 2015 00:09:35 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Peer-to-Peer Session Initiation Protocol Working Group of the IETF.

        Title           : P2P Overlay Diagnostics
        Authors         : Haibin Song
                          Jiang Xingfeng
                          Roni Even
                          David A. Bryan
                          Yi Sun
	Filename        : draft-ietf-p2psip-diagnostics-16.txt
	Pages           : 29
	Date            : 2015-01-23

Abstract:
   This document describes mechanisms for P2P overlay diagnostics.  It
   defines extensions to the RELOAD P2PSIP base protocol to collect
   diagnostic information, and details the protocol specifications for
   these extensions.  Useful diagnostic information for connection and
   node status monitoring is also defined.  The document also describes
   the usage scenarios and provides examples of how these methods are
   used to perform diagnostics in P2PSIP overlay networks.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-p2psip-diagnostics/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-p2psip-diagnostics-16

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-p2psip-diagnostics-16

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Roy, Radhika R CIV USARMY (US)" <[email-masked]>
Date: Fri, 23 Jan 2015 19:24:38 +0000

Hi, Song, et al:

I have one general question about the draft as follows:

1. Will these diagnostics collection by P2P RELOAD protocol as it is being
extended be good enough for P2PSIP management?

2. Does it mean that we do not need any separate P2P Management Protocol
(e.g. P2PSNMP aka like P2PSIP) for management P2PSIP network for all of its
nodes that use P2PSIP protocol?

BR/Radhika

-----Original Message-----
From: P2PSIP [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Friday, January 23, 2015 3:10 AM
To: [email-masked]
Cc: [email-masked]
Subject: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-16.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
 This draft is a work item of the Peer-to-Peer Session Initiation Protocol
Working Group of the IETF.

Abstract:

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2psip

---

From: "Songhaibin (A)" <[email-masked]>
Date: Mon, 26 Jan 2015 00:38:14 +0000

Hi Roy,

> From: P2PSIP [mailto:[email-masked]] On Behalf Of Roy, Radhika R
> CIV USARMY (US)
> Sent: Saturday, January 24, 2015 3:25 AM
> To: [email-masked]
> Subject: Re: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-16.txt
> 
> Hi, Song, et al:
> 

It is considered useful for diagnostics at this moment. There can be future extensions. It is not a full set.

> nodes that use P2PSIP protocol?

IMO P2P network management and diagnostics are two different concepts, and you can have other protocols/extensions for management.

-Haibin

---

From: "Roy, Radhika R CIV USARMY (US)" <[email-masked]>
Date: Mon, 26 Jan 2015 13:07:11 +0000

Hi, Haibin:

Great!

Yes, I also thought the same. We are looking for full management set for
P2PSIP.

We saw one proposal P2PSNMP draft some time ago. Why did that draft authors
not continue?

Or, will people create extensions one after another until the full set for
P2PSIP management available?

BR/Radhika

-----Original Message-----
From: Songhaibin (A) [mailto:[email-masked]] 
Sent: Sunday, January 25, 2015 7:38 PM
To: Roy, Radhika R CIV USARMY (US); [email-masked]
Subject: RE: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-16.txt

Hi Roy,

> From: P2PSIP [mailto:[email-masked]] On Behalf Of Roy, 
> Radhika R CIV USARMY (US)
> 1. Will these diagnostics collection by P2P RELOAD protocol as it is 
> being extended be good enough for P2PSIP management?

It is considered useful for diagnostics at this moment. There can be future
extensions. It is not a full set.

> 2. Does it mean that we do not need any separate P2P Management 
> Protocol (e.g. P2PSNMP aka like P2PSIP) for management P2PSIP network 
> for all of its nodes that use P2PSIP protocol?

IMO P2P network management and diagnostics are two different concepts, and
you can have other protocols/extensions for management.

-Haibin

directories.
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at
tools.ietf.org.

---

From: "Songhaibin (A)" <[email-masked]>
Date: Thu, 29 Jan 2015 09:29:34 +0000

Hi Radhika,

This is a management issue rather than a technical issue. 

Best Regards!
-Haibin

> From: Roy, Radhika R CIV USARMY (US) [mailto:[email-masked]]
> Sent: Monday, January 26, 2015 9:07 PM
> To: Songhaibin (A); [email-masked]

---

From: "Roy, Radhika R CIV USARMY (US)" <[email-masked]>
Date: Thu, 29 Jan 2015 12:10:09 +0000

Hi, Haibin and all members of this WG:

Right!

It is also P2P application issue. For example, MANET WG does the routing
protocols for MANETs. However, they also build the RFCs/standards for the
management standards for MANETs for each of the routing protocols they have
standardized.

In the same token, it is the P2PSIP WG shall to do the same. We also expect
to produce the RFCs/standards for the P2PSIP management standards/RFCs in
this P2PSIP WG.

If needed, we can extend our charter. Otherwise, there is be a big gap for
actual adaptation of the P2PSIP applications either using RELOAD or any
other things that this P2PSIP WG has produced or will be producing.

So, we have to proactive in developing the standards for the management of
the P2PSIP (as MANET WG does).

BR/Radhika

-----Original Message-----
From: Songhaibin (A) [mailto:[email-masked]] 
Sent: Thursday, January 29, 2015 4:30 AM
To: Roy, Radhika R CIV USARMY (US); [email-masked]
Subject: RE: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-16.txt

Hi Radhika,

Best Regards!
-Haibin

> Yes, I also thought the same. We are looking for full management set 
> for P2PSIP.
> 
> We saw one proposal P2PSNMP draft some time ago. Why did that draft 
> authors not continue?
> 
> Or, will people create extensions one after another until the full set 
> for P2PSIP management available?
> 
> BR/Radhika
> 
> > Protocol (e.g. P2PSNMP aka like P2PSIP) for management P2PSIP 
> > network for all of its nodes that use P2PSIP protocol?
> 
> IMO P2P network management and diagnostics are two different concepts, 
> and you can have other protocols/extensions for management.
> 
> -Haibin
> 
> > BR/Radhika
> >

---

From: "Roy, Radhika R CIV USARMY (US)" <[email-masked]>
Date: Thu, 29 Jan 2015 12:41:09 +0000

Let me clarify a little more on management works of MANET WG.

MANET WG has used the SNMP as the base management protocol and has developed
MIBs for all of the MANET physical routing protocols that have standardized.

In our P2PWG, we do have the same. That is, for example P2PSNMP protocol
that is used as the base protocol for management of P2PSIP protocol.

So, if there is no anything like P2P-Management Protocol, what will do for
management of the P2PSIP?

Under the umbrella of P2PSIP, we can produce P2P-IM, P2PSIP-Conferencing,
P2P-Binary Floor Control Protocol, P2P-Media Mixing/Bridging Protocol,
P2P-Other protocols that are needed for P2PSIP.

In the same token, we can produce P2PSIP-Management Protocol.

We will appreciate comments from all members of the P2PSIP WG.

BR/Radhika

-----Original Message-----
From: P2PSIP [mailto:[email-masked]] On Behalf Of Roy, Radhika R
CIV USARMY (US)
Sent: Thursday, January 29, 2015 7:10 AM
To: Songhaibin (A); [email-masked]
Subject: Re: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-16.txt

Right!

BR/Radhika

-----Original Message-----
From: Songhaibin (A) [mailto:[email-masked]]
Sent: Thursday, January 29, 2015 4:30 AM
To: Roy, Radhika R CIV USARMY (US); [email-masked]
Subject: RE: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-16.txt

Hi Radhika,

Best Regards!
-Haibin

---

From: "Songhaibin (A)" <[email-masked]>
Date: Sat, 31 Jan 2015 05:49:47 +0000

I think in the early discussion in P2PSIP WG. SNMP were not recommended for the management of p2p networks. Of course, you can extend RELOAD for more management issues, just like what has been done for the diagnostics.

Best Regards!
-Haibin

> Sent: Thursday, January 29, 2015 8:41 PM

---

From: "Roy, Radhika R CIV USARMY (US)" <[email-masked]>
Date: Sat, 31 Jan 2015 16:20:57 +0000

Hi, Haibin:

OK, it provides a direction how we can proceed with RELOAD extensions for
all other remaining functions that P2PSIP needs.

My guess is that RELOAD provides routing, security, and other
infrastructures that all the things that are needed no matter what
additional capabilities are needed. Per your suggestion, I think we can
proceed as follows:

1. Let us extend RELOAD like diagnostics for additional capabilities for
management of the P2PSIP application signaling application protocol. 

2. We may have to develop P2P-BFCP for conference floor control and see how
RELOAD that provide the basic infrastructure as stated above can be used for
this.

3. We may have to develop P2P-Media Channel Protocol for media
bridging/mixing and see how RELOAD can be used for this as stated in item 2.

4. Similarly, for others ...

Is this direction for the group?

BR/Radhika

-----Original Message-----
From: Songhaibin (A) [mailto:[email-masked]] 
Sent: Saturday, January 31, 2015 12:50 AM
To: Roy, Radhika R CIV USARMY (US); [email-masked]
Subject: RE: [P2PSIP] I-D Action: draft-ietf-p2psip-diagnostics-16.txt

I think in the early discussion in P2PSIP WG. SNMP were not recommended for
the management of p2p networks. Of course, you can extend RELOAD for more
management issues, just like what has been done for the diagnostics.

Best Regards!
-Haibin