Subject: Re: [P2PSIP] Jari Arkko's Discuss on draft-ietf-p2psip-diagnostics-19: (with DISCUSS)

From: Alissa Cooper <[email-masked]>
Date: Sat, 19 Mar 2016 04:31:16 -0700

Jari,

Are you able to clear now that these changes have been made?

Thanks,
Alissa

> On Jan 29, 2016, at 10:46 PM, Songhaibin (A) <[email-masked]> wrote:
> 
> Dear Alexey and Jari,
> 
> Accept the text what Jari suggested. And now it is clear.
> 
> BR,
> -Haibin Song
> 
>> -----Original Message-----
>> From: Alexey Melnikov [mailto:[email-masked]]
>> Sent: Thursday, January 07, 2016 6:36 PM
>> To: Jari Arkko; Songhaibin (A)
>> Cc: The IESG; [email-masked]; [email-masked];
>> [email-masked]
>> Subject: Re: [P2PSIP] Jari Arkko's Discuss on draft-ietf-p2psip-diagnostics-19:
>> (with DISCUSS)
>> 
>> Hi,
>> 
>>> On 7 Jan 2016, at 00:34, Jari Arkko <[email-masked]> wrote:
>>> 
>>> 
>>>> In Section 5.3, it says "The dMFlags field described above is a 64 bit field
>> that allows initiator nodes to identify up to 62 items of base information to
>> request in a request message (the first and last flags being reserved)." 62 bits
>> can be used to indicate up to 62 diagnostic Kinds, but dMFlags reserves all "0"s
>> that means nothing is requested, and all "1"s that means everything is
>> requested. But at the same time, the first and last bits cannot be used for
>> other purposes.
>>> 
>>> Right. Can that be explained somewhere, and can Section 9.1 show the
>>> two aspects? That is, the all 0s/1s *and* first and last bits being
>>> reserved? The current text does not reserve the first and last bits.
>>> It only reserves the all 0s and all 1s...
>> 
>> I thought the same.
>>> 
>>>   +-------------------------+------------------------------+----------+
>>>   |  diagnostic information |diagnostic flag in dMFlags    | RFC      |
>>>   |-------------------------+------------------------------+----------|
>>>   |Reserved                 | 0x 0000 0000 0000 0000
>> |RFC-[TBDX]|
>>>   |STATUS_INFO              | 0x 0000 0000 0000 0001
>> |RFC-[TBDX]|
>>>   |ROUTING_TABLE_SIZE       | 0x 0000 0000 0000 0002
>> |RFC-[TBDX]|
>>>   |PROCESS_POWER            | 0x 0000 0000 0000 0004
>> |RFC-[TBDX]|
>>>   |UPSTREAM_BANDWIDTH       | 0x 0000 0000 0000 0008
>> |RFC-[TBDX]|
>>>   |DOWNSTREAM_ BANDWIDTH    | 0x 0000 0000 0000 0010
>> |RFC-[TBDX]|
>>>   |SOFTWARE_VERSION         | 0x 0000 0000 0000 0020
>> |RFC-[TBDX]|
>>>   |MACHINE_UPTIME           | 0x 0000 0000 0000 0040
>> |RFC-[TBDX]|
>>>   |APP_UPTIME               | 0x 0000 0000 0000 0080
>> |RFC-[TBDX]|
>>>   |MEMORY_FOOTPRINT         | 0x 0000 0000 0000 0100
>> |RFC-[TBDX]|
>>>   |DATASIZE_STORED          | 0x 0000 0000 0000 0200
>> |RFC-[TBDX]|
>>>   |INSTANCES_STORED         | 0x 0000 0000 0000 0400
>> |RFC-[TBDX]|
>>>   |MESSAGES_SENT_RCVD       | 0x 0000 0000 0000 0800
>> |RFC-[TBDX]|
>>>   |EWMA_BYTES_SENT          | 0x 0000 0000 0000 1000
>> |RFC-[TBDX]|
>>>   |EWMA_BYTES_RCVD          | 0x 0000 0000 0000 2000
>> |RFC-[TBDX]|
>>>   |UNDERLAY_HOP             | 0x 0000 0000 0000 4000
>> |RFC-[TBDX]|
>>>   |BATTERY_STATUS           | 0x 0000 0000 0000 8000
>> |RFC-[TBDX]|
>>>   |Reserved                 | 0x FFFF FFFF FFFF FFFF
>> |RFC-[TBDX]|
>>>   +-------------------------+------------------------------+----+
>>> 
>>> But maybe I'm missing something.
>>> 
>>> I thought the text above should be something like this instead:
>> 
>> Exactly my point. If what Jari suggests is not true, then the text needs even
>> more work.
>>> 
>>>   +-------------------------+------------------------------+----------+
>>>   |  diagnostic information |diagnostic flag in dMFlags    | RFC      |
>>>   |-------------------------+------------------------------+----------|
>>>   |Reserved All 0s value   | 0x 0000 0000 0000 0000
>> |RFC-[TBDX]|
>>>   |Reserved First Bit    | 0x 0000 0000 0000 0001       |RFC-[TBDX]|
>>>   |STATUS_INFO              | 0x 0000 0000 0000 0002
>> |RFC-[TBDX]|
>>>   |ROUTING_TABLE_SIZE       | 0x 0000 0000 0000 0004
>> |RFC-[TBDX]|
>>>   |PROCESS_POWER            | 0x 0000 0000 0000 0008
>> |RFC-[TBDX]|
>>>   |UPSTREAM_BANDWIDTH       | 0x 0000 0000 0000 0010
>> |RFC-[TBDX]|
>>>   |DOWNSTREAM_ BANDWIDTH    | 0x 0000 0000 0000 0020
>> |RFC-[TBDX]|
>>>   |SOFTWARE_VERSION         | 0x 0000 0000 0000 0040
>> |RFC-[TBDX]|
>>>   |MACHINE_UPTIME           | 0x 0000 0000 0000 0080
>> |RFC-[TBDX]|
>>>   |APP_UPTIME               | 0x 0000 0000 0000 0100
>> |RFC-[TBDX]|
>>>   |MEMORY_FOOTPRINT         | 0x 0000 0000 0000 0200
>> |RFC-[TBDX]|
>>>   |DATASIZE_STORED          | 0x 0000 0000 0000 0400
>> |RFC-[TBDX]|
>>>   |INSTANCES_STORED         | 0x 0000 0000 0000 0800
>> |RFC-[TBDX]|
>>>   |MESSAGES_SENT_RCVD       | 0x 0000 0000 0000 1000
>> |RFC-[TBDX]|
>>>   |EWMA_BYTES_SENT          | 0x 0000 0000 0000 2000
>> |RFC-[TBDX]|
>>>   |EWMA_BYTES_RCVD          | 0x 0000 0000 0000 4000
>> |RFC-[TBDX]|
>>>   |UNDERLAY_HOP             | 0x 0000 0000 0000 8000
>> |RFC-[TBDX]|
>>>   |BATTERY_STATUS           | 0x 0000 0000 0001 0000
>> |RFC-[TBDX]|
>>>   |Reserved Last Bit              | 0x 8000 0000 0000 0000
>> |RFC-[TBDX]|
>>>   |Reserved All 1s Value       | 0x FFFF FFFF FFFF FFFF
>> |RFC-[TBDX]|
>>>   +-------------------------+------------------------------+----+
>>> 
>>>> 
>>>>> 
>>>>> Also, Section 5.3 uses "delimited" when it probably should have said
>>>>> "terminated", unless there's more substructure in the
>>>>> SOFTWARE_VERSION string than is identified by the text.
>>>> 
>>>> It is the language problem and accepted.
>>> 
>>> Thanks!
>>> 
>>> Jari
>>> 
>

---

From: Jari Arkko <[email-masked]>
Date: Sun, 20 Mar 2016 00:25:30 +0200

Alexey is correct. That’s still a bug, and one that has to be fixed.

I’ll leave it to you Alissa to shepherd this however, I have cleared.

Jari

On 19 Mar 2016, at 21:36, Alexey Melnikov <[email-masked]> wrote:

> Alissa,
> 
>> On 19 Mar 2016, at 11:31, Alissa Cooper <[email-masked]> wrote:
>> 
>> Jari,
>> 
> The draft has improved, however Section 9.1 still seems incorrect: if the first bit is reserved, then the first allocated value must be 2, so all other allocated values should be shifted by 1 bit.
> 
>> 
>> Thanks,
>> Alissa
>>

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 19 Mar 2016 19:36:15 +0000

Alissa,