Subject: [P2PSIP] [Technical Errata Reported] RFC6940 (5530)

From: RFC Errata System <[email-masked]>
Date: Mon, 15 Oct 2018 19:46:47 -0700 (PDT)

The following errata report has been submitted for RFC6940,
"REsource LOcation And Discovery (RELOAD) Base Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5530

--------------------------------------
Type: Technical
Reported by: Michael Chen <[email-masked]>

Section: 10.7.4.4

Original Text
-------------
P SHOULD then send a Ping for its own Node-ID routed through B.

Corrected Text
--------------
P SHOULD then send a Ping for its own Resource-ID n+1 routed through B.

Notes
-----
10.7.4.4 says, "repeat the discovery process used in the initial join", which refers to the 2nd paragraph after 10.5.9:

"It SHOULD send a Ping directed at Resource-ID n+1 (directly after its own Resource-ID)."

Ping Node-ID is simply wrong. This correction makes it consistent with 10.5.9. Credit goes to xramtsov in the mailing list.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6940 (draft-ietf-p2psip-base-26)
--------------------------------------
Title               : REsource LOcation And Discovery (RELOAD) Base Protocol
Publication Date    : January 2014
Author(s)           : C. Jennings, B. Lowekamp, Ed., E. Rescorla, S. Baset, H. Schulzrinne
Category            : PROPOSED STANDARD
Source              : Peer-to-Peer Session Initiation Protocol RAI
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Tue, 16 Oct 2018 09:24:17 +0200

Dear all,

> Corrected Text

this should rather read:

P SHOULD then send a Ping for Resource-ID n+1 routed through B, where n
is P's own Node-ID.

IMHO "own Resource-ID n+1" is a bit confusing, because P is not the
responsible peer for n+1. What is meant is (own Resource-ID n)+1, but
that is hard to get from the text.

Regards
 Roland

---

From: Ben Campbell <[email-masked]>
Date: Tue, 16 Oct 2018 11:41:01 -0500

Is anyone aware of interop issues or implementation errors likely caused by this?

Thanks!

Ben.

> On Oct 16, 2018, at 2:24 AM, Bless, Roland (TM) <[email-masked]> wrote:
> 
> Dear all,
> 
>> Corrected Text
>> --------------