Subject: [Pals] What should we do with draft-jiang-pwe3-mc-pon

From: Stewart Bryant <[email-masked]>
Date: Fri, 06 Mar 2015 14:29:35 +0000

The authors of http://datatracker.ietf.org/doc/draft-jiang-pwe3-mc-pon/
have asked us to start a poll for WG adoption. However before we do this
I think that we as a WG need discuss the right way forward for this draft.

In looking at the history of the draft I discover that there has been 
almost
no technical discussion on the list.

If I look back at the minutes I find:

@ IETF 90

YJS: how much is deployed with the 2:n splitters?
Ed: Bright House would probably do it. The splitter would be in house as
it solves other issues.  PON is growing, but not a great deal deployed
in NA cable.
Yuanlong: used for small cell backhaul. Can protect a bunch of small
cells.
YJS: so far interest in, but not deployed.  2:N splitter needs to resynch.
Why do we need if phy not there.
Andy: please provide comments to the list.
Matthew: readers? 4, only one commenter on the list

and @ IETF 91

Edwin presented the slides
No comments.
The call for WG adoption will be carried to the email list.
The Chairs noted interest in the meetings and on the list.

In the last remark we may have been mistaken given that  all I
can find are eight emails up to this point excluding automatic notifications
and emails from the authors asking the chairs to take an action.

In looking at the draft, the only IANA actions are in the ICC RG
parameter registry which has Expert Review or FCFS codepoint
ranges, thus there is no need for a standards track RFC or indeed
any RFC from this point of view.

In looking at the subject matter itself, I wonder whether this
is a technology where it is expected there will be multi-vendor
deployment within a PON domain requiring multi-vendor
interworking of this feature.

The IESG have recently been pushing back on the publication of
drafts that have limited support, and thus we need to be in
a position to justify moving forward with this draft on whatever
stream we decide is best.

Given the above, I would like to understand the views of the
WG on which stream is most appropriate for this work:

PALS WG - Standards Track

PALS WG - Informational

AD sponsored

Independent Stream

What are the views of the PALS WG on how we should move forward
and why?

- Stewart

---

From: Jiangyuanlong <[email-masked]>
Date: Wed, 11 Mar 2015 02:17:04 +0000

Hi Stewart,

The motive and situation is similar to ICCP, maybe the following mailing list can provide some reasons from SP’s viewpoint when that I-D was polled:
https://www.ietf.org/mail-archive/web/pwe3/current/msg10339.html

Actually, trunk protection (or Type B protection) for PON has been deployed by service providers in quite a few countries. There are also quite a few service providers interested in providing ICCP like synchronization for PON, this can be confirmed by our coauthors on the SP side.

Best regards,
Yuanlong

From: Pals [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Friday, March 06, 2015 10:30 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Pals] What should we do with draft-jiang-pwe3-mc-pon

In looking at the history of the draft I discover that there has been almost
no technical discussion on the list.

@ IETF 90

and @ IETF 91

PALS WG - Informational

AD sponsored

Independent Stream

- Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 11 Mar 2015 11:11:26 +0000

Yuanlong

I think the critical point in the thread was the express need for 
mult-vendor deployments, something that we are all used to in classical 
networks.

It would be useful to know how often multi-vendor PON is in practice 
deployed.

Stewart

On 11/03/2015 02:17, Jiangyuanlong wrote:
>
> Hi Stewart,
>
> The motive and situation is similar to ICCP, maybe the following 
> mailing list can provide some reasons from SP’s viewpoint when that 
> I-D was polled:
>
> Actually, trunk protection (or Type B protection) for PON has been 
> deployed by service providers in quite a few countries. There are also 
> quite a few service providers interested in providing ICCP like 
> synchronization for PON, this can be confirmed by our coauthors on the 
> SP side.
>
> Best regards,
>
> Yuanlong
>
> *From:*Pals [mailto:[email-masked]] *On Behalf Of *Stewart Bryant
> *Sent:* Friday, March 06, 2015 10:30 PM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* [Pals] What should we do with draft-jiang-pwe3-mc-pon
>
>
> The authors of 
> http://datatracker.ietf.org/doc/draft-jiang-pwe3-mc-pon/ 
> <http://datatracker.ietf.org/doc/draft-jiang-pwe3-mc-pon/>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Hongyu Li (Julio)" <[email-masked]>
Date: Wed, 11 Mar 2015 12:31:38 +0000

With my knowledge in PON and Access Network, Type-B protection is the most typical protection method in PON deployment and is the most cost-effective one. As PON technology is providing bandwidth up to 10 Gbps, it can be applied to more scenarios than ever. ITU-T has left a big hole for type-B to be deployed at large without defining the method of sync between two OLT devices. Obviously, IETF is in a much better position to fill the gap by enhancing ICCP.

Fully support this draft moving forward.

Hongyu

@ IETF 90

and @ IETF 91

PALS WG - Informational

AD sponsored

Independent Stream

- Stewart

---

From: Edwin Mallette <[email-masked]>
Date: Wed, 11 Mar 2015 09:54:24 -0400

To add my two cents, IEEE 1904.1 addressed specific layer2 messaging to
enable PON protection for EPON access networks for both tree protection and
trunk protection.  I agree with Hongyu that trunk protection (Type B) is the
most typical protection method in PON deployment.  Similar to the ITU-T,
IEEE1904.1 left a hole for trunk protection as the inter-system sync method
was not defined and was determined to be out of scope of the project.  This
was left to other SDOs/future projects to address.

And to respond to Stewarts question about multiple vendors in the PON space,
we (as an network operator) currently have three different vendors EPON OLTs
deployed and in production.  One goal of IEEE1904.1 was to enable
interoperability and we have had quite a bit of success there.

Regards.

Ed

From:  "Hongyu Li (Julio)" <[email-masked]>
Date:  Wednesday, March 11, 2015 at 8:31 AM
To:  "[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Cc:  "[email-masked]"
<[email-masked]>
Subject:  Re: [Pals] What should we do with draft-jiang-pwe3-mc-pon

With my knowledge in PON and Access Network, Type-B protection is the most
typical protection method in PON deployment and is the most cost-effective
one. As PON technology is providing bandwidth up to 10 Gbps, it can be
applied to more scenarios than ever. ITU-T has left a big hole for type-B to
be deployed at large without defining the method of sync between two OLT
devices. Obviously, IETF is in a much better position to fill the gap by
enhancing ICCP. 

Hongyu

@ IETF 90

and @ IETF 91

PALS WG - Informational

AD sponsored

Independent Stream

- Stewart
_______________________________________________ Pals mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/pals

---

From: Jiangyuanlong <[email-masked]>
Date: Thu, 12 Mar 2015 02:40:12 +0000

Access nodes (OLT is only one type of implementation) are specified in BBF TR178, they are not something different from network equipments in classical networks (both MPLS and routing are already included in the architecture of TR178).
Many service providers and vendors have taken part in its development, as I am aware they have shown great interest in the interoperability for those access nodes.

Thanks,
Yuanlong

From: Stewart Bryant [mailto:[email-masked]]
Sent: Wednesday, March 11, 2015 7:11 PM
To: Jiangyuanlong; [email-masked]
Cc: [email-masked]
Subject: Re: [Pals] What should we do with draft-jiang-pwe3-mc-pon

Yuanlong

I think the critical point in the thread was the express need for mult-vendor deployments, something that we are all used to in classical networks.

It would be useful to know how often multi-vendor PON is in practice deployed.

Stewart

Best regards,
Yuanlong

From: Pals [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Friday, March 06, 2015 10:30 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Pals] What should we do with draft-jiang-pwe3-mc-pon

@ IETF 90

and @ IETF 91

PALS WG - Informational

AD sponsored

Independent Stream

- Stewart

--

---

From: shencb <[email-masked]>
Date: Thu, 12 Mar 2015 11:27:31 +0800

hi, everyone,
     in my opinion, for some large operators, if they deploy PON protection to provide good access network availability for business customers, MBH, and some special application such as surveilunce, the ICCP will be very benifitting. for China Telecom, We have deployed a great number of PON equipments, in some scenarios, we use trunk protection for business application. besides, we are trialing the MBH over PON as well as promoting the Broadband project SD-331 "Architecture and Technical Requirements for PON-Based Mobile Backhaul Networks", so an interoperable solution is attractive to us.
     the idea to push interoperability on it should be supposed as prefered. of course, other operators' point of view should be welcomed and discuss it further.
     Best Regards!
                                                             Shen Chengbin from China Telecom

沈成彬 主任
博士，教授级高工
中国电信股份有限公司上海研究院 基础网络部 
地       址：上海市浦东新区浦东南路1835号
邮       编：200122
电       话：021-28970176
手       机：18918588789
电子邮箱：[email-masked]

Champion(Chengbin) Shen Director
Ph.D, Senior Engineer (Professor Grade)
Dept. of Infrastructure Networks
Shanghai Research Institute of China Telecom Corp. Ltd.
Add: 1835 South Pudong Road, Shanghai, 200122, China
Tel : +86 21 28970176
Mobile: +86 18918588789
E-mail: [email-masked]
 
From: Stewart Bryant
Date: 2015-03-11 19:11
To: Jiangyuanlong; [email-masked]
CC: [email-masked]
Subject: Re: [Pals] What should we do with draft-jiang-pwe3-mc-pon
Yuanlong

Stewart

 
 
Best regards,
Yuanlong

@ IETF 90

and @ IETF 91

PALS WG - Informational

AD sponsored

Independent Stream

- Stewart

---

From: Mingui Zhang <[email-masked]>
Date: Mon, 16 Mar 2015 02:40:10 +0000

Hi Stewart,

If there are practical scenarios for multivendor-PON protection, it would be beneficial to progress it as a new application of ICCP. 
Since the code-points to be assigned are in the ranges of Expert Review or FCFS in the ICC RG parameter registry, I think it indicates the PALS WG - informational stream is appropriate.

Thanks,
Mingui

>-----Original Message-----

---

From: zhouguangtao <[email-masked]>
Date: Mon, 16 Mar 2015 12:49:45 +0800

如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

Subject: Re: Re: [Pals] What should we do with draft-jiang-pwe3-mc-pon
From: zhouguangtao <[email-masked]>
To: "Mingui Zhang" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Date: Mon, 16 Mar 2015 12:49:45 +0800

Hi Stewart,

We have purchased and constructed ONUs and OLTs separately from multiple vendors. IT is necessary to consider Type-B PON protection and enable their interoperability. 

Thanks,
Guangtao  Zhou
Senior Engineer 
Network Technology Research Institute of China Unicom 

From: Mingui Zhang
Date: 2015-03-16 10:40
To: [email-masked]; [email-masked]
CC: [email-masked]
Subject: Re: [Pals] What should we do with draft-jiang-pwe3-mc-pon
Hi Stewart,

Thanks,
Mingui

>What are the views of the PALS WG on how we should move forward

_______________________________________________
Pals mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pals
如果您错误接收了该邮件，请通过电子邮件立即通知我们。[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。
If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] if you want to unsubscribe from this mail. We will immediately remove your information from our sending catalogue.

---

From: Puyun <[email-masked]>
Date: Tue, 17 Mar 2015 06:38:46 +0000

Agree

Regards.

Jack PU

From: Pals [mailto:[email-masked]] Edwin Mallette
Date:  Wednesday, March 11, 2015 at 21:54
To:  Hongyu Li (Julio); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Pals] What should we do with draft-jiang-pwe3-mc-pon

To add my two cents, IEEE 1904.1 addressed specific layer2 messaging to enable PON protection for EPON access networks for both tree protection and trunk protection.  I agree with Hongyu that trunk protection (Type B) is the most typical protection method in PON deployment.  Similar to the ITU-T, IEEE1904.1 left a hole for trunk protection as the inter-system sync method was not defined and was determined to be out of scope of the project.  This was left to other SDOs/future projects to address.

And to respond to Stewarts question about multiple vendors in the PON space, we (as an network operator) currently have three different vendors EPON OLTs deployed and in production.  One goal of IEEE1904.1 was to enable interoperability and we have had quite a bit of success there.

Regards.

Ed

From: "Hongyu Li (Julio)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 11, 2015 at 8:31 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Pals] What should we do with draft-jiang-pwe3-mc-pon

Hongyu

@ IETF 90

and @ IETF 91

PALS WG - Informational

AD sponsored

Independent Stream

- Stewart
_______________________________________________ Pals mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/pals

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 17 Mar 2015 06:54:54 +0000

Hi Stewart,

An interoperable approach for PON protection may be helpful for the PON deployment in various network scenarios. The codepoints allocated by IANA may refer this document for background information.

Best regards,
Jie

@ IETF 90

and @ IETF 91

PALS WG - Informational

AD sponsored

Independent Stream

- Stewart

---

From: "weiqiang cheng" <[email-masked]>
Date: Tue, 17 Mar 2015 15:02:06 +0800

Agree, the draft is useful.

B.R.

Weiqiang Cheng

From: Pals [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
Sent: Tuesday, March 17, 2015 2:55 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Pals] What should we do with draft-jiang-pwe3-mc-pon

Hi Stewart, 

Best regards,

Jie

@ IETF 90

and @ IETF 91

PALS WG - Informational

AD sponsored

Independent Stream

- Stewart