Subject: [Pals] Stephen Farrell's No Objection on draft-ietf-pals-endpoint-fast-protection-04: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Wed, 14 Dec 2016 17:13:39 -0800

Stephen Farrell has entered the following ballot position for
draft-ietf-pals-endpoint-fast-protection-04: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pals-endpoint-fast-protection/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- section 5: I'm not sure "revertive" is a useful term
here. Seems to me that it's a) admirably obscure, b) maybe
inaccurate, as we're not reverting to a previous state
here but rather changing paths, and maybe c) it's not
clear if we end up with a "fully functional" path after
"reverting." But maybe it's an accepted term of art in
routing - if so, some reference to where it's well
described might be nice.

- section 8, para 1: this assumes that "managed by network
operator" means "is secure." I think we have examples
where not all that happens within a network is under the
control of the owner of the network, so I question that
assumption. (I'm not now asking for a concrete change as
that'd be a major bit of work, but I am as willing as ever
to continue to call this out as it appears;-) If you could
remove text based on that assumption, that'd improve the
document I think.

---

From: Yimin Shen <[email-masked]>
Date: Fri, 16 Dec 2016 20:42:31 +0000

Hi Stephen,

Thanks very much for your review and valuable comments. Please see my answers inline…

-- Yimin

On 12/14/16, 8:13 PM, "Pals on behalf of Stephen Farrell" <[email-masked] on behalf of [email-masked]> wrote:

    
[yshen] We can rename the section to “Restorative and revertive behaviors”, and rename the 3 bullets to “Global repair”, “Control plane convergence”, and “Local reversion”, which may be more commonly used terms and easier to understand. We will also modify the text accordingly.

[yshen] We can remove “the role of protector is entirely managed by network operator”, and say something like “In all scenarios, PLRs, protectors and backup PEs are devices within a network, …” (That is, the mechanism doesn’t introduce any new flow or any risk from external devices).    

    _______________________________________________
    Pals mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/pals