Subject: [Pals] Alia Atlas' Yes on draft-ietf-pals-endpoint-fast-protection-04: (with COMMENT)

From: "Alia Atlas" <[email-masked]>
Date: Wed, 14 Dec 2016 09:38:25 -0800

Alia Atlas has entered the following ballot position for
draft-ietf-pals-endpoint-fast-protection-04: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pals-endpoint-fast-protection/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Minor:

1) The details in Figure 11 on p. 22 don't look quite right.    There is
no forwarding state shown on PE4 to handle the incoming labels of 2000
(P3's outgoing label of bypass tunnel to PE4) or 3000 (P2's outgoing
label of bypass tunnel to PE4).    Either there should be additional
forwarding state on PE4 that says to pop 2000 (or 3000) and identify a
context label space - or PE4 should have allocated the context label 999
to the bypass tunnels from P3 and PE2.

I see the same issue in Figures 12, 13, and 14.   Is there  a detail or
explanation missing?

---

From: Yimin Shen <[email-masked]>
Date: Fri, 16 Dec 2016 21:13:29 +0000

Hi Alia,

Thanks very much for the detailed review (for those examples) and comments. Please see my clarification below, using Figure-11.

There are two bypass tunnels. One goes from P3 – P4 – PE4. So, P3 pushes label 2000, and P4 swaps it to the context label 999. (PE4 has bound label 999 to the bypass tunnel).

Likewise, the other bypass tunnel goes from PE2 – P5 – PE4. So, PE2 pushes label 3000, and P5 swaps it to the context label 999. (PE4 has bound label 999 to this bypass tunnel as well).

I will add forwarding state detail of P4 and P5 to the document, like below.

          |<-------------- PW1 --------------->|

      - PE1 -------------- P1 ------- P3 --------- PE2 ------
     /                                             PLR \         PLR        \
    /                                                         \        |             \
   /                                                            \      |                \
CE1                                            bypass P4   P5 bypass   CE2
   \                                                                \   |              /
    \                                                                \  |           /
     \                                                                \ |        /
      - PE3 -------------- P2 ---------------- PE4 ------
                                            protector

          |<-------------- PW2 --------------->|

	 PW1's label assigned by PE2: 100
	 PW2's label assigned by PE4: 200
	 On P3: </t>
	     Incoming label of transport tunnel to PE2: 1000
	     Outgoing label of transport tunnel to PE2: implicit null
	     Outgoing label of bypass tunnel to PE4: 2000
	 On PE2:
	     Outgoing label of bypass tunnel to PE4: 3000
	 On PE4:
	     Context label (incoming label of bypass tunnels): 999 <<<<<<<<<< Notice this
	 
	 Forwarding state on P3:
	 label 1000 -- primary nexthop: pop, to PE2
	                         backup nexthop:  swap 2000, to P4

	 Forwarding state on PE2:
	 label 100 -- primary nexthop: pop, to CE2
	                       backup nexthop:  push 3000, to P5

	 Forwarding state on P4:  <<<<<<<<<<<<<<<<< Will add 
	 label 2000 -- nexthop: swap to 999, to PE4 <<<<<<<<<<<<<<<<< Will add

	 Forwarding state on P5: <<<<<<<<<<<<<<<< Will add
	 label 3000 -- nexthop: swap to 999, to PE4 <<<<<<<<<<<<<<<< Will add

	 Forwarding state on PE4:
	 label 200 -- nexthop: pop, to CE2
	 label 999 -- nexthop: label table of PE2's label space <<<<<<<<<<<<<< This is the context label, which is also the in-coming label of both bypass tunnels.

Thanks,

-- Yimin

On 12/14/16, 12:38 PM, "Alia Atlas" <[email-masked]> wrote:

    
    
    Minor: