Subject: Re: [Pals] PALS Working Group last call for draft-ietf-pals-p2mp-pw-lsp-ping-01

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 14 Apr 2017 07:51:21 -0400

This ends the WG last call for draft-ietf-pals-p2mp-pw-lsp-ping. Authors,
please respond to Greg’s comments.

Thanks,
Andy

On Wed, Mar 15, 2017 at 11:00 AM, Andrew G. Malis <[email-masked]> wrote:

> Having heard from all of the authors regarding IPR, this starts the WG
> last call for https://tools.ietf.org/html/draft-
> ietf-pals-p2mp-pw-lsp-ping-01 . Because it’s over IETF week, this last
> call will last for three weeks, ending on April 5. Please review the
> draft and send all comments to [email-masked].
>
> Thanks,
> Andy
>
>

---

From: "Parag Jain (paragj)" <[email-masked]>
Date: Wed, 19 Apr 2017 16:45:11 +0000

Hi Greg,

Thanks for your comments. Please see inline.

On Mar 15, 2017, at 11:57 AM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Dear Authors,
please find my WG LC comments below:

  *   per RFC 5586 GAL can be used to identify OAM payload but it is not necessary for PW. We can use PW ACH per RFC 4385 without putting GAL in;

pj> yes, both the options can be supported - GAL label as well as PW ACH. Will update the draft to add PW ACH.

  *   it is not clear what "IP ACH Channel header" is. Is it IP ACH Channel type? But MPLS G-ACh Types registry<http://www.iana.org/assignments/g-ach-parameters/g-ach-parameters.xhtml#mpls-g-ach-types> doesn't have IP ACH type but IPv4 (0x0021) and IPv6 (0x0057) types.

pj> You are right, by IP ACH channel type we mean both ipv4 and ipv6 ACH. Will update the draft.

Thanks
Parag

Regards,
Greg

On Wed, Mar 15, 2017 at 8:00 AM, Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:
Having heard from all of the authors regarding IPR, this starts the WG last call for https://tools.ietf.org/html/draft-ietf-pals-p2mp-pw-lsp-ping-01 . Because it’s over IETF week, this last call will last for three weeks, ending on April 5. Please review the draft and send all comments to [email-masked]<mailto:[email-masked]>.

Thanks,
Andy

_______________________________________________
Pals mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pals

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 24 Apr 2017 23:22:30 -0700

Hi Parag,
thank you for your thoughtful consideration of my comments. I've checked
the update and have found all my comments being addressed.

Regards,
Greg

On Wed, Apr 19, 2017 at 9:45 AM, Parag Jain (paragj) <[email-masked]>
wrote:

> On Mar 15, 2017, at 11:57 AM, Greg Mirsky <[email-masked]> wrote:
>
> Dear Authors,
>    - per RFC 5586 GAL can be used to identify OAM payload but it is not
>    necessary for PW. We can use PW ACH per RFC 4385 without putting GAL in;
>
>    - it is not clear what "IP ACH Channel header" is. Is it IP ACH
>    Channel type? But MPLS G-ACh Types registry
>    <http://www.iana.org/assignments/g-ach-parameters/g-ach-parameters.xhtml#mpls-g-ach-types> doesn't
>    have IP ACH type but IPv4 (0x0021) and IPv6 (0x0057) types.
>
> On Wed, Mar 15, 2017 at 8:00 AM, Andrew G. Malis <[email-masked]>
> wrote:
>
>> last call for https://tools.ietf.org/html/draft-ietf-
>> pals-p2mp-pw-lsp-ping-01 . Because it’s over IETF week, this last call
>>  will last for three weeks, ending on April 5. Please review the draft
>> and send all comments to [email-masked].
>>
>> Thanks,
>> Andy
>>
>>
>> [email-masked]

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 25 Apr 2017 09:46:29 -0400

Parag and Greg,

I’ve just reviewed the update, and it looks good except for one thing - now
that there are two options for encapsulation, to ensure interoperability,
we need to choose at least one (or both) as a MUST for implementation. I
would propose at least the GAL Label encapsulation as a MUST, and I prefer
that both be required (but I won’t insist if you don’t agree).

So we need to add a sentence to section 5 along the lines of “To ensure
interoperability, implementations of this document MUST support the GAL
Label encapsulation.” Or “To ensure interoperability, implementations of
this document MUST support both encapsulations.”

Thanks,
Andy

On Tue, Apr 25, 2017 at 2:22 AM, Greg Mirsky <[email-masked]> wrote:

>>> last call for https://tools.ietf.org/html/draft-ietf-pals
>>> -p2mp-pw-lsp-ping-01 . Because it’s over IETF week, this last call will
>>> last for three weeks, ending on April 5. Please review the draft and
>>> send all comments to [email-masked].
>>>
>>> Thanks,
>>> Andy
>>>
>>>

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 25 Apr 2017 07:03:28 -0700

Hi Andy,
indeed, the interoperability is the new issue after we've introduced two
options. For PW I'd consider use of PW ACH as MUST and GAL as SHOULD. But
MUST for both makes sense as well.

Regards,
Greg

On Tue, Apr 25, 2017 at 6:46 AM, Andrew G. Malis <[email-masked]> wrote:

> Parag and Greg,
>
> I’ve just reviewed the update, and it looks good except for one thing -
> now that there are two options for encapsulation, to ensure
> interoperability, we need to choose at least one (or both) as a MUST for
> implementation. I would propose at least the GAL Label encapsulation as a
> MUST, and I prefer that both be required (but I won’t insist if you don’t
> agree).
>
>>> pj> yes, both the options can be supported - GAL label as well as PW
>>> ACH. Will update the draft to add PW ACH.
>>>
>>>
>>>> -p2mp-pw-lsp-ping-01 . Because it’s over IETF week, this last call

---

From: "Parag Jain (paragj)" <[email-masked]>
Date: Tue, 25 Apr 2017 17:07:14 +0000

Hi Greg and Andy

Sami and I prefer to go with “MUST for both”. I’ll update the draft and submit a new version.

Thanks
Parag

From: Greg Mirsky <[email-masked]>
Date: Tuesday, April 25, 2017 at 10:03 AM
To: "Andrew G. Malis" <[email-masked]>
Cc: "Parag Jain (paragj)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Pals] PALS Working Group last call for draft-ietf-pals-p2mp-pw-lsp-ping-01

Hi Andy,
indeed, the interoperability is the new issue after we've introduced two options. For PW I'd consider use of PW ACH as MUST and GAL as SHOULD. But MUST for both makes sense as well.

Regards,
Greg

On Tue, Apr 25, 2017 at 6:46 AM, Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:
Parag and Greg,

I’ve just reviewed the update, and it looks good except for one thing - now that there are two options for encapsulation, to ensure interoperability, we need to choose at least one (or both) as a MUST for implementation. I would propose at least the GAL Label encapsulation as a MUST, and I prefer that both be required (but I won’t insist if you don’t agree).

So we need to add a sentence to section 5 along the lines of “To ensure interoperability, implementations of this document MUST support the GAL Label encapsulation.” Or “To ensure interoperability, implementations of this document MUST support both encapsulations.”

Thanks,
Andy

On Tue, Apr 25, 2017 at 2:22 AM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
Hi Parag,
thank you for your thoughtful consideration of my comments. I've checked the update and have found all my comments being addressed.

Regards,
Greg

On Wed, Apr 19, 2017 at 9:45 AM, Parag Jain (paragj) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

Dear Authors,

Thanks
Parag

Regards,
Greg

Thanks,
Andy

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 25 Apr 2017 14:31:18 -0400

Parag,

Thanks!

Cheers,
Andy

On Tue, Apr 25, 2017 at 1:07 PM, Parag Jain (paragj) <[email-masked]>
wrote:

> *From: *Greg Mirsky <[email-masked]>
> *Date: *Tuesday, April 25, 2017 at 10:03 AM
> *To: *"Andrew G. Malis" <[email-masked]>
> *Cc: *"Parag Jain (paragj)" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [Pals] PALS Working Group last call for
> draft-ietf-pals-p2mp-pw-lsp-ping-01
>
>
>
> Hi Andy,
>

---

From: "Parag Jain (paragj)" <[email-masked]>
Date: Wed, 26 Apr 2017 13:20:46 +0000

Hi Andy

Thanks for your and Greg’s comments. I submitted a new version of the draft yesterday.

Thanks
Parag

From: "Andrew G. Malis" <[email-masked]>
Date: Tuesday, April 25, 2017 at 2:31 PM
To: "Parag Jain (paragj)" <[email-masked]>
Cc: Greg Mirsky <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Sami Boutros <[email-masked]>
Subject: Re: [Pals] PALS Working Group last call for draft-ietf-pals-p2mp-pw-lsp-ping-01

Parag,

Thanks!

Cheers,
Andy

On Tue, Apr 25, 2017 at 1:07 PM, Parag Jain (paragj) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg and Andy

Thanks
Parag

From: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 25, 2017 at 10:03 AM
To: "Andrew G. Malis" <[email-masked]<mailto:[email-masked]>>
Cc: "Parag Jain (paragj)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Pals] PALS Working Group last call for draft-ietf-pals-p2mp-pw-lsp-ping-01

Hi Andy,

Regards,
Greg

Thanks,
Andy

Regards,
Greg

Dear Authors,

Thanks
Parag

Regards,
Greg

Thanks,
Andy