Subject: [Pals] [Technical Errata Reported] RFC8077 (5243)

From: RFC Errata System <[email-masked]>
Date: Wed, 24 Jan 2018 22:53:27 -0800 (PST)

The following errata report has been submitted for RFC8077,
"Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5243

--------------------------------------
Type: Technical
Reported by: JAYANT BHARDWAJ <[email-masked]>

Section: 6.1

Original Text
-------------
-  Group ID

      An arbitrary 32-bit value that represents a group of PWs that is
      used to create groups in the PW space.  The Group ID is intended
      to be used as a port index or a virtual tunnel index.  To simplify
      configuration, a particular PW Group ID at ingress could be part
      of a Group ID assigned to the virtual tunnel for transport to the
      egress router.  The Group ID is very useful for sending wildcard
      label withdrawals or PW wildcard status Notification messages to
      remote PEs upon physical port failure.

Corrected Text
--------------
-  Group ID
 
      An arbitrary 32-bit value that represents a group of PWs that is
      used to create groups in the PW space.  The Group ID is intended
      to be used as a port index or a virtual tunnel index.  To simplify
      configuration, a particular PW Group ID at ingress could be part
      of a Group ID assigned to the virtual tunnel for transport to the
      egress router.  The Group ID is very useful for sending wildcard
      label withdrawals or PW wildcard status Notification messages to
      remote PEs upon physical port failure or transport tunnel failure.

Notes
-----
The PW group can be created on basis of the transport tunnel index.

So  Group Id can be used to send PW wildcard status notification to remote PEs on physical port failure or Transport tunnel failure.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8077 (draft-ietf-pals-rfc4447bis-05)
--------------------------------------
Title               : Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)
Publication Date    : February 2017
Author(s)           : L. Martini, Ed., G. Heron, Ed.
Category            : INTERNET STANDARD
Source              : Pseudowire And LDP-enabled Services
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 25 Jan 2018 12:47:09 +0000

Whilst the statement is correct, I interpret the sentence as providing 
an example rather than a definitive list. Thus the proposed errata is 
simply providing another use example. There will be no interworking 
issues  or functional issues with the original text.

Looking at the errata acceptance criteria 
https://www.ietf.org/iesg/statement/errata-processing.html I don't think 
it makes the grade beyond hold for document update, but since I very 
much doubt that this RFC will be revised in the foreseeable future I 
would be inclined to reject it.

- Stewart

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 25 Jan 2018 13:08:04 +0000

Hi all,
I concur with Stewart. I do not see this as a Technical erratum because it cannot cause any interoperability issues.
After re-classifying it as Editorial, it can be hold until RFC update or rejected out of hand - with little (if any) practical difference between these two options.

My 2c,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

-----Original Message-----
From: Pals [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Thursday, January 25, 2018 2:47 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Pals] [Technical Errata Reported] RFC8077 (5243)

Whilst the statement is correct, I interpret the sentence as providing an example rather than a definitive list. Thus the proposed errata is simply providing another use example. There will be no interworking issues  or functional issues with the original text.

Looking at the errata acceptance criteria https://www.ietf.org/iesg/statement/errata-processing.html I don't think it makes the grade beyond hold for document update, but since I very much doubt that this RFC will be revised in the foreseeable future I would be inclined to reject it.

- Stewart

On 25/01/2018 06:53, RFC Errata System wrote:
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party can log in to change 
> the status and edit the report, if necessary.
>

_______________________________________________
Pals mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pals

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Eric Gray <[email-masked]>
Date: Fri, 26 Jan 2018 09:21:28 +0000

It is not clear to me that it will be possible to detect a tunnel failure, at any point in the corresponding tunnel LSP other than tunnel end points, except as a result of a physical port failure.

--
Eric

-----Original Message-----
From: Pals [mailto:[email-masked]] On Behalf Of RFC Errata System
Sent: Thursday, January 25, 2018 1:53 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Pals] [Technical Errata Reported] RFC8077 (5243)

The following errata report has been submitted for RFC8077, "Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)".

Section: 6.1

Original Text
-------------
-  Group ID

Corrected Text
--------------
-  Group ID

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary.