Subject: Re: [Pals] New Version Notification for draft-ietf-pals-ethernet-cw-02.txt

From: Stewart Bryant <[email-masked]>
Date: Wed, 28 Feb 2018 11:19:51 +0000

All,

Hopefully this is now correct :)

I think think that this now incorporates all the feedback I have 
received. If I have missed anything or anyone has any further comment, I 
still have time for one more spin before IETF.

If you look at the recommendation text you will see that I changed it a 
little to allow both method if necessary. It is not explained in the 
text, but I think that there is a MS-PW corner case where the edge 
segments cannot do EL but can do FAT, whilst the core segments cannot 
see far enough into the stack to do FAT. The only circumstance where I 
think that this can happen is where SR is used in the core. However 
rather than explain the detail, I have said both can be used if 
"circumstances" require. As I write this I wonder if I need to explain 
that the implementer SHOULD/MUST get the EL value from the FAT value 
otherwise we are right back where we started. It seems obvious to me 
that that is how you would do it, but...

At IETF I would like to get agreement that this is ready to hand to 
Matthew to get him to run WG Last Call.

Best Regards

Stewart

On 28/02/2018 11:03, [email-masked] wrote:
> A new version of I-D, draft-ietf-pals-ethernet-cw-02.txt
> has been successfully submitted by Stewart Bryant and posted to the
> IETF repository.
>
> Name:		draft-ietf-pals-ethernet-cw
> Revision:	02
> Title:		Use of Ethernet Control Word RECOMMENDED
> Document date:	2018-02-28
> Group:		pals
> Pages:		8
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-pals-ethernet-cw-02.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-pals-ethernet-cw/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-pals-ethernet-cw-02
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-pals-ethernet-cw-02
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-pals-ethernet-cw-02
>
> Abstract:
>     The pseudowire (PW) encapsulation of Ethernet, as defined in RFC4448,
>     specifies that the use of the control word (CW) is optional.  In the
>     absence of the CW an Ethernet pseudowire packet can be misidentified
>     as an IP packet by a label switching router (LSR).  This in turn may
>     lead to the selection of the wrong equal-cost-multi-path (ECMP) path
>     for the packet, leading in turn to the misordering of packets.  This
>     problem has become more serious due to the deployment of equipment
>     with Ethernet MAC addresses that start with 0x4 or 0x6.  The use of
>     the Ethernet PW CW addresses this problem.  This document recommends
>     the use of the Ethernet pseudowire control word in all but
>     exceptional circumstances.
>
>     This document updates RFC4448.
>
>                                                                                    
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 28 Feb 2018 12:30:02 +0000

Stewart,
I've looked up the -02 version of the draft and I have one comment and one question.

These comments deal with the last sentence in Section 4 that says: "In the case of multi-segment PWs, if ELI is used then it should be used on every segment of the PW."

My question is about the use of "should" in this statement. In this form it does not represent any level of requirement - is this indeed the intention? 

My comment is that, to the best of my understanding, there is no way for the ingress PE to know that all intended PW segments support EL/ELI and no way to force usage of EL/ELI on each segment even if each segment supports EL/ELI. Maybe you could add that the method by which usage of ELI/EL on every segment is guaranteed is out of scope of this document (or something like that).

With these points in mind I think that it is indeed time to move forward with this draft.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

-----Original Message-----
From: Pals [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Wednesday, February 28, 2018 1:20 PM
To: [email-masked]
Subject: Re: [Pals] New Version Notification for draft-ietf-pals-ethernet-cw-02.txt

All,

I think think that this now incorporates all the feedback I have received. If I have missed anything or anyone has any further comment, I still have time for one more spin before IETF.

If you look at the recommendation text you will see that I changed it a little to allow both method if necessary. It is not explained in the text, but I think that there is a MS-PW corner case where the edge segments cannot do EL but can do FAT, whilst the core segments cannot see far enough into the stack to do FAT. The only circumstance where I think that this can happen is where SR is used in the core. However rather than explain the detail, I have said both can be used if "circumstances" require. As I write this I wonder if I need to explain that the implementer SHOULD/MUST get the EL value from the FAT value otherwise we are right back where we started. It seems obvious to me that that is how you would do it, but...

At IETF I would like to get agreement that this is ready to hand to Matthew to get him to run WG Last Call.

Best Regards

Stewart

On 28/02/2018 11:03, [email-masked] wrote:
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>

_______________________________________________
Pals mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pals

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 28 Feb 2018 14:30:16 +0000

Hi Sasha

I have added your very own words to  -03.

"In the case of multi-segment PWs, if ELI/EL is used then it should be
used on every segment of the PW. The method by which usage of ELI/EL on
every segment is guaranteed is out of scope of this document."

I will wait to see if anyone else has any further comments and if not 
upload before IETF.

- Stewart

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 28 Feb 2018 16:50:49 +0000

Stewart,
Looks OK to me.

Thumb typed by Sasha Vainshtein

________________________________
From: Stewart Bryant <[email-masked]>
Sent: Wednesday, February 28, 2018 4:30:16 PM
To: Alexander Vainshtein
Cc: [email-masked]; [email-masked]
Subject: Re: [Pals] New Version Notification for draft-ietf-pals-ethernet-cw-02.txt

Hi Sasha

- Stewart