Subject: Re: [Pals] [bess] CW in EVPN: Was Signaling Control Word in EVPN

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 23 Oct 2018 08:27:53 +0000

James,

I am adding PALS WG to the list of addressees because, AFAIK, the PW CW is defined in this WG.

I think that the really observed problem with incorrect ECMP behavior exists, but it is different from your description in your earlier email:

Any LSR on the path between ingress and egress LER is free to look beyond the MPLS label stack and misinterpret the 0x00 0x00 at the start of a control-word as a valid MAC that starts 00:00:XX:XX:XX:XX and try to hash on Ethernet headers starting directly after the MPLS label stack.

I have not seen (or heard about) such behavior in any deployed networks.

However, I am aware of some modern forwarding chipsets that (correctly) treat the ‘0000’ in the first nibble of the payload of a labeled packet (i.e., immediately following the bottom of the label stack) as the indication of a 32-bit PW control word but (incorrectly), consider this as a CW of an Ethernet PW (as if no other PWs exist!) and try to hash on the presumed MAC addresses, Ethertype etc.  Such behavior is really deadly for, say TDM PWs that, AFAIK, are still widely deployed in many places.

I wonder if IETF (or, specifically, the PALS WG) can do anything about that.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

Email:   [email-masked]

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of James Bensley
Sent: Tuesday, October 23, 2018 11:06 AM
To: [email-masked]
Subject: [bess] CW in EVPN: Was Signaling Control Word in EVPN

Hi All,

I've removed all the individual contacts as per mod request and changed the subject as this conversation was diverging away from the OPs original query (sorry if any of that was my fault).

On Tue, 9 Oct 2018 at 15:54, Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:

> James,

> Agreed. We touched on that in section 7 of draft-ietf-pals-ethernet-cw, where we advised operators that enabling post-CW DPI for ECMP calculations could cause misordering.

Hi Andy,

Perhaps I wasn't clear enough - and LSR (not the ingress/egress LER) even trying to detect CW is a source of problems within the network, this is why I was querying the use of the PWMCW.

On Tue, 9 Oct 2018 at 16:44, Yutianpeng (Tim) <[email-masked]<mailto:[email-masked]>> wrote:

> Personally I support having control word capability which is more common. It is said in RFC 8214:

>    “It is recommended that the control word be included in the absence of an entropy label”

> So I think we can still have EL capability on EVPN VPWS if I understand correct. Only if the existing "BGP Path  Attributes" does not work well.

> I support adapt CW capability into EVPN also as EVPN itself is facing same challenge with EVPN VPWS.

> By the way, rfc4385 mentioned PW controlling ECMP.

The CW doesn't control ECMP - this is my gripe here. It's one thing to recommend a technology that not all devices support (EL/ELI or FAT) but which fully fixes the problem if it supported, it's another thing to recommend a technology that doesn't fully fix the problem if it is supported at all. My concern is that by continuing to suggest a partial solution (PWMCW) we help to keep that partial solution in circulation when surely the WG should look to deprecate it for a solution that fully fixes the problem?

Cheers,

James.

_______________________________________________

BESS mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/bess

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: James Bensley <[email-masked]>
Date: Mon, 29 Oct 2018 13:33:52 +0000

> However, I am aware of some modern forwarding chipsets that (correctly) treat the ‘0000’ in the first nibble of the payload of a labeled packet (i.e., immediately following the bottom of the label…

Hi Sasha,

Well in either case we have both provided different examples of when
the PWMCW doesn't prevent reordering when ECMP is present in the PSN.
Perhaps I need to actually step back a bit here and ask a different
question, to further understand the non-technical problem first.

What is the scope/remit of the WG in this scenario? To be clear on
what I mean by this, the PWMCW is a flawed method for preventing
reordering when ECMP is present (see our two examples above). It also
doesn't add any entropy to improve ECMP when ECMP is required. Entropy
labels help to prevent reordering and help to add entropy, despite
these technical benefits but they may have other non-technical
disadvantages. So what is the WGs remit with recommending one
technology over another?

In this specific case, is it:

Option 1. The WG's remit is to phase out or discourage flawed
technologies if a superior one exists, so it should look to deprecate
CWs because ELs are superior from a purely technical view?
Option 2. The WG's remit is to support as many technologies as
possible, so it shouldn't look to deprecate CWs because ELs may have
other non-technical draw backs?
Option 3. The WG's remit is to remain neutral on the subject of CWs vs
other methods, and simply ensure that all drafts follow the correct
due diligence process regardless of whether one technology is
technically "better" than another?
Option 4. The WG's remit is something else?

Cheers,
James.

---

From: "Yutianpeng (Tim)" <[email-masked]>
Date: Mon, 29 Oct 2018 22:38:47 +0000

Hi,
Some comments below.
Regards,
Tim
-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of James Bensley
Sent: 29 October 2018 13:34
To: [email-masked]; [email-masked]
Subject: Re: [bess] CW in EVPN: Was Signaling Control Word in EVPN

> I have not seen (or heard about) such behavior in any deployed networks.
[Tim]: This behavior exists on some devices, but they should at least ignore 0x0 MAC.
> However, I am aware of some modern forwarding chipsets that (correctly) treat the ‘0000’ in the first nibble of the payload of a labeled packet (i.e., immediately following the bottom of the label…
[Tim]: Yes, this does exist, at least ever :), but this is a behavior not compliance with RFC and should be corrected. Chipset with such capabilities is usually programmable and should have the capability to fix the limit, otherwise will be a disaster for pretending to be intelligent. 

Hi Sasha,

Well in either case we have both provided different examples of when the PWMCW doesn't prevent reordering when ECMP is present in the PSN.
Perhaps I need to actually step back a bit here and ask a different question, to further understand the non-technical problem first.

What is the scope/remit of the WG in this scenario? To be clear on what I mean by this, the PWMCW is a flawed method for preventing reordering when ECMP is present (see our two examples above). It also doesn't add any entropy to improve ECMP when ECMP is required. Entropy labels help to prevent reordering and help to add entropy, despite these technical benefits but they may have other non-technical disadvantages. So what is the WGs remit with recommending one technology over another?

Option 1. The WG's remit is to phase out or discourage flawed technologies if a superior one exists, so it should look to deprecate CWs because ELs are superior from a purely technical view?
Option 2. The WG's remit is to support as many technologies as possible, so it shouldn't look to deprecate CWs because ELs may have other non-technical draw backs?
Option 3. The WG's remit is to remain neutral on the subject of CWs vs other methods, and simply ensure that all drafts follow the correct due diligence process regardless of whether one technology is technically "better" than another?
Option 4. The WG's remit is something else?

[Tim]: My opinion is: 
Control word is proven technology for years and has been deployed a lot. I cannot find a reason we should abandon it. ELs can be better but it is also difficult to achieve.
Many of the chipsets nowadays are still not capable to implement ELs. I believe both techniques will exit for a long period of time.

Cheers,
James.

[email-masked]