Subject: RE: Question for vendors and operators

From: "Beadles, Mark A" <[email-masked]>
Date: Tue, 9 Apr 2002 20:00:25 -0000

Let me confirm my understanding of what you have stated by rephrasing.

In situations that call for the use of PPP,
the Authentication Protocol is:  (PAP), CHAP, EAP, etc.
The protocol that carries the authentication protocol is:  PPP LCP

In situations that do not call for the use of PPP, 
the Authentication Protocol is:  EAP, etc.
The protocol that carries the authentication protocol is:  PANA

So PANA proposes a protocol for carrying authentication for network access
_in non-PPP scenarios_.  Is this an accurate statement?

+ Mark Anthony Beadles  + [email-masked] +
+       Chief Architect + SmartPipes, Inc.        +
+   Vox 614.923.5657    +     Fax 614.923.6299    +

-----Original Message-----
From: Alper E. YEGIN [mailto:[email-masked]] 
Sent: Tuesday, 09 April 2002 14:01
To: Beadles, Mark A; [email-masked]; [email-masked]
Subject: Re: Question for vendors and operators

Mark,

> From: [email-masked]:
> >And all we are trying to do in this WG is to develop a solution that 
> >would basically enable what you describe below. So I do believe there 
> >is a real need for such a solution to be standardized in the IETF.
>
> Basavaraj,
>
> In relation to the question you have posed and the responses I have 
> seen, please help me understand the following question:
>
> "Is it the intent of this WG to specify a new protocol to replace the 
> PPP protocol suite in _wired_ as well as wireless access scenarios?"

The intent is not to replace "PPP". But in scenarios where PPP is used
*only* for its authentication capability, PANA can be used instead. (So,
PANA can not replace all functionalities of PPP in every usage scenario).

>
> If "yes", what reason is there to replace a standardized, deployed,
accepted
> protocol which works well for wired access? (This question is 
> rhetorical).
>
> If "no", then is the work of this WG limited to the wireless space?

No, it is not. It runs over IP, and one can deploy this solution whereever
IP runs.

>
> I suspect the answer is "no" since all the responses I have seen to 
> this question have been specifically limited to wireless scenarios.  
> Is my suspicion correct?  Is the PANA intended to be limited to 
> wireless or is
it
> Intended to be more generic in scope?

Definitely generic. It's upto the people to deploy it in whatever
environment they wish to. The protocol design doesn't have to assume wired
or wireless.

alper

>
> Thanks
> Mark
>
> + Mark Anthony Beadles  + [email-masked] +
> +       Chief Architect + SmartPipes, Inc.        +
> +   Vox 614.923.5657    +     Fax 614.923.6299    +
>
>

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Tue, 9 Apr 2002 15:10:49 -0700

> _in non-PPP scenarios_.  Is this an accurate statement?

if "non-PPP scenario" means "scenario where PPP can be used
only for its EAP encapsulation capability", then yes.

alper