Subject: RE: Location of authentication agent

From: <[email-masked]>
Date: Fri, 19 Apr 2002 10:53:49 -0500

A couple of clarifications:

> 
> Splitting the NAS into AA and EP is a major architectural
> change. 

PANA does not require or mandate that the NAS be split up into
the AA and EP. You can colocate the AA and EP just as well as
you could split them. If you split the AA and EP, then there are 
obviously a few more issues that the protocol needs to worry about.
PANA does not recommend architectural changes for the well 
undertsood NAS model. However if there are reasons for splitting
the AP and EP, then it should be possible to do so and PANA 
allows this. 

> If such a change is to be proposed, then it is
> incumbent upon the working group to work out all
> the details of the change, so that the interoperability
> and security implications are well known before the
> result is standardized. It is not acceptable to make
> the change, declare part of the
> consequences of the change (i.e. the protocol
> and security between PAA and EP) out of
> scope, then just work on the other part.

I agree with what you are saying here. The limited scope
charter that I sent out yesterday is essentially proposing 
to work on the simple aspects of the problem domain.
So in the interest of moving forward with the WG tasks 
I can at least live with it for now.

>             jak
-Basavaraj

---

From: Reinaldo Penno <[email-masked]>
Date: Fri, 19 Apr 2002 10:16:12 -0700 (PDT)

In another email you just said.

> I am not so sure if
> we really need to study the interactions of PAA and
> AAA as much as we
> need to study the interaction of PANA with 802.1x
> and PPP.

or as much we need to study the interaction between
PAA and EP. It's the same argument. It's another
protocol!

So, if I make a protocol called "Reinaldo's" which
uses PAA data and communicates with "Reinaldo's
Server", do I need to know anything or care about how
Pac and PAA communicates? 

       |---------------|
Pac->>>|  PAA  | COPS  |->>>EP
       |       |       |
       -----------------
 
       |---------------|
Pac->>>|  PAA  | AAA   |->>>AAA server
       |       |       |
       -----------------

       |-------------------|
Pac->>>|  PAA  | Reinaldo's|->>>Reinaldo's server
       |       |           |
       --------------------|

I do not know, maybe we are talking about different
things...

Reinaldo

> I can at least live with it for now.

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/