Subject: RE: PAA-EP protocol requirements

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 28 Oct 2002 22:25:39 +0100

I agree with Yoshihiro's comments. Some more below

  > 
  > Three comments.
  > 
  > First, it would be better for the requirement draft to include the
  > definition of EP which is described in the usage scenarios draft.
  > 
  > Second, I agree that push model (pusing information from PAA to EP)
  > should be used for the communication between PAA and EP.  
  > On the other
  > hand, it might be good to have an explicit statement on 
  > optional usage
  > of event notification in the push model in which EP MAY inform PAA
  > when a new device is connnected to the network, which was discussed
  > recently on the mailing list and no one seemed to have 
  > objected to it.

=> I'm not sure about the MAY. I made the suggestion to allow for cases
where the EP crashes and loses all state related to the PaCs. In this 
case we have to make sure that the protocol allows for a pull. Also another 
optimisation would be to allow the EP to request state for all PaCs on-link, 
instead of requesting them one by one. This is only an optimisation though.

An obvious requirement: 
- The protocol MUST provide confidentiality, identity and message authentication
and replay attacks. 

Hesham

---

From: "fan zhao" <[email-masked]>
Date: Mon, 28 Oct 2002 15:46:39 -0800

I think that the two modes both are needed.

The following is the comparation between the two modes:
The push mode requires that different EPs, if more than one, maintain the
same status of lease.
The advantage of this method is as follow:
a)	PAA only sends the lease to all the EP(s) once.
b)	EP(s) can make the decision directly when it receives the packets from
PaC.
c)	The lifetime of lease can be time, number of packets and size of packets
as long as all the EPs keep the same states.

The disadvantage of this method is as follow:
a)	The protocol of sending the lease to all the EPs has to guarantee that
the lease will be put into effect on the different EP at the same time.
b)	The protocol of maintaining the same state of lease on the different EP
has to be designed.

The other way is that when EP receives the packet from PaC, it will retrieve
the lease from PAA at first. If EP can get the valid lease of PaC from PAA,
it will forward the packet of PaC; otherwise it discards it silently.
The advantage of this method is as follow:
a)	The protocol of sending the lease to all the EPs and maintaining the
same state of lease on the different EP is not a must.
b)	The lease is maintained by PAA, for example, if the lifetime of lease is
time, PAA will update the lifetime until it expires.

The disadvantage of this method is as follow:
a)	EP will spend time to retrieve the lease from PAA when it receives the
packet from PaC
		for the first time although after that EP can save the lease locally.
b)	If EP holds the first packet from PaC when it is trying to retrieve the
lease, it potentially provides the opportunity for attackers to launch the
Denial-of-Service attacks. If EP directly forwards the first packet from PaC
to PAA as the request for retrieving the lease and then waits for PAA to
send back the lease associated with lease, it will increase the time to
transmit the packet (since the size of packet is larger) and wastes the
bandwidth.
c)	If the lifetime of lease is the size of packets or the number of
packets, it is hard for one EP to know what is the lifetime of the lease for
the same PaC in another EP.

fan zhao

-----Original Message-----
From: Hesham Soliman (EAB) [mailto:[email-masked]]
Sent: 2002年10月28日 13:26
To: 'Yoshihiro Ohba'; Alper E. YEGIN
Cc: Pana (E-mail)
Subject: RE: PAA-EP protocol requirements

An obvious requirement:
- The protocol MUST provide confidentiality, identity and message
authentication
and replay attacks.

Hesham

---

From: "fan zhao" <[email-masked]>
Date: Mon, 28 Oct 2002 16:11:41 -0800

The definition of lease is as following:
Lease:
It regulates how often PaC will need to re-authenticate itself to PAA after
the successful initial authentication. The lifetime of lease is negotiated
by PAA and PaC during the initial authentication. For example, it can be 30
minutes, 8M bytes or 2^12 packets.

fan zhao

-----Original Message-----
From: Hesham Soliman (EAB) [mailto:[email-masked]]
Sent: 2002年10月28日 13:26
To: 'Yoshihiro Ohba'; Alper E. YEGIN
Cc: Pana (E-mail)
Subject: RE: PAA-EP protocol requirements

An obvious requirement:

Hesham

---

From: Julien Bournelle <[email-masked]>
Date: Tue, 29 Oct 2002 14:12:22 +0100

> - The protocol MUST provide confidentiality, identity and message authentication

totally agree but do you mean that all these features must be IN the PAA-EP protocol 
or that these features could be provided by another protocol such as IPsec ?

[email-masked]

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 29 Oct 2002 09:27:22 -0500

> minutes, 8M bytes or 2^12 packets.

I think that re-authentication interval should be determined by the
network and should not be a negotiatable parameter.

Yoshihiro Ohba

---

From: "fan zhao" <[email-masked]>
Date: Tue, 29 Oct 2002 13:07:13 -0800

Do you mean that the re-authentication interval depends on
the type of underlying layer2 network or whatelse?
Can you explain a little bit more?
Thanks.

fan

Yoshihiro Ohba

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 29 Oct 2002 18:36:30 -0500

> Can you explain a little bit more?

Re-authentication interval should be determined by either PAA or
backend authentication server, which is responsible for authorizing
the PaC device for network access.  The value might depend on the type
of underlying layer 2.  I don't see a benefit of supporting
re-authentication interval negotiation.

Yoshihiro Ohba