Subject: RE: PANA threat evaluation draft.

From: "Mohan Parthasarathy" <[email-masked]>
Date: Wed, 23 Oct 2002 10:11:47 -0700

Subir,

> 
> 
> Mohan, 
> Here is a quick comment:
> 
> Requirement 3: 
> 
> Are you assuming that layer-2 security exists here? If not, then by 
> mutual authentication you may not be able to avoid some MITM attacks. 
>
There is no assumption about layer 2 in this case.

> For example, an AP can come in between PaC and PAA and forward the 
> PaC's credentials by simply changing the IP/MAC address. Once 
> authentication is successful (mutual authentication is performed) 
> AP disconnects the PaC and gains the access. 
> 
How does mutual authentication succeed in this case ?  PaC and
AS share a secret (could be in the form of pre-shared key, certificates
etc.) which is not known to anybody else and they verify the identity
of each other by generating and verifying a hash. For example, IKE
provides mutual authentication.

-mohan

> 
> Subir
> 
> 
> 
> > Mohan Parthasarathy wrote:
> > 
> > Folks,
> > 
> > PANA threats and secuirty requirements doc is at
> > 
> > http://www.toshiba.com/tari/pana/draft-ietf-pana-threats-eval-00.txt
> > 
> > before it is officially annonunced.
> > 
> > Please send comments to the list.
> > 
> > -thanks
> > mohan
>

---

From: Subir Das <[email-masked]>
Date: Wed, 23 Oct 2002 14:06:09 -0400

> provides mutual authentication.

  Remember AP is forwarding everything what PaC is sending until 
  authentication process is completed.

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 23 Oct 2002 14:26:47 -0400

Mohan,

If a security association established as a result of mutual
authentication is not cryptographycally bound to the device identifier
or something that needs to be protected, a class of MiTM attack that
Subir mentioned is still possible.  This is also desribed in the PANA
over TLS draft (it defines Device Identifier protection mechanism for
this purpose), and a similar issue is also being discussed in the EAP
WG.

BTW, I'm not sure whether IKE is free from any kinds of MiTM attacks.

Yoshihiro Ohba