Subject: RE: PAA-EP protocol requirements

From: <[email-masked]>
Date: Wed, 30 Oct 2002 16:54:56 +0200

Hi,

In similar manner the EP could ask the enforcement policy information from the PAA. I mean the push model doesn't scale as well as the pull model.

The discovery could be left out. 

What about usage scenarios, where we have multiple EPs in serial. First could be in the AP, and second in the AR. I.e. mixture of the three usage scenarios.

Then about the PAA<->EP protocol. Is it really needed? What if the protocol is AAA, then obviously the scenario becomes similar to where EP and PAA are co-located. AAA already provides DWR/DWA messages.

- Dan

> -----Original Message-----
> From: ext Reinaldo Penno [mailto:[email-masked]]
> Sent: 30 October, 2002 05:27
> To: Yoshihiro Ohba
> Cc: Yoshihiro Ohba; Alper E. YEGIN; Pana (E-mail)
> Subject: Re: PAA-EP protocol requirements
> 
> 
> I saw your point, but I think I didn't convey my
> question right...
> 
> the more basic question is: should we provide for this
> case where the EP notifies the PAA explicitly in the
> PAA<->EP protocol? If yes, do we still need discovery?
> 
> Should we assume that the PAC will always be able to
> discover who the PAA is, so in a sense most of the
> time (except when PAA and EP are co-located) the PAC
> is the one initiating authentication?
> 
> If this is not the case, do we still need discovery,
> given the models listed in the requiremetns draft?
> Looking at those models it seems to me all packets
> reach an EP first, which can always ask the PAA to
> initiate authentication?
> 
> any thoughts?
> 
> 
> 
> --- Yoshihiro Ohba <[email-masked]> wrote:
> > On Tue, Oct 29, 2002 at 05:10:03PM -0800, Reinaldo
> > Penno wrote:
> > > Hello Yoshi, 
> > > 
> > > Isn't this a discovery problem? why try to fix it
> > at
> > > the EP<->PAA communication?
> > 
> > No, it is not a part of a discovery problem, since
> > the discovery is
> > used for PaC to discover the PAA.
> > 
> > > 
> > > Shouldn't the PAC discover the PAA or the EP send
> > some
> > > ICMP or whatever back to the PAC so that he tries
> > to
> > > contact the PAA?
> > 
> > Both two cases just cover PANA authentication
> > initiated by PaC.  ICMP
> > is just a trigger for PANA authentication initiated
> > by PaC, I think.
> > 
> > What I'm mentioning here is about a trigger for PANA
> > authentication
> > initiated by PAA.
> > 
> > Yoshihiro Ohba
> > 
> 
> 
> __________________________________________________
> Do you Yahoo!?
> HotJobs - Search new jobs daily now
> http://hotjobs.yahoo.com/
> 
>

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Wed, 30 Oct 2002 18:54:43 -0800

> What about usage scenarios, where we have multiple EPs in serial. First
could be in the AP, and second in the AR. I.e. mixture of the three usage
scenarios.

I'm not sure if we'd need this kind of an approach for network
access authentication. I guess one can imagine some enhanced/optimized
scenarios using this model...

> Then about the PAA<->EP protocol. Is it really needed? What if the
protocol is AAA, then obviously the scenario becomes similar to where EP and
PAA are co-located. AAA already provides DWR/DWA messages.

I'm not sure if I understand this right, but, yes, PAA-EP
protocol might be based on one of the existing AAA protocols.
But we need to analize them, this is why we are working out the
requirements...

alper