Subject: RE: [Pana] issue 23 and 25

From: [email-masked]
Date: Wed, 15 Oct 2003 11:07:59 +0300

I mean the same code space, but different numbers so that 
overlapping is not happening when processing PANA and AAA 
messages at the same application level.
- Dan

> -----Original Message-----
> From: ext Yoshihiro Ohba [mailto:[email-masked]]
> Sent: 14 October, 2003 21:18
> To: Forsberg Dan (NRC/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Pana] issue 23 and 25
>
>
> On Tue, Oct 14, 2003 at 02:23:19PM +0300,
> [email-masked] wrote:
> > > -----Original Message-----
> > > From: ext Yoshihiro Ohba [mailto:[email-masked]]
> > > Sent: 14 October, 2003 00:28
> > > To: [email-masked]
> > > Subject: [Pana] issue 23 and 25
> > >
> > >
> > > There are two PANA draft -01 issues for which I'm not
> sure about the
> > > consensus.
> > >
> > > Issue 23: PANA Message type/AVP numbers and Diameter command
> > > codes/AVPs
> >
> > Let me give some background for this issue, since I submitted it.
> >
> > One approach is that a NAS supports PANA functionality. A NAS
> > can be a Diameter/Radius client. To better support
> interworking with the
> > PANA and NAS functionality, it would be good to distinguish
> the command
> > code and message type numbers. This way for example PANA
> message header
> > parsing functionality can be added to a NAS almost as "link
> layer" and
> > the PANA session handling functionality can be "migrated"
> into the NAS.
>
> This seems to suggest using different code space for Diameter command
> codes and PANA message types, right?  What about using different code
> space for Diameter AVP types and PANA AVP types?  I think the same
> justification is also applicable to PANA AVP types.
>
> Yoshihiro Ohba
> 

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 15 Oct 2003 09:53:14 -0700

> messages at the same application level.

That also works for me, as long as the same rule consistently applies
to both PANA message types and PANA AVP types.

Yoshihiro Ohba

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 15 Oct 2003 09:53:14 -0700

Yoshihiro Ohba

---

From: Alper Yegin <[email-masked]>
Date: Wed, 15 Oct 2003 11:23:09 -0700

First it was using the same codes for both PANA and Diameter. Now it is
using non-overlapping codes. I still don't see why we have to care about
these, and unnecessarily constraint ourselves. These two are separate
protocols. If a process uses both protocols, it better know what protocol a
received message belongs to.

Alper

---

From: Alper Yegin <[email-masked]>
Date: Wed, 15 Oct 2003 11:23:09 -0700

Alper