Subject: Re: [Pana] [issue19] Result-Code AVP values?

From: Alper Yegin <[email-masked]>
Date: Wed, 01 Oct 2003 17:35:37 -0700

>        PANA_UNABLE_TO_DELIVER                  3002
>           Error code from PAA to PaC.  The network was unable to
>           deliver the message.

I presume this would be sent by the PAA when it cannot pass a response from
PaC to the AAA backend? We should clarify...
> 
>        PANA_REALM_NOT_SERVED                   3003
>           Error code from PAA to PaC.  The network doesn't recognize
>           the realm.

We don't have a place where PaC sends the realm information. So, I can't see
where such an error would be returned to the PaC.

> 
>        PANA_TOO_BUSY                           3004
>           Error code from PAA to PaC.  Not enough resources to serve
>           the client.  PaC SHOULD attempt to send this message to
>           alternate PAA.  This error SHOULD NOT be used as an answer
>           to the PANA-PAA-Discover message.

I think PAA should never have to send such a message. I'd say the PAA should
allocate sufficient resources before engaging in a PANA session. After all,
we don't have a session relocation facility, PaC cannot change its PAA in
the middle.

> 9.4.7.4.  Permanent failures
> 
>     Errors that fall within the permanent failures category are used
>     to inform the sender that the message processing failed, and
>     that the sender should not attempt to send the same message
>     again.

I'm not clear on the separation between these permanent failures and the
protocol errors (previous section).

> 
>        PANA_AVP_UNSUPPORTED                    5001
>           Error code from PAA to PaC or from PaC to PAA.  The
>           received message contained an AVP that is not recognized
>           or supported and was marked with the Mandatory bit.  A
>           PANA message with this error MUST contain one or more
>           Failed-AVP AVP containing the AVPs that caused the
>           failure.

I think we also need to define Failed-AVP AVP in the draft.

Alper

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Alper Yegin <[email-masked]>
Date: Wed, 01 Oct 2003 17:35:37 -0700

Alper