Subject: Inactive EP detection (was Re: [Pana] PAA-2-EP protocol requirements)

From: [email-masked]
Date: Tue, 02 Dec 2003 11:21:27 +0100

hi Alper,

Alper Yegin a écrit:
> 
> (sorry for the late and batched responses due to my travels)
> 
> 
>> > I'm not sure how much "explicit support" we need for this from the 
>> PAA2EP
>> > protocol. There can always be ad-hoc solutions to this. For example, 
>> running
>> > some request-reply messages between the PAA and EP can be used as a
>> > keep-alive. I can imagine an implementation resorting to such 
>> techniques
>> > when the protocol does not have a dedicated facility....
>>
>> ok. my feeling is you think it's not a requirement at all :-)
> 
> 
> I don't think it is a hard requirement on the PAA2EP protocol.
> It may be a requirement of the architecture which can be satisfied
> by other means...

what is required then ? is the following sounds correct:

the PAA-2-EP protocol must enable the PAA to detect inactive EPs. this 
does not mean that the PAA-2-EP protocol must support a heartbeat 
mechanism or any other specific feature.
if yes, it is a good point, but the only requirement is that the 
PAA-2-EP protocol must not prevent to address this problem by other 
means (see above).

thanks,
Yacine

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: [email-masked]
Date: Tue, 02 Dec 2003 11:21:27 +0100

hi Alper,

thanks,
Yacine

---

From: [email-masked]
Date: Tue, 02 Dec 2003 12:18:19 +0100

hi Alper:

 >> anyway, these questions bring up some PANA framework issues related to
 >> the EP-PAA relation when we have multiple PAAs in the access network:
 >> * can a given EP relate to multiple PAAs ?
 >
 >
 > I think we had discussed that there may be multiple PAAs on a link,
 > but the PaC will run PANA with one of them. So, I guess yes, an EP
 > might be associated with more than one PAA.
 >
 >> * does a given PAA configure all the EPs with the same rules ?
 >
 > The provisioning info pushed to EPs for a given PaC would be the
 > same.
 >
 >> * or only the one which treat the traffic coming from the PaC ?
 >
 >
 > Well, PAA decides which EPs should receive the information. And this
 > depends on the topology. For a multi-access link with multiple access
 > routers as EPs, each router will be provisioned with the PaC-specific
 > info.
 >
 > On the other hand, if a switch is the EP, as a L2 access device there is
 > only one connected to PaC and that single device is the EP. It will be
 > provisioned with the PaC-specific info.

my understanding is the following:

PAA-1 and PAA-2 authenticate the PaCs via PANA in the access network. 
For each PaC authenticated by PAA-1, PAA-1 authorize this PaC traffic by 
configuring the concerned EPs. depending on the topology, there could be 
more than one.

does it look correct ?

 >> * inter-PAAs communication ?
 >
 >
 > Why do we need this for?

for exemple: context transfer between PAAs for mobility handling (in 
order to avoid re-authentication, which would reduce the handover perf).
this is strongly dependent of the relation between PAA and EPs discussed 
above.

 > Alper

Yacine

 >> etc...
 >>
 >> comments on these "issues" are warmly welcome !
 >>
 >>
 >>
 >> >>c) Accounting/Feedback from the EPs:
 >> >>The PAA must have an efficient way to to get the accounting 
information
 >> >>of PaC from EP since the PAA may be a client of the AAA backend
 >> >>infrastructure.
 >> >
 >> >
 >> > Getting statistics from the EP makes sense. For example, in the 
case of
 >> > SNMP, if we get the counters from the EP this is good enough. The
 >> AAA client
 >> > sitting on the PAA can turn these into accoutning records.
 >>
 >> should the PAA poll the EPs to get these counters when needed (the
 >> SNMP way...) or the EPs are supposed to send them periodically ?
 >>
 >> anyway, this should be somehow a requirement.
 >>
 >>
 >> > Alper
 >> >
 >>
 >> thanks,
 >> yacine
 >>
 >> >>d) ????
 >> >>
 >> >>
 >> >>thanks,
 >> >>Yacine El Mghazli
 >> >>
 >> >>
 >> >>
 >> >>
 >> >>
 >> >>
 > _________________________________________________________________
 > Set yourself up for fun at home!  Get tips on home entertainment
 > equipment, video game reviews, and more here.
 > http://special.msn.com/home/homeent.armx
 >
 >

---

From: [email-masked]
Date: Tue, 02 Dec 2003 12:18:19 +0100

does it look correct ?

Yacine

information
case of

---

From: Alper Yegin <[email-masked]>
Date: Wed, 03 Dec 2003 07:34:24 -0800

> what is required then ?

Identification of how inactive EPs can be detected when a particular PAA2EP
protocol is used. Again, this may or may not involve an explicit/dedicated
feature of the base protocol.

I don't think we really need to develop new things in here. This problem is
not specific to PANA. It's not like EPs are going to crash more often
because PANA is running in the network ;)

Alper

> is the following sounds correct:
>

---

From: Alper Yegin <[email-masked]>
Date: Wed, 03 Dec 2003 07:34:24 -0800

Alper

---

From: Alper Yegin <[email-masked]>
Date: Wed, 03 Dec 2003 08:30:06 -0800

> configuring the concerned EPs. depending on the topology, there could be

Yes. This is what I'm thinking.

> this is strongly dependent of the relation between PAA and EPs discussed

I cannot see the relation. I think changing PAAs due to mobility and
enabling fast reauthentication via context transfers is orthogonal to the
PAA2EP protocol.

Alper

---

From: Alper Yegin <[email-masked]>
Date: Wed, 03 Dec 2003 08:30:06 -0800

Alper

---

From: [email-masked]
Date: Fri, 12 Dec 2003 14:10:47 +0100

hi all,

does the working group foresee deployment scenarios where we have 
multiple PAAs in the same IP subnet ?

thanks,
Yacine

---

From: [email-masked]
Date: Fri, 12 Dec 2003 14:10:47 +0100

hi all,

thanks,
Yacine

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 12 Dec 2003 02:04:13 -0800

I think multiple PAAs in the same IP subnet will be important when
realizing a network selection over a shared medium without depending
on L2-based selection techniques such as PPPoE discovery.  Of cource,
more work would be needed for establishing an appropriate routing
context and assigning an IP address for use of a selected network.

Yoshihiro Ohba

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 12 Dec 2003 02:04:13 -0800

Yoshihiro Ohba

---

From: Alper Yegin <[email-masked]>
Date: Fri, 12 Dec 2003 11:16:29 -0800

Hi Yoshi,

I don't fully understand this scenario. Normally there is one physical
network, owned by one NAP. That NAP puts a PAA, and enables PaC select from
a set of ISPs. 

You seem to suggest multiple NAPs sharing the same physical access network.
I don't think this is a realistic scenario.

Alper

---

From: Alper Yegin <[email-masked]>
Date: Fri, 12 Dec 2003 11:16:29 -0800

Hi Yoshi,

Alper

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 12 Dec 2003 14:43:23 -0800

> I don't think this is a realistic scenario.

I did not actually think about multiple NAPs.  What I was thinking is
a model where there is only one NAP, but each PAA is owned by a
different ISP and performs only ISP authentication for the ISP. In
this case, the NAP just provides the ISPs the physical location to put
their PAAs and EPs, and no NAP authentication is performed.

Yoshihiro Ohba

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 12 Dec 2003 14:43:23 -0800

Yoshihiro Ohba

---

From: [email-masked]
Date: Mon, 15 Dec 2003 14:49:59 +0100

> their PAAs and EPs, and no NAP authentication is performed.

see the folowing message on the same subject:
ftp://ftp.research.telcordia.com/pub/Group.archive/pana/webview/msg01956.html

yacine

---

From: [email-masked]
Date: Mon, 15 Dec 2003 14:49:59 +0100

yacine

---

From: Alper Yegin <[email-masked]>
Date: Mon, 15 Dec 2003 12:57:07 -0800

> their PAAs and EPs, and no NAP authentication is performed.

This is different than the current NAS model. If we have to extend/modify
the design to support such a scenario, we need to understand if it qualifies
to justify that action. Why would anyone not use the current NAS model and
resort to something like that?

Alper

---

From: Alper Yegin <[email-masked]>
Date: Mon, 15 Dec 2003 12:57:07 -0800

Alper