Subject: RE: [Pana] EAP-Payload in PBR (new issue)

From: [email-masked]
Date: Thu, 22 Jan 2004 17:36:40 +0200

I guess an error should be sent instead then, not the PBR msg.
- Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of ext Yoshihiro Ohba
> Sent: 17 January, 2004 02:44
> To: [email-masked]
> Subject: [Pana] EAP-Payload in PBR (new issue)
> 
> 
> In the current PANA spec, EAP-Payload AVP is a required AVP for
> PANA-Bind-Request.  However, it is possible that EAP conversation
> fails without generating a EAP-Success or EAP-Failure message,
> specifically when a AAA timeout occurs (please see EAP Full
> Authenticator State Machine diagram in the EAP state machines draft,
> pdf version).
> 
> Thus, EAP-Payload AVP should be optional for PANA-Bind-Request.
> 
> Yoshihiro Ohba
> 
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pana
> 

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 22 Jan 2004 09:17:58 -0800

I thought that PANA-Error message is used for errors occured within
PANA.  But in this case, the error is an EAP authentication failure
and I think it should be carried by PANA authentication
success/failure message (i.e., PBR).

(There is another problem with using PANA-Error for this case: 
Which AVP is considered invalid and carried in Failed-AVP?)

Yoshihiro Ohba

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 22 Jan 2004 09:17:58 -0800

Yoshihiro Ohba