Subject: RE: [Pana] NEW: [issue72] Capability discovery during PAA discovery

From: Alper Yegin <[email-masked]>
Date: Thu, 15 Apr 2004 17:56:44 -0700

> > Currently capability discovery is not accomplished until the end of
> > EAP authentication. Copying some bits, such as POPA types and
> > per-packet protection capability, to PAA discovery may be useful for
> > discovering capability mismatch early on.
> >
> So, there are two issues here.
> 
> 1) Adding some capability AVPs to PANA-start-request message.
> 2) Enabling verification later on to compensate for the lack of security
> in
>     the discovery phase (i guess when the Pana-bind-request message is
>     received)
> 
> Is that right ?

Yes.

> 
> I can see it being useful in general, but how useful it is to know early
> on the
> POPA type and per-protection capabilities ?

Knowing if there is a potential mismatch that's going to be a show-stopper, PaC might decline to use a particular PAA, and save the hassle of going through the whole authentication phase.

Alper

> 
> -thanks
> mohan
> 
> 
> > ----------
> > category: Technical
> > document: draft-ietf-pana-pana-xx.txt
> > messages: 243
> > nosy: dforsber
> > priority: Should Fix
> > status: Pending
> > title: Capability discovery during PAA discovery
> > __________________________________________________
> > PANA Issues <[email-masked]>
> > <http://danforsberg.info:8080/pana-issues/issue72>
> > __________________________________________________
> > =ڙx%Ojvˢz m? 0 '~ ffX) Z
> 
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pana

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Alper Yegin <[email-masked]>
Date: Thu, 15 Apr 2004 17:56:44 -0700

Yes.

Alper