Subject: [Pana] Re: PANA NAP and ISP authentication

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 24 Jun 2004 07:03:15 -0700

Hi Rafa,

Let me send this email to the PANA mailing list.

On Thu, Jun 24, 2004 at 03:42:19AM +0200, Rafael Marin Lopez wrote:
> Hi Yoshihiro
> 
> I was reading section about PANA NAP and ISP authentication (section 4.6) :
> 
> 
> " PAA offers NAP and ISP separate authentication, as well as a
> 
>      choice of ISP from "ISP1" and "ISP2".  PaC accepts the offer from
>      PAA, with choosing "ISP1" as the ISP.
> 
>   o  An EAP sequence for NAP authentication and an EAP sequence for ISP
>      authentication is performed in this order in authentication phase.
> 
>   o  An EAP authentication method with a single round trip is used in
>      the EAP sequence.
> 
>   o  The EAP authentication methods derive keys.  Once the two EAP
>      authenticatioins are successful, the PANA_MAC_KEY is derived from
>      the two AAA-Keys.
> 
> "
> 
> That is, PANA_MAC_KEY is derived after we have two AAA-Keys....

The answer is no.  I think the explanation of this example is
ambiguous.  The PANA_MAC_Key is first derived from the AAA-Key1 upon
the completion of the first EAP, and then the PANA_MAC_Key is updated
so that the key is derived from both AAA-Key1 and AAA-Key2 upon the
completion of the second EAP.

> 
> o  After PANA SA is established, all messages are integrity and
>      replay protected with the MAC AVP.
> 
> 
> ... and with PANA_MAC_KEY we can calculate MAC AVP .
> 
> However ... this MAC AVP appears before these two authentications are 
> carried out, for example:
> 
> <-----     PANA-Auth-Request(x+3,y+4)[EAP, MAC]// ISP
> 
> 
> I guess , here MAC is calculated by using AAA-Key 1 (we have only this 
> so far) but in :
> 
> 			PANA-Bind-Request(x+5,y+6)          //S-flag set
>                           [EAP{Success}, Device-Id, Key-Id,
>                            Lifetime, Protection-Cap., PPAC, MAC]
> 
> 
> 
> MAC is calculated by using both AAA_Key1 and AAA_Key2... am I wrong?

You are right.  

How about changing as follows?

change:

"
  o  An EAP authentication method with a single round trip is used in
     the EAP sequence.

  o  The EAP authentication methods derive keys.  Once the two EAP
     authenticatioins are successful, the PANA_MAC_KEY is derived from
     the two AAA-Keys.
"

to:

"
  o  An EAP authentication method with a single round trip is used in
     each EAP sequence.

  o  Two AAA-Keys are derived from the EAP authentication methods,
     i.e., AAA-Key1 and AAA-Key2.  The PANA_MAC_Key is first derived
     from the AAA-Key1 upon the completion of the first EAP, and then
     it is updated so that it is derived from both AAA-Key1 and
     AAA-Key2 upon the completion of the second EAP.
"

Regards,

Yoshihiro Ohba

> 
> 
> -- 
> 
> ------------------------------------------------------
> Rafael Marin Lopez
> Faculty of Computer Science-University of Murcia
> 30071 Murcia - Spain
> Telf: +34968367645    e-mail: [email-masked]
> ------------------------------------------------------
> 

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Rafael Marin Lopez <[email-masked]>
Date: Thu, 24 Jun 2004 16:33:38 +0200

Hi Yoshi...

>completion of the second EAP.
Now it's clear.

>     AAA-Key2 upon the completion of the second EAP.
Sounds good for me.

Thanks.