Subject: [Paw] Towards a PAW WG

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 14 Dec 2018 13:18:31 +0000

Dear all:

At the PAW bar BOF in Bangkok, we found common interests in discussing matters similar to DetNet but with a focus on wireless. 

What’s so special with wireless? Well, in very short, scheduling brings all the benefits it does on wires, and more. Scheduling can enable multi channel operations, energy savings, G-MPLS forwarding operations with schedule-based Replication (overhearing), Elimination and Reordering.

But the methods to build a Predictable and Available Wireless network will differ from those used by DetNet/TSN on wires because the medium can be shared, lossy, and broadcast.

This is why we also discussed the need of a group that would specifically address the PAW problem. What would such a group do? 

Quite simply PAW would aim at providing latency and throughput guarantees over a set of radios to be defined, and collaborate with the groups in charge of these radios. In more details:

- Which radios? There are 2 elephants in that room, the adult, ieee std 802.15.4 TSCH for which we have RFC 7554, and the young, ieee sig 802.11 RTA, for which we’d need an informational doc explaining what’s special and interesting about it. Also I’m hearing through the grapevine that the German DLR is developing a new radio that could become a standard for plane communication.

- there is a need to extend the DetNet use cases draft with a wireless twist. Cover real time gaming, in cars and in planes automation, conferencing, building automation, and industrial process control and factory automation.

- there is work that is discussed at BIER and ROLL about methods that could provide extensive time and space diversity using synchronized overhearing and elimination, as well as OAM techniques to optimize the use of the possibly extensive replication that can be needed to provide high delivery ratio with bounded latency. This work needs a central hosting.

- 6TiSCH provides IP best effort over a PAW-capable radio, but did not work on the deterministic flows. We are missing the data model to control the GMPLS forwarding over complex Tracks that is described in the 6TiSCH architecture. PAW would be the natural place to do that.

- ... <anything I missed?>

All and all, there is quite a bit of work ahead. But then, we need to show that we can build a critical mass of people to form a WG. This is where this list comes into play. 

So please respond, indicate what radio we could work on, what network layer problem we need to solve, what amount of energy you are willing to make this happen. Don’t be shy!!

Many thanks in advance...

Pascal

---

From: <[email-masked]>
Date: Tue, 18 Dec 2018 07:46:00 +0000

Hi Pascal,

I'm interested in DetNet on wireless, especially on IEEE 802.15.4
TSCH. I think some features in TSN (e.g. 802.1Qch) can be mapped
to TSCH thanks to its time-aware nature. To do that kind of
mapping, we need its data model and management interface for it.

I have a question, though. Isn't PAW covered by 6tisch WG?
draft-ietf-6tisch-architecture-19 talks about deterministic
wireless networks for industrial applications, centralized TSCH
scheduling, and packet replication. There are some expired
drafts (*1) for centralized management. I don't know what's
happened to those drafts, but I thought 6tisch WG would
eventually work on centralized networks in future. Isn't it gonna
happen?

If we are to expand our focus to include 802.11 radio, probably
6tisch WG cannot cover that.

*1: https://tools.ietf.org/html/draft-ietf-6tisch-6top-interface-04
    https://tools.ietf.org/html/draft-ietf-6tisch-coap-03

Best regards,
Toshio Ito

> -----Original Message-----
> From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
> Sent: Friday, December 14, 2018 10:19 PM
> To: [email-masked]
> Subject: [Paw] Towards a PAW WG
> 
> Dear all:
> 
> What’s so special with wireless? Well, in very short, scheduling brings all the benefits it does on wires,
> and more. Scheduling can enable multi channel operations, energy savings, G-MPLS forwarding operations with
> schedule-based Replication (overhearing), Elimination and Reordering.
> 
> But the methods to build a Predictable and Available Wireless network will differ from those used by
> DetNet/TSN on wires because the medium can be shared, lossy, and broadcast.
> 
> Quite simply PAW would aim at providing latency and throughput guarantees over a set of radios to be defined,
> and collaborate with the groups in charge of these radios. In more details:
> 
> - Which radios? There are 2 elephants in that room, the adult, ieee std 802.15.4 TSCH for which we have
> RFC 7554, and the young, ieee sig 802.11 RTA, for which we’d need an informational doc explaining what’s
> special and interesting about it. Also I’m hearing through the grapevine that the German DLR is developing
> a new radio that could become a standard for plane communication.
> 
> - there is a need to extend the DetNet use cases draft with a wireless twist. Cover real time gaming, in
> cars and in planes automation, conferencing, building automation, and industrial process control and factory
> automation.
> 
> - there is work that is discussed at BIER and ROLL about methods that could provide extensive time and space
> diversity using synchronized overhearing and elimination, as well as OAM techniques to optimize the use
> of the possibly extensive replication that can be needed to provide high delivery ratio with bounded latency.
> This work needs a central hosting.
> 
> - 6TiSCH provides IP best effort over a PAW-capable radio, but did not work on the deterministic flows.
> We are missing the data model to control the GMPLS forwarding over complex Tracks that is described in the
> 6TiSCH architecture. PAW would be the natural place to do that.
> 
> All and all, there is quite a bit of work ahead. But then, we need to show that we can build a critical
> mass of people to form a WG. This is where this list comes into play.
> 
> So please respond, indicate what radio we could work on, what network layer problem we need to solve, what
> amount of energy you are willing to make this happen. Don’t be shy!!
> 
> --
> Paw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/paw

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 18 Dec 2018 07:59:14 +0000

Great question, Toshio : )

The architecture of 6TiSCH is global but the work there always focused on IPv6 (best effort) over 15.4 TSCH. I do not see 6TiSCH rechartering for DetNet type. 
I see PAW as a spin off from 6TISCH, focusing on the deterministic side of the 6TiSCH architecture, and extending to other MAC/PHYs, e.g., work starting at 802.11 in RTA/EHT.

And yes, I see PAW taking over the deterministic wireless data model work that started in 6TiSCH and stalled there. That is the last point below. We also have to consider what the detnet data plane formats becomes in a GMPLS environment where the flow ID and possibly the sequence can be implicit, derived from the timeslot.

The IESG is polling for BoF requests for Prague. Would you be interested in seeing that happen?

Pascal
 
> From: [email-masked] <[email-masked]>
> Sent: mardi 18 décembre 2018 08:46
> To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
> Subject: RE: Towards a PAW WG
> 
> Hi Pascal,
> 
> I'm interested in DetNet on wireless, especially on IEEE 802.15.4 TSCH. I think
> some features in TSN (e.g. 802.1Qch) can be mapped to TSCH thanks to its
> time-aware nature. To do that kind of mapping, we need its data model and
> management interface for it.
> 
> draft-ietf-6tisch-architecture-19 talks about deterministic wireless networks for
> industrial applications, centralized TSCH scheduling, and packet replication.
> There are some expired drafts (*1) for centralized management. I don't know
> what's happened to those drafts, but I thought 6tisch WG would eventually
> work on centralized networks in future. Isn't it gonna happen?
> 
> If we are to expand our focus to include 802.11 radio, probably 6tisch WG
> cannot cover that.
> 
> 
> > At the PAW bar BOF in Bangkok, we found common interests in discussing
> > matters similar to DetNet but with a focus on wireless.
> >
> > What’s so special with wireless? Well, in very short, scheduling
> > brings all the benefits it does on wires, and more. Scheduling can
> > enable multi channel operations, energy savings, G-MPLS forwarding
> operations with schedule-based Replication (overhearing), Elimination and
> Reordering.
> >
> > But the methods to build a Predictable and Available Wireless network
> > will differ from those used by DetNet/TSN on wires because the medium can
> be shared, lossy, and broadcast.
> >
> > This is why we also discussed the need of a group that would
> > specifically address the PAW problem. What would such a group do?
> >
> > Quite simply PAW would aim at providing latency and throughput
> > guarantees over a set of radios to be defined, and collaborate with the groups
> in charge of these radios. In more details:
> >
> > - Which radios? There are 2 elephants in that room, the adult, ieee
> > std 802.15.4 TSCH for which we have RFC 7554, and the young, ieee sig
> > 802.11 RTA, for which we’d need an informational doc explaining what’s
> > special and interesting about it. Also I’m hearing through the grapevine that
> the German DLR is developing a new radio that could become a standard for
> plane communication.
> >
> > - there is a need to extend the DetNet use cases draft with a wireless
> > twist. Cover real time gaming, in cars and in planes automation,
> > conferencing, building automation, and industrial process control and factory
> automation.
> >
> > - there is work that is discussed at BIER and ROLL about methods that
> > could provide extensive time and space diversity using synchronized
> > overhearing and elimination, as well as OAM techniques to optimize the use
> > We are missing the data model to control the GMPLS forwarding over
> > complex Tracks that is described in the 6TiSCH architecture. PAW would be
> the natural place to do that.
> >
> > All and all, there is quite a bit of work ahead. But then, we need to
> > show that we can build a critical mass of people to form a WG. This is where
> this list comes into play.
> >
> > So please respond, indicate what radio we could work on, what network
> > layer problem we need to solve, what amount of energy you are willing to
> make this happen. Don’t be shy!!
> >

---

From: <[email-masked]>
Date: Tue, 18 Dec 2018 08:58:05 +0000

Thanks for your response, Pascal.

Spinning off from 6tisch is a good starting point, I think. And
if we are using non-IP encapsulation, we need so many components
to discuss and 6tisch WG cannot cover that.

> The IESG is polling for BoF requests for Prague. Would you be interested in seeing that happen?

Yes, I'm very interested in PAW BoF!

Best regards,
Toshio Ito

> From: Pascal Thubert (pthubert) <[email-masked]>
> Sent: Tuesday, December 18, 2018 4:59 PM
> To: ito toshio(伊藤 俊夫 ○ＲＤＣ□ＮＳＬ) <[email-masked]>; [email-masked]
> The architecture of 6TiSCH is global but the work there always focused on IPv6 (best effort) over 15.4 TSCH.
> I do not see 6TiSCH rechartering for DetNet type.
> I see PAW as a spin off from 6TISCH, focusing on the deterministic side of the 6TiSCH architecture, and
> extending to other MAC/PHYs, e.g., work starting at 802.11 in RTA/EHT.
> 
> And yes, I see PAW taking over the deterministic wireless data model work that started in 6TiSCH and stalled
> there. That is the last point below. We also have to consider what the detnet data plane formats becomes
> in a GMPLS environment where the flow ID and possibly the sequence can be implicit, derived from the timeslot.
>

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 18 Dec 2018 09:30:58 -0300

Pascal,
             So many interesting things to do...
I am currently working on space diversity for 6tisch, and
one of my students is also working on G-MPLS and flow
support.
             Moreover, I am really interested in deterministic
flows -à la wireless- and controlled replication to provide
latency guarantees.
             Thank you.
             Regards,

                                     Diego

Le mar. 18 déc. 2018 à 05:58, <[email-masked]> a écrit :

> TSCH. I think
> > > of the possibly extensive replication that can be needed to provide
> high
> > > delivery ratio with bounded latency.
> > > > - 6TiSCH provides IP best effort over a PAW-capable radio, but did
> not work
> > > on the deterministic flows.

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125