Subject: [paws] updated charter proposal

From: <[email-masked]>
Date: Wed, 23 Mar 2011 22:23:49 +0000

Folks,

Here's an updated charter proposal.

But please read these two drafts before you come to the BOF:

I-D: Protocol to Access White Space database: Problem statement and Requirements
http://www.ietf.org/id/draft-patil-paws-problem-stmt-00.txt

I-D: Protocol to Access White Space database: Overview and Use case scenarios
http://www.ietf.org/id/draft-probasco-paws-overview-usecases-00.txt

Governments around the world continue to search for new pieces of radio spectrum which can be used by the expanding wireless communications industry to provide more services in the usable spectrum.  The concept of allowing secondary transmissions (licensed or unlicensed) in frequencies allocated to a primary user is a technique to "unlock" existing spectrum for new use. An obvious requirement is that these secondary transmissions do not interfere with the primary use of the spectrum. Often, in a given physical location, the primary user(s) may not be using the entire band allocated to them.  The available spectrum for a secondary use would then depend on the location of the secondary user.  The primary user may have a schedule when it uses the spectrum, which may be available for secondary use outside that schedule.  The fundamental issue is how to determine for a specific location and specific time, if any of the primary spectrum is available for secondary use. One simple mechanism is to use a geospatial database that records protected contours for primary users, and require the secondary users to check the database prior to selecting what part of the spectrum they use.  Such databases could be available on the Internet for query by users.
In a typical implementation of geolocation and database to access TV white space, a radio is configured with, or has the capability to determine its location in latitude and longitude.   At power-on, before the device can transmit or use any of the spectrum set aside for secondary use, the device must identify the relevant database to query, contact the database, provide its geolocation and receive in return a list of  unoccupied or "white space" spectrum (for example, in a TV White space implementation, the list of available channels at that location). The device can then select one of the channels from the list and begin to transmit and receive on the selected channel. The device must query the database subsequently on a periodic basis for a list of unoccupied channels based on certain conditions, e.g. a fixed amount of time has passed or the device has changed location beyond a specified threshold.
The databases are expected to be reachable via the Internet and the devices querying these databases are expected to have some form of Internet connectivity, directly or indirectly. The databases  may be country specific since the available spectrum and  regulations may vary, but the fundamental operation of the protocol should be country independent, thus extensibility of data structures will be required. The solution will not be tied to any specific spectrum, country, or phy/mac/air interface but may incorporate relevant aspects of these as needed for proper operation.
The proposed working group will :
    - standardize a protocol for querying the database, which includes a location sensitive database discovery mechanism and security for  the protocol, and application services.
    - Standardize the data structure to be carried by the query protocol.
Since the location of a user device is involved, privacy implications arise, and the protocol will have to have robust security mechanisms.
Existing IETF location data structures and privacy mechanisms may be considered for use. The WG will also investigate the need for other mechanisms and related protocols to the White Space DB.
The Working Group will set up and maintain appropriate contact and liaison with other relevant standards bodies and groups, including IEEE 802.11af and IEEE 802.22 to begin with. The working group may also consider input from regulatory entities that are involved in the specification of the rules for secondary use of spectrum in specific bands.
Milestones
Sep 2011        Submit 'Requirements and Framework' to the IESG for
      publication as Informational
Apr 2012        Submit 'Protocol for Querying a Whitespace Database'
      to the IESG for publication as Proposed Standard
Apr 2012        Submit 'Data Model for Whitespace query protocol'
      to the IESG for publication as Proposed Standard

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 31 Mar 2011 19:33:43 +0200

Hi,

I believe that the BOF went quite well. In my opinion the problem
statement seems clear, the charter proposal is in reasonable shape,
there is interest from the community and there seem to be resources
interested to do the work. The IESG and IAB will meet tomorrow morning
to review the events of the week, and part of the discussion will be
about how to proceed with the BOFs that happened this week, including
PAWS. 

Thanks and Regards,

Dan

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Richard Shockey
	Sent: Thursday, March 31, 2011 7:29 PM
	To: [email-masked]; [email-masked]
	Subject: [paws] So what happened in the BOF?