Subject: [paws] Testing and certification for devices using PAWS

From: Paul Lambert <[email-masked]>
Date: Tue, 11 Oct 2011 17:21:35 -0700

Seems like we need to consider testing and certification of WS devices.

How do we run tests?
How do we ensure access to databases of multiple regulatory authorities in multiple locations?
How do we control location? Can location be set for testing?
Are special back doors required to GDBs?
How do we establish different frequency grants for testing purposes?

Requirements:
Device-to-GDB must have facilities for testing to:
- test multiple locations
- test multiple GBD and Regional Authority GDBs
- test various frequency grants from a fixed testbed
- support international test houses

We will need real databases to have special limited backdoor for testing and certification.

Paul

---

From: <[email-masked]>
Date: Wed, 12 Oct 2011 02:53:41 +0000

Hi Paul,

Your comment below relates to how testing of the protocol between devices
to databases is done.
IMO this is beyond the scope of the actual protocol itself.

I do see the need for testing to be done in a lab with various location
settings. But this could potentially be simulated or emulated or
manipulated with some lab setting.

-Raj

On 10/11/11 7:21 PM, "ext Paul Lambert" <[email-masked]> wrote:

>_______________________________________________
>paws mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/paws

---

From: "M.K.Sajeev sajeev" <[email-masked]>
Date: Tue, 11 Oct 2011 21:25:45 -0700 (PDT)

Hi,

Scenarios mentioned here looks like end to end testing of white space radios, and certifying those. Where do these fit in? Is it in the scope of IEEE 802.22?
 
Best Regards,

Sajeev Manikkoth

________________________________
From: "[email-masked]" <[email-masked]>
To: [email-masked]; [email-masked]
Sent: Wednesday, 12 October 2011, 8:23
Subject: Re: [paws] Testing and certification for devices using PAWS

Hi Paul,

-Raj

---

From: Peter Stanforth <[email-masked]>
Date: Wed, 12 Oct 2011 06:42:13 -0400

Looks good in principle. Covers all the likely activities.  Spelling out the total extent and apportioning them a percentage is a good idea.  Not sure we can charge them 75% of something we were going to do anyway. But there will absolutely be some additional effort above and beyond to support Google.  I agree with sending something to Alan soon with a follow up call. Would be good to get some insight on how Google thinks.

---

From: <[email-masked]>
Date: Wed, 12 Oct 2011 16:24:59 +0000

Ø  testing of white space radios, and certifying those. Where do these fit in? Is it in the scope of IEEE 802.22?
If the technology to be used in the WS is WiFi, then I believe it is in scope of WiFi Alliance, www.wi-fi.org<http://www.wi-fi.org>
If the technology is going to be some 3G/4G cellular, then I believe it falls under the scope of 3GPP.
If the technology will be 802.22, then they'll have to find a certification body. Etc.

I am not sure how much ietf can help in setting up the testbed for the certification. The protocol we are supposed to work on will be able to carry location, but how that location is determined by the client (pre-configuration, GPS, other, etc) is out of paws scope. Same for frequency grants.

-          Gabor

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext M.K.Sajeev sajeev
Sent: Tuesday, October 11, 2011 9:26 PM
To: Patil Basavaraj (Nokia-CIC/Dallas); [email-masked]; [email-masked]
Subject: Re: [paws] Testing and certification for devices using PAWS

Hi,

Best Regards,

Sajeev Manikkoth

Hi Paul,

-Raj

On 10/11/11 7:21 PM, "ext Paul Lambert" <[email-masked]<mailto:[email-masked]>> wrote:

>[email-masked]<mailto:[email-masked]>

_______________________________________________
paws mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/paws

---

From: Paul Lambert <[email-masked]>
Date: Wed, 12 Oct 2011 12:13:33 -0700

> IMO this is beyond the scope of the actual protocol itself.
Perhaps - but the testability of the system has some unique issues.  Some of the solutions might include modifications to the protocol.

Paul

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, October 11, 2011 7:54 PM
> To: Paul Lambert; [email-masked]
> >How do we ensure access to databases of multiple regulatory
> authorities
> >in multiple locations?
> >We will need real databases to have special limited backdoor for
> testing
> >and certification.
> >
> >Paul
> >

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Oct 2011 15:21:35 -0400

<as individual>
Having looked into this a bit, my opinion is that the protocol does not need any special facility to support this kind of testing.  If you think it does, perhaps an example would be helpful.

Brian

---

From: Paul Lambert <[email-masked]>
Date: Wed, 12 Oct 2011 16:28:36 -0700

Humm ... seems like this could all be done with backdoors in the implementation or agreements on identified trusted database authorizes to provide testing facilities.

Paul

Paul A. Lambert | Marvell Semiconductor | +1-650-787-9141

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Wednesday, October 12, 2011 12:22 PM
> To: Paul Lambert
> Cc: [email-masked]; [email-masked]
> Having looked into this a bit, my opinion is that the protocol does not
> need any special facility to support this kind of testing.  If you
> think it does, perhaps an example would be helpful.
> 
> Brian
> 
> > Perhaps - but the testability of the system has some unique issues.
> Some of the solutions might include modifications to the protocol.
> >
> > Paul
> >
> >