Subject: [paws] RulesetInfo issue

From: Don Joslyn <[email-masked]>
Date: Tue, 10 Sep 2013 09:32:12 -0400

The INIT_RESP message contains Authority, maxLocationChange, maxPollingSecs, and RulesetIds supported by the database. The maxLocationChange and maxPollingSecs properties may be different for each RulesetId that is specified, but it appears that we're assuming these values will always apply to only the returned Authority and that all RulesetIds would always use the same values per Authority. Is it the intent that maxLocationChange returned to the device should be the minimum of the maxLocationChange for all of the RulesetIds supported by the database or should this property be a separate property for each RulesetId that is supported? The same issue applies to maxPollingSecs.

A hypothetical example where this might break... If the database supports "US" Authority and supports RulesetId = "FccTvBandWhiteSpace-2010" and RulesetId = "FccPcast3.5-2014" (made this one up), then these two rule sets would be forced to share the same values for maxLocationChange and maxPollingSecs.

Thoughts?

Thanks,
Don

---

From: Vincent Chen <[email-masked]>
Date: Tue, 10 Sep 2013 09:13:58 -0700

Don,

Thanks for bringing this up. At the F2F, we agreed to support multiple
rulesets in the AVAIL_SPECTRUM_RESP, so we would also change the INIT_RESP.

Summary:
  - RulesetInfo message changes to contain only a single rulesetId
  - There would be list of RulesetInfo messages

RulesetInfo contains:
  - authority
  - rulesetId
  - maxLocationChange
  - maxPollingSecs

INIT_RESP contains:
  - List of RulesetInfo messages
  - databaseChange

SpectrumSpec:
 - RulesetInfo
 - needsSpectrumReport
 - List of SpectrumSchedule messages

AVAIL_SPECTRUM_RESP contains:
  - timestamp
  - deviceDescriptor
  - location
  - List of SpectrumSpec messages

Does that make more sense?

-vince

On Tue, Sep 10, 2013 at 6:32 AM, Don Joslyn <[email-masked]>wrote:

> The INIT_RESP message contains Authority, maxLocationChange,
> maxPollingSecs, and RulesetIds supported by the database. The
> maxLocationChange and maxPollingSecs properties may be different for each
> RulesetId that is specified, but it appears that we’re assuming these
> values will always apply to only the returned Authority and that all
> RulesetIds would always use the same values per Authority. Is it the intent
> that maxLocationChange returned to the device should be the minimum of the
> maxLocationChange for all of the RulesetIds supported by the database or
> should this property be a separate property for each RulesetId that is
> supported? The same issue applies to maxPollingSecs.****
>
> ** **
>
> A hypothetical example where this might break… If the database supports
> “US” Authority and supports RulesetId = “FccTvBandWhiteSpace-2010” and
> RulesetId = “FccPcast3.5-2014” (made this one up), then these two rule sets
> would be forced to share the same values for maxLocationChange and
> maxPollingSecs.****
>
> ** **
>
> Thoughts?****
>
> ** **
>
> Thanks,****
>
> Don****
>
> _______________________________________________
> paws mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/paws
>
>

-- 
-vince

---

From: Don Joslyn <[email-masked]>
Date: Tue, 10 Sep 2013 14:08:24 -0400

Vince,

This makes perfect sense to me, and I'm satisfied with your proposed changes.

Thanks,
Don

From: Vincent Chen [mailto:[email-masked]]
Sent: Tuesday, September 10, 2013 12:14 PM
To: Don Joslyn
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [paws] RulesetInfo issue

Don,

Thanks for bringing this up. At the F2F, we agreed to support multiple rulesets in the AVAIL_SPECTRUM_RESP, so we would also change the INIT_RESP.

Summary:

RulesetInfo contains:
  - authority
  - rulesetId
  - maxLocationChange
  - maxPollingSecs

INIT_RESP contains:

SpectrumSpec:
 - RulesetInfo
 - needsSpectrumReport

-vince

On Tue, Sep 10, 2013 at 6:32 AM, Don Joslyn <[email-masked]<mailto:[email-masked]>> wrote:
The INIT_RESP message contains Authority, maxLocationChange, maxPollingSecs, and RulesetIds supported by the database. The maxLocationChange and maxPollingSecs properties may be different for each RulesetId that is specified, but it appears that we're assuming these values will always apply to only the returned Authority and that all RulesetIds would always use the same values per Authority. Is it the intent that maxLocationChange returned to the device should be the minimum of the maxLocationChange for all of the RulesetIds supported by the database or should this property be a separate property for each RulesetId that is supported? The same issue applies to maxPollingSecs.

Thoughts?

Thanks,
Don

_______________________________________________
paws mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/paws

--
-vince