Subject: [paws] Validating multiple rulesetIds during registration

From: Don Joslyn <[email-masked]>
Date: Tue, 10 Sep 2013 11:10:51 -0400

The REGISTRATION_REQ message includes deviceDesc which includes a list of rulesetIds. If the device includes multiple rulesetIds in the REGISTRATION_REQ message, the database should validate the included registration information against each rulesetId specified by the device. If validation fails for one or more of the rulesetIds included in the request message, there is no way to indicate in the registration response message which rulesetId failed validation.

In the event that multiple rulesetIds are specified in the registration request, if more than one requires registration and one or more fails, should we:
   a.  Return an overall error response indicating the first rulesetId that failed registration.
   b.  Return all rulesetIds that failed registration with an error message indicating the nature for each failure.

In the event that one or more rulesets fail, but also one or more rulesets are successful, should we return:
   a.  A successful response indicating the rulesets that were successful.
   b.  A failure response indicating one or more rulesets that failed.

Thanks,
Don

---

From: Vincent Chen <[email-masked]>
Date: Tue, 10 Sep 2013 09:59:28 -0700

Don,

Great points!

To be consistent with the proposed change to INIT_RESP, I think the
REGISTRATION_RESP should also contain a list of RulesetInfo messages, one
for each successful registration.

 - If any registrations are successful, the response is successful and
contains RulesetInfo messages that are successful
 - If no registrations are successful, it is an error response, with a
failure code indicating type of error (e.g., REQUIRED for missing required
fields)

Justification: When device includes multiple rultesetIds in its request
messages, it's expecting a "best efforts/best match" behavior, and this
matches that expectation.

Does that sound OK?

-vince

On Tue, Sep 10, 2013 at 8:10 AM, Don Joslyn <[email-masked]>wrote:

> The REGISTRATION_REQ message includes deviceDesc which includes a list of
> rulesetIds. If the device includes multiple rulesetIds in the
> REGISTRATION_REQ message, the database should validate the included
> registration information against each rulesetId specified by the device. If
> validation fails for one or more of the rulesetIds included in the request
> message, there is no way to indicate in the registration response message
> which rulesetId failed validation.****
>
> ** **
>
> In the event that multiple rulesetIds are specified in the registration
> request, if more than one requires registration and one or more fails,
> should we:****
>
>    a.  Return an overall error response indicating the first rulesetId
> that failed registration.****
>
>    b.  Return all rulesetIds that failed registration with an error
> message indicating the nature for each failure.****
>
> ** **
>
> In the event that one or more rulesets fail, but also one or more rulesets
> are successful, should we return:****
>
> ****
>    b.  A failure response indicating one or more rulesets that failed.****
>
> ** **
>
> Thanks,****
>
> Don****
>
> _______________________________________________
> paws mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/paws
>
>

-- 
-vince

---

From: Don Joslyn <[email-masked]>
Date: Tue, 10 Sep 2013 14:09:39 -0400

Vince,

Your proposal sounds good to me.

I wonder if anyone would be interested in also including failed Rulesets with a status that indicates what went wrong. Maybe we could add a "status" field to the RulesetInfo for that purpose?

Thanks,
Don

From: Vincent Chen [mailto:[email-masked]]
Sent: Tuesday, September 10, 2013 12:59 PM
To: Don Joslyn
Cc: [email-masked]
Subject: Re: [paws] Validating multiple rulesetIds during registration

Don,

Great points!

To be consistent with the proposed change to INIT_RESP, I think the REGISTRATION_RESP should also contain a list of RulesetInfo messages, one for each successful registration.

 - If any registrations are successful, the response is successful and contains RulesetInfo messages that are successful
 - If no registrations are successful, it is an error response, with a failure code indicating type of error (e.g., REQUIRED for missing required fields)

Justification: When device includes multiple rultesetIds in its request messages, it's expecting a "best efforts/best match" behavior, and this matches that expectation.

Does that sound OK?

-vince

On Tue, Sep 10, 2013 at 8:10 AM, Don Joslyn <[email-masked]<mailto:[email-masked]>> wrote:
The REGISTRATION_REQ message includes deviceDesc which includes a list of rulesetIds. If the device includes multiple rulesetIds in the REGISTRATION_REQ message, the database should validate the included registration information against each rulesetId specified by the device. If validation fails for one or more of the rulesetIds included in the request message, there is no way to indicate in the registration response message which rulesetId failed validation.

Thanks,
Don

_______________________________________________
paws mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/paws

--
-vince