Subject: RE : [Pce] WG feedback required on PCE Capability Discovery

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Wed, 4 May 2005 20:03:21 +0200

Hi Zhang,
 
Sorry for this delayed answer.
What you propose is interesting, but how a PCE would know detailed capabilities of other PCEs?  
Note that in some applications like inter-area TE you may end up with a large number of PCEs.
Hence this would still require an automatic mechanism allowing a PCE discovering detailed capabilities of other PCEs,
and the benefit would IMHO be reduced...
 
Best Regards,
 
JL

-----Message d'origine-----
De : Zhang Renhai [mailto:[email-masked]] 
Envoyé : samedi 30 avril 2005 10:32
À : LE ROUX Jean-Louis RD-CORE-LAN
Cc : [email-masked]
Objet : Re: [Pce] WG feedback required on PCE Capability Discovery

Hi, JL
 
If every PCE know well of the capabilities of other's PCE, before PCE reject
a request because of its computation capabilities , it can get the appropriate one and 
return it to PCC. if so ,at any time ,the PCC need not to know the detailed 
capabilities,knowing only generic PCE capabilities is enough for PCC.
Could this be  another choise?
 
Thanks.
Zhang

----- Original Message ----- 
From: LE ROUX Jean-Louis RD-CORE-LAN 
To: [email-masked] 
Sent: Monday, April 18, 2005 5:02 PM
Subject: [Pce] WG feedback required on PCE Capability Discovery

Hi all, 
 
There has been several discussions within the PCE com Design Team and among PCE discovery requirements co-authors, regarding dynamic discovery of PCE capabilities. 
 
Once we agree that there is a need for dynamic PCE capability discovery, then it appears that there are three options: 
 
Option 1: A single specific PCE discovery mechanism is used to discover all PCE capabilities (as currently required in the PCE discovery requirements I-D http://www.ietf.org/internet-drafts/draft-leroux-pce-discovery-reqs-00.txt).
 
Option 2: All PCE capabilities are discovered through added functionality in the PCE communication protocol (http://www.ietf.org/internet-drafts/draft-ash-pce-comm-protocol-gen-reqs-00.txt).
 
Option 3: Discovery of some generic PCE capabilities (computation domain, scope...) is done by the PCE discovery mechanism and discovery of detailed capabilities (e.g. type of constraints supported...) relies on the PCE communication protocol.
 
In 1) since PCC knows all PCE capabilities, it is the reponsibility of the PCC to select the appropriate PCE for a particular path computation. So, no capability-related request parameters are needed in the communication protocol, since the PCC alreay knows what is expected from the PCE.
 
In 3) PCC knows certain basic capabilities, but for the capabilities that it is unaware of, it may request specific parameters in the communication protocol when a path computation request is made to the PCE. If the PCE is not capable of the requested paramters, then appropriate failure is reported.
 
Note that this does not take into account discovery of PCE location, that can be done either statically or dynamically through functionality in the PCE discovery mechanism (here the PCE communication protocol cannot help).  
 
Note also that PCE capabilities could of course be configured statically but this is out of the scope of this discussion focused on dynamic capability discovery.
 
WG feedback on this topic would be highly desired. 
Please give us your comments and preferences regarding these three options. 
 
JL 

--------------------------------------------------------------------------------

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: Zhang Renhai <[email-masked]>
Date: Thu, 05 May 2005 10:08:40 +0800

MessageHi JL

Never mind the lateness:-)I should thank you for your reply.

The primary benefit of my advice , I think, is that it can 
reduce the PCCs's maintaining task, especially when many PCEs exit
and the capabilities or policy of PCEs may vary.In some environment,
most PCCs maybe have no or very few request to PCE, should these PCCs
maintain all capabilities of all PCEs ?This kind of maintaining will
consume a lot of resource.
By the way, according to my advice, PCE discovery mechanism is 
not only applied to PCC, but also to PCE to find the other PCE's 
capabilities, the difference is that PCE finds generic and 
detailed capabilities but PCC find only generic capabilities.

Regards,
Zhang

  ----- Original Message ----- 
  From: LE ROUX Jean-Louis RD-CORE-LAN 
  To: Zhang Renhai 
  Cc: [email-masked] 
  Sent: Thursday, May 05, 2005 2:03 AM
  Subject: RE : [Pce] WG feedback required on PCE Capability Discovery

  Hi Zhang,

  Best Regards,
   
  JL
    -----Message d'origine-----
    De : Zhang Renhai [mailto:[email-masked]] 
    Envoyé : samedi 30 avril 2005 10:32
    À : LE ROUX Jean-Louis RD-CORE-LAN
    Cc : [email-masked]
    Objet : Re: [Pce] WG feedback required on PCE Capability Discovery

    Hi, JL

    Thanks.
    Zhang

    ----- Original Message ----- 
    From: LE ROUX Jean-Louis RD-CORE-LAN 
    To: [email-masked] 
    Sent: Monday, April 18, 2005 5:02 PM
    Subject: [Pce] WG feedback required on PCE Capability Discovery

    Hi all, 

    JL