Subject: [Pce] PCE Disco Reqs v01

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Wed, 29 Jun 2005 14:00:47 +0200

Hi all,

Version 01 of the PCE discovery reqs ID has just been published
http://www.ietf.org/internet-drafts/draft-leroux-pce-discovery-reqs-01.t
xt

This version takes into account comments received during Minneapolis
session and on the list.

Here are the major changes since 00:
-Added multi-area network case in the problem statement
-Added application scenario (section 4) 
-Section 5.1 on capability discovery modified as per discussions on the
list:
	-Discovery of PCE location, PCE scopes and domain(s) under
control is mandatory
	-Capability discovery is no longer a MUST
       The list of capabilities is now out of the scope and should be
addressed in a 
       separate document.
       
-Added section 5.6 on extensibility 
-Added Security section

Section 5.5 (Discovery of PCE capacity and congestion) requires WG
feedback:
-Is there a need for the discovery of PCE capacity in terms of
computation power? This static parameter could be used to ensure
weighted load balancing of requests in case PCEs do not have the same
capacity. 
-Would it be useful that a PCE report its status as "congested" in case
it is too busy? PCCs may then use this dynamic information to prefer a
different PCE. 

Your comments/feedback would be highly welcome, especially on the above
point

Best Regards,

JL
_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Wed, 29 Jun 2005 08:03:29 -0500

Hi JL,

> -Would it be useful that a PCE report its status as "congested"
> in case it is too busy? PCCs may then use this dynamic
> information to prefer a different PCE. 

Yes, it would be useful.  Also, this is a requirement in
http://www.ietf.org/internet-drafts/draft-ietf-pce-comm-protocol-gen-req
s-00.txt (see Sections 6.1.3 and 6.1.6).

Thanks,
Regards,
Jerry

---

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Wed, 29 Jun 2005 15:23:04 +0200

Hi Jerry,

Yes, I know that this is also a requirement for the PCC-PCE com proto :-)
Actually here we are wondering if it would be useful to also rely on the dynamic PCE discovery mechanism to disclose PCE congestion status? 
It may be useful that a PCC be aware of the PCE status even in the absence of a PCC-PCE  communication session, this could avoid PCC-PCE communication setup failure...

Regards,

JL

>-----Message d'origine-----
>De : Ash, Gerald R (Jerry), ALABS [mailto:[email-masked]] 
>Envoyé : mercredi 29 juin 2005 15:03
>À : LE ROUX Jean-Louis RD-CORE-LAN; [email-masked]
>Cc : Ash, Gerald R (Jerry), ALABS
>Objet : RE: [Pce] PCE Disco Reqs v01
>
>
>Hi JL,
>
>> -Would it be useful that a PCE report its status as "congested" in 
>> case it is too busy? PCCs may then use this dynamic information to 
>> prefer a different PCE.
>

Thanks,
Regards,
Jerry