Subject: RE : [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG document ?

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Tue, 5 Jul 2005 08:37:19 +0200

Hi Eric
 
We have a security section that is IMHO quite clear in terms of masquerade, forgery...
and indirectly addresses trust models you refer to.
But I agree with you that security requirements of a PCE discovery solution would better
be addressed in a dedicated section "PCE Discovery security requirements"  rather than in the default security section.
What about the following:
 
"5.9 PCE Discovery Security Requirements
 
The PCE Discovery mechanism MUST address security issues across multiple ASes.
Key consideration MUST be given in terms of how to establish a trusted model for PCE discovery.
The PCE discovery mechanism MUST explicitly support a specific set of trust models.
 
Particularly, mechanisms MUST be defined to avoid PCE masquerade and forgery.
It MUST be possible for PCEs to authenticate PCCs and for PCCs to authenticate PCEs.
 
Also, the PCE discovery mechanism MUST be able to restrict the scope of 
discovery to a set of authorized PCCs. The identity of any PCE MUST only be learnt by authorized PCCs. 
It MUST be possible to encrypt  discovery information."  

Note that this requirement also implies the PCC-PCE communication protocol.
 
Is it fine with you if we add this section for next revision?
 
Best Regards
 
JL

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Gray, Eric
Envoyé : jeudi 30 juin 2005 17:27
À : 'JP Vasseur'
Cc : [email-masked]
Objet : RE: [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG document ?

JP,
 
    I believe this draft needs more work - particularly in the area of establishing
"security requirements" (as opposed to simple inclusion of a security section)
- before it is ready to be adopted as a WG document.
[JLLR]  
 
    Implicit in the PCE concept is the inherently undefined nature of the trust
model that may apply in any given deployment. Consequently it MUST be a
requirement that any PCE discovery mechanism explicitly supports a specific
set of trust models and that the complete set of possible solutions (assuming
the _possibility_ that one solution may not satisfy all requirements) supports
every reasonable combination of security trust models.
 
    It is imperative that this is established as a "requirement" of PCE discovery
solutions because this requirement will have a very definite effect on choices
the WG might make right away in seeking a solution.
 
    For example, assuming that we need to support a model where we assume
that it is possible for a foreign agency to mimic a valid PCE, this assumption 
will severely limit the approaches that might be used - as long as it is also a
requirement to avoid approaches that require extensive manual configuration.
 
    To further illustrate this example, this requirement would make a choice of
discovery based on broadcast/multicast announcement mechanisms much
less workable - possibly directing us more toward an authenticated directory
service approach.
 
    To accept this document as a WG document without first nailing down the
specific security requirements that we want to apply would potentially send 
the wrong message to the authors, the WG, the Internet community and - 
possibly - the IESG.
 
    It is far more important to ensure that the work has started in the right
direction than it is to drive the work to conform more closely to a time table.
 
--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of JP Vasseur
Sent: Thursday, June 30, 2005 9:53 AM
To: [email-masked]
Subject: [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG document ?

Dear WG,

draft-leroux-discovery-reqs has just been re-published, addressing several of comments received during the last meeting and on the list (very few remaining open items).

Could you provide us your feed-back on adopting draft-leroux-discovery-reqs-01.txt as a WG document ?

JP and Adrian.

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: "Gray, Eric" <[email-masked]>
Date: Tue, 5 Jul 2005 07:37:21 -0400

JL,
 
    As long as we include explicit security requirements, and define some
trust models
that we expect to support, then we are definitely moving in the right
direction. We can
figure out wording details as we go along.  In other words, I do not know
that the text 
you propose is what the WG is looking for, but including your proposed text
gives the
WG something to respond to.
 
    One relatviely small point is that there is a list of high-level
requirements in section 
3.2 (Requirements Overview) that should include some mention of security
requirements.
 
--
Eric

-----Original Message-----
From: LE ROUX Jean-Louis RD-CORE-LAN
[mailto:[email-masked]]
Sent: Tuesday, July 05, 2005 2:37 AM
To: Gray, Eric; JP Vasseur
Cc: [email-masked]
Subject: RE : [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG
document ?

Hi Eric
 
We have a security section that is IMHO quite clear in terms of masquerade,
forgery...
and indirectly addresses trust models you refer to.
But I agree with you that security requirements of a PCE discovery solution
would better
be addressed in a dedicated section "PCE Discovery security requirements"
rather than in the default security section.
What about the following:

The PCE Discovery mechanism MUST address security issues across multiple
ASes.
Key consideration MUST be given in terms of how to establish a trusted model
for PCE discovery.
The PCE discovery mechanism MUST explicitly support a specific set of trust
models.

Particularly, mechanisms MUST be defined to avoid PCE masquerade and
forgery.
It MUST be possible for PCEs to authenticate PCCs and for PCCs to
authenticate PCEs.
 
Also, the PCE discovery mechanism MUST be able to restrict the scope of 
discovery to a set of authorized PCCs. The identity of any PCE MUST only be
learnt by authorized PCCs. 
It MUST be possible to encrypt  discovery information."  

 
Best Regards
 
JL

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la
part de Gray, Eric
Envoyé : jeudi 30 juin 2005 17:27
À : 'JP Vasseur'
Cc : [email-masked]
Objet : RE: [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG
document ?

JP,
 
    I believe this draft needs more work - particularly in the area of
establishing
"security requirements" (as opposed to simple inclusion of a security
section)
- before it is ready to be adopted as a WG document.
[JLLR]  
 
    Implicit in the PCE concept is the inherently undefined nature of the
trust
model that may apply in any given deployment. Consequently it MUST be a
requirement that any PCE discovery mechanism explicitly supports a specific
set of trust models and that the complete set of possible solutions
(assuming
the _possibility_ that one solution may not satisfy all requirements)
supports
every reasonable combination of security trust models.
 
    It is imperative that this is established as a "requirement" of PCE
discovery
solutions because this requirement will have a very definite effect on
choices
the WG might make right away in seeking a solution.
 
    For example, assuming that we need to support a model where we assume
that it is possible for a foreign agency to mimic a valid PCE, this
assumption 
will severely limit the approaches that might be used - as long as it is
also a
requirement to avoid approaches that require extensive manual configuration.
 
    To further illustrate this example, this requirement would make a choice
of
discovery based on broadcast/multicast announcement mechanisms much
less workable - possibly directing us more toward an authenticated directory
service approach.

    It is far more important to ensure that the work has started in the
right
direction than it is to drive the work to conform more closely to a time
table.
 
--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of JP Vasseur
Sent: Thursday, June 30, 2005 9:53 AM
To: [email-masked]
Subject: [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG
document ?

Dear WG,

draft-leroux-discovery-reqs has just been re-published, addressing several
of comments received during the last meeting and on the list (very few
remaining open items).

Could you provide us your feed-back on adopting
draft-leroux-discovery-reqs-01.txt as a WG document ?

JP and Adrian.

---

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Tue, 5 Jul 2005 14:06:54 +0200

Hi Eric
 
> One relatviely small point is that there is a list of high-level requirements in section 
>3.2 (Requirements Overview) that should include some mention of security requirements.
 
You are right, this will be done in next revision
 
Thanks for these relevant comments
 
JL

-----Message d'origine-----
De : Gray, Eric [mailto:[email-masked]] 
Envoyé : mardi 5 juillet 2005 13:37
À : LE ROUX Jean-Louis RD-CORE-LAN
Cc : [email-masked]; JP Vasseur
Objet : RE: RE : [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG document ?

JL,
 
    As long as we include explicit security requirements, and define some trust models
that we expect to support, then we are definitely moving in the right direction. We can
figure out wording details as we go along.  In other words, I do not know that the text 
you propose is what the WG is looking for, but including your proposed text gives the
WG something to respond to.
 
    One relatviely small point is that there is a list of high-level requirements in section 
3.2 (Requirements Overview) that should include some mention of security requirements.
 
--
Eric

-----Original Message-----
From: LE ROUX Jean-Louis RD-CORE-LAN [mailto:[email-masked]]
Sent: Tuesday, July 05, 2005 2:37 AM
To: Gray, Eric; JP Vasseur
Cc: [email-masked]
Subject: RE : [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG document ?

Hi Eric

 

 
 
Best Regards
 
JL

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Gray, Eric
Envoyé : jeudi 30 juin 2005 17:27
À : 'JP Vasseur'
Cc : [email-masked]
Objet : RE: [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG document ?

JP,

 

 

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of JP Vasseur
Sent: Thursday, June 30, 2005 9:53 AM
To: [email-masked]
Subject: [Pce] Adoption of draft-leroux-pce-discovery-reqs-01.txt as WG document ?

Dear WG,

JP and Adrian.