Subject: [Pce] RE: Missing Requirement in draft-ietf-pce-comm-protocol-gen-reqs-00.txt

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Fri, 8 Jul 2005 06:49:26 -0500

JP,

> During a discussion that I had with Adrian, I noticed
> that there was no requirement for PCE communication
> protocol to support the ability to request a TE LSP path
> reoptimization. If the path of an existing TE LSP to be
> reoptimized is not provided to a stateless PCE, then this
> may lead to sub-optimal routing and thus in no
> reoptimization of the existing path although a more
> optimal path may exist.
>
> Isn't a requirement to able to support reoptimization
> requests whereby the head-end has the ability to provide
> the existing path?

Yes, I agree.

I think we can add the requirement to Section 6.1.4 'Path Computation
Requests', such as:

"The path computation request message MUST support TE LSP path
reoptimization.  Furthermore, reoptimization requests MUST include the
ability to provide the existing path, in order to ensure optimal path
routing."

OK?

Thanks,
Jerry

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: JP Vasseur <[email-masked]>
Date: Fri, 8 Jul 2005 08:17:26 -0400

Hi Jerry,

> ability to provide the existing path, in order to ensure optimal path

Sure,

Thanks.

JP.