Subject: RE: [Pce] Requirement for less-constrained path indraft-ietf-pce-comm-protocol-gen-reqs-00.txt

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Mon, 11 Jul 2005 06:27:08 -0500

Hi JP,

> Quick question ... I do not see any requirement to get less- 
> constrained TE LSP path in 
> draft-ietf-pce-comm-protocol-gen-reqs-00.txt.
> In most of the cases, when configuring a TE LSP with specific  
> attributes, one of the most challenging part consists of determining  
> the attributes values which will not result in the inability to find  
> a path in some circumstances (such as network element failures). The  
> typical case is the bandwidth. The first approach is to try to  
> compute the "closest" solutions. Another approach relies on the  
> configuration of multiple set of attributes:
> 1) The preferred set of attributes
> 2) One or more less-preferred set of attributes
> 3) Un-constrained TE LSP
> 
> When a PCE is used for TE LSP path computation, it looks to me that  
> it could be quite useful to be able to specify interest in less- 
> constrained path rather than potentially have to configure a set of  
> attributes (less optimal) which would result in several 
> rounds of PCC/ 
> PCE communication.
> 
> Isn't it a requirement that should be listed in draft-ietf-pce-comm- 
> protocol-gen-reqs-00.txt?

Sounds OK to me.  It would help if you suggested some specific text to
insert in the updated draft sent out last Thursday.

Thanks,
Jerry

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: JP Vasseur <[email-masked]>
Date: Mon, 11 Jul 2005 13:03:58 -0400

Hi Jerry,

> insert in the updated draft sent out last Thursday.

Of course, I do not want to request for additional requirements if  
SPs do not require such capabilities of course, thus I'll let SPs  
voice their opinion and in particular whether it should be a MAY,  
SHOULD or MUST.

Opinion from the WG ?

JP.