Subject: [Pce] Fw: Applications Area help requested by PCE Working Group

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 26 Aug 2005 10:28:12 +0100

Hi,

A response from the Applications Area to our enquiry about existing
protocols that we might use for PCC-PCE communications.

Your thoughts and comments please.

Thanks,
Adrian

----- Original Message ----- 
From: "Martin Duerst" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; <[email-masked]>
Cc: "'Jean Philippe Vasseur'" <[email-masked]>
Sent: Thursday, August 25, 2005 10:53 AM
Subject: Re: Applications Area help requested by PCE Working Group

> What about just defining an XML format and send it
> over HTTP? From a first look, your stuff looks extremely
> request/response-oriented. HTTP comes with a lot of what
> you need already built in, such as security,... It's
> probably not a perfect fit, but the fact that it's
> already very widely implemented will help a lot.
> If you are concerned about sending everything over
> port 80 (or are concerned that the IESG may be concerned),
> then using another port would solve that problem.
>
> If you have looked at HTTP and don't think it works,
> then telling us where you see problems will help us
> maybe come up with a better idea.
>
> Regards,    Martin.
>
> At 02:44 05/08/24, Adrian Farrel wrote:
>  >Hi,
>  >
>  >Scott helpfully forwarded my mail
>  >http://www1.ietf.org/mail-archive/web/discuss/current/msg00263.html on
8th
>  >August.
>  >
>  >We've had no responses.
>  >
>  >We believe that we need to go ahead and invent our own protocol for
this
>  >work, but we want to be sure that you folk don't think there is
something
>  >that does what we want that we should we re-use or modify slightly.
Hence
>  >this mail.
>  >
>  >Giving it until the end of the month before we go our own way.
>  >
>  >Cheers,
>  >Adrian and JP (PCE WG chairs)
>
>
>

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: Stephen Morris <[email-masked]>
Date: Sun, 28 Aug 2005 16:05:35 +0100 (BST)

Adrian
There is also an option for employing a web services
approach. In this, the PCE would implement a web
service. This is also very much the direction software
is taking generally (service oriented architecture,
J2EE, etc.).
Best wishes
Stephen

> >  >Adrian and JP (PCE WG chairs)

___________________________________________________________ 
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with voicemail http://uk.messenger.yahoo.com