Subject: RE: [Pce] I-D ACTION:draft-ietf-pce-discovery-reqs-01.txt

From: [email-masked]
Date: Tue, 16 Aug 2005 18:11:00 +0200

Hi Jean-Louis (and others),

I have a few questions related to PCE discovery that hopefully you can
clarify.

- The PCE architecture drafts suggests to reuse existing protocols for
PCE discovery, yet it does not mandate that the PCE actually participate
in these protocols. Does this mean that automated PCE discovery is
limited to specific scenarios, or should it be applicable to any
scenario (composite node, external node, IGP/BGP participant, or not
..). I can imagine it is not useful or feasible to cover every possible
scenario.

- PCE can advertise their capabilities in order for PCC to select the
appropriate PCE for their path computation. Does this also require or
assume that PCCs must understand the advertised capabilities and make
the right choice? For example, a PCE may have limited scope, yet a PCC
may not understand the scope of its path computation request and direct
it to the 'wrong' PCE. (follow-up actions could e.g. be re-direct or
forward, which is probably beyond the scope of PCE discovery)

cheers,
	Eduard

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Fri, 26 Aug 2005 14:59:33 +0200

Hi Eduard

Sorry for replying a bit late.
Please see inline, 

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] 
> Envoyé : mardi 16 août 2005 18:11
> À : LE ROUX Jean-Louis RD-CORE-LAN
> Cc : [email-masked]
> Objet : RE: [Pce] I-D ACTION:draft-ietf-pce-discovery-reqs-01.txt 
> 
> I have a few questions related to PCE discovery that 
> hopefully you can clarify.
> 
> - The PCE architecture drafts suggests to reuse existing 
> protocols for PCE discovery, yet it does not mandate that the 
> PCE actually participate in these protocols. Does this mean 
> that automated PCE discovery is limited to specific 
> scenarios, or should it be applicable to any scenario 
> (composite node, external node, IGP/BGP participant, or not 
> ..). 

PCE discovery is not limited to specific scenarii. 
It applies to external PCEs, regardless whether they are IGP/BGP participant or not.
However, PCE discovery is of course not required for composite PCEs, as in this case PCC and PCE are located on the same box... but this is not precluded, it may be used for internal service discovery within a box!

I can imagine it is not useful or feasible to cover 
> every possible scenario.

Which specific scenarii have you in mind?

> 
> - PCE can advertise their capabilities in order for PCC to 
> select the appropriate PCE for their path computation. Does 
> this also require or assume that PCCs must understand the 
> advertised capabilities and make the right choice?

> For 
> example, a PCE may have limited scope, yet a PCC may not 
> understand the scope of its path computation request and 
> direct it to the 'wrong' PCE. 

Yes, a PCC should understand PCE information disclosed, 
this is required for accurate PCE selection...

(follow-up actions could e.g. 
> be re-direct or forward, which is probably beyond the scope 
> of PCE discovery)

Yes in case of wrong selection, there could be various options:
-simply reject the request, indicating the reasons for the rejection
-reject the request an indicate a relevant PCE
-forward the request to a relevant PCE
-...

But as you mention this is beyond the scope of PCE discovery.

Thanks for these comments,

Regards

JL