Subject: RE: [Pce] About the presentation ofdraft-zhang-pce-comm-app-model-01.txt

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Fri, 5 Aug 2005 12:14:20 +0200

Hi Zhang

Please see inline 

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de Zhang Renhai
> Envoyé : mercredi 3 août 2005 15:28
> À : [email-masked]
> Objet : [Pce] About the presentation 
> ofdraft-zhang-pce-comm-app-model-01.txt
> 
> Hi, all
>  
>  Sorry for not all clear about some questions asked to me at 
> the meeting.
> I really appreciate that someone can repeat the question and 
> we can discuss more here.

Sure, here it is:

The problem you raise is valuable, race condition issues will increase in case of distributed-PCE computation with external PCEs, as the delay between path computation and path setup will increase. But I have some scalability concerns with your proposed solution: Basically one objective of PCE distribution would be to reduce the number of requests to be handled by PCEs, as this could be the bottleneck, and here actually your proposal requires sending requests to all PCEs. Hence all PCEs will support the whole PCCs' requests load.
IMHO this may significantly disminish the benefits of PCE distribution.
Anyway thanks for higlighting this problem, and for initiating discussion. 

Regards,

JL

> 
>  Actually, what I proposed surely is just applied to some 
> kind of circumstances. For example, if three PCEs are serving 
> all requests in a domain, and these PCEs are coupled closely, 
> for instance, they may be located in different box but in the 
> same tank or room, or located in different place remote to 
> each other and connected by a high speed line, so based on my 
> proposal, even only one request is sent to one of these PCE, 
> and the PCE can forward the request to other two PCEs quickly 
> to make the two PCEs maintain the request table,and this 
> delation of transmittion may be ignoed  by some tradeoff.
> The essential goal of the draft is just to use the table to 
> solve some known question.
>  I don't know how the communication for the detailed 
> discovery will be because the detailed capability is still 
> not specified now, how complicated a detailed capability 
> could be for a special request? Can a tradeoff be made 
> between below two choice for some special application:
>  
>   -saving the detailed discovery communication, 
> correspondingly sending 
>    the same request to all PCEs(or just one of these PCEs 
> like what I mentioned above)
>   -performing the detailed discovery communication for each PCC?
> 
>   Certainly,this proposal is not intent to became part of the 
> PCE communication protocol.
> 
>  Another concern of this draft is to make the requests 
> distributed to different PCE more *reasonable*, for example, 
> three PCEs in a domain, PCE1, PCE2, PCE3, and now PCE3 is 
> congested with too much requests or other reason, for the PCC 
> originating the request, which PCE else should it choose? 
> PCE1 or PCE2? what information should be used to help to 
> select again more reasonable? Based on the Global Computing 
> Table, the congesting PCE(PCE3) will know the number of 
> requests that other PCE is now dealing with, although PCE1 and
> PCE2 both are not congested now, based on the mentioned 
> information, PCE3 can select other PCE with least number of 
> requests and appropriate capability to make sure the PCC can 
> get the computation result asap, and I think the time from 
> sending request to receiving the computing result may be a 
> important consideration for some application.
> 
> Cheers,
> Zhang
> 
> 
> 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pce
> 

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: Zhang Renhai <[email-masked]>
Date: Mon, 08 Aug 2005 16:10:07 +0800

Hi, Jean Louis

  Nice to see your question again in mailing list. Please see inline.

----- Original Message ----- 
From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
To: "Zhang Renhai" <[email-masked]>; <[email-masked]>
Sent: Friday, August 05, 2005 6:14 PM
Subject: RE: [Pce] About the presentation ofdraft-zhang-pce-comm-app-model-01.txt

Hi Zhang

Please see inline 

Sure, here it is:

JL->The problem you raise is valuable, race condition issues will increase in case of distributed-PCE computation with external PCEs, as the delay between path computation and path setup will increase. But I have some scalability concerns with your proposed solution: Basically one objective of PCE distribution would be to reduce the number of requests to be handled by PCEs, as this could be the bottleneck, and here actually your proposal requires sending requests to all PCEs. Hence all PCEs will support the whole PCCs' requests load.

ZRH---->Sending requests to all PCEs is a method to make it possible that each PCE can know the current resources application status, and accordingly
can sort order for the requests which may be computed in different PCEs, for example, req1 and req2 are send repectively to PCE1, PCE2, and req1 has
a lower priority than req2, but if PCE1 doesn't know that there is another req with a higher priority(req2 is sent to PCE2),  it may take the resource that req2
may also need and only suffice one request. Then when PCE2 is computing the path for req2 later, what about the result? teardown the first path computed 
for req1? or reply the failure of the computation for req2?
So if both the PCE1 and PCE2 know the all the current requests, based on some policies configured by operator, PCE1 can delay the computation for req1,
to get the computation orderly and make sure the resources distributed reasonably.

JL->IMHO this may significantly disminish the benefits of PCE distribution.

ZRH--->Each PCE knowing all the requests doesn't means to add the load of computation to each PCE, it's just give each PCE enough information to make the PCEs working cooperatively. See the example again, PCE1 knows there are being two requests but only computes req1, PCE2 knows there are being two but 
only computes req2.

Thanks and Regards,
Zhang

JL->Anyway thanks for higlighting this problem, and for initiating discussion. 

Regards,

JL