Subject: RE: [Pce] Choosing the PCE protocol

From: "Zafar Ali \(zali\)" <[email-masked]>
Date: Tue, 4 Oct 2005 12:28:13 -0400

Hi, 
 
I agree w/ the comments made by Dean. It is also important to realize
that the PCE communication protocol is a control plane protocol, not a
management plane protocol: hence it is of the utmost importance to
minimize communication overhead (see Dean's comment on communication
overhead).  
 
Thanks
 
Regards... Zafar
 
>To: "Adrian Farrel" <adrian at olddog.co.uk>, <pce at ietf.org> 
>Subject: RE: [Pce] Choosing the PCE protocol 
>From: "Dean Cheng \(dcheng\)" <dcheng at cisco.com> 
>Date: Mon, 3 Oct 2005 15:30:13 -0700 
>Cc: 
>List-archive: <http://www1.ietf.org/pipermail/pce> 
>List-help: <mailto:[email-masked]?subject=help> 
>List-id: Path Computation Element <pce.lists.ietf.org> 
>List-post: <mailto:[email-masked]> 
>List-subscribe: <https://www1.ietf.org/mailman/listinfo/pce>,
<mailto:[email-masked]?subject=subscribe> 
>List-unsubscribe: <https://www1.ietf.org/mailman/listinfo/pce>,
<mailto:[email-masked]?subject=unsubscribe> 
>Sender: pce-bounces at lists.ietf.org 
>Thread-index: AcXFDbZz2JEoluA8QS2YadSDtllKogDWGX5Q 
>Thread-topic: [Pce] Choosing the PCE protocol 
>
>-----------------------------------------------------------------------
---------
>
>Hi,
>
>  I don't think HTTP is a good candidate for the PCE application
>  and here are some weakness one could think of, if it used for
>  PCE application: 
> 
>    1) The HTTP is specifically designed for communications between
>       web server and its client, or applications in that nature. 
>       Although it is possible to add extensions to support PCE
>       application, it would require a considerable amount of work.
>       That is not worth of the effort given the much smaller and
>       narrower application scope of PCE.
> 
>    2) The payload of HTTP messages (both request and response)
>       is in form of byte stream, which is unstructured comparing 
>       to the PCEP proposal, where the content is structured with
>objects.
>       For the PCE application, the object based format is more 
>       efficient in terms of processing.
> 
>    3) The HTTP does not have unsolicited messages such as Notification
>       message and Error message that are defined by PCEP.
> 
>    4) PCE architecture allows a PCE functions as a server but also as
>       a client communicating with another PCE server. In both cases, 
>       the same protocol is used. PCEP supports this scenario. There
>       requires some work to make HTTP behavior as such.
> 
>Dean

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: Anca Zamfir <[email-masked]>
Date: Tue, 04 Oct 2005 13:54:30 -0400

I agree. Also here are some advantages of PCEP:
- draft-vasseur-pce-pcep-02.txt meets the PCE requirements as stated in 
draft-ietf-pce-comm-protocol-gen- reqs-02.txt
- It is a lightweight protocol with a simple and clean state machine.
- Looks that it is easily extensible for new future requirements (by adding new 
messages or objects).
- It has small number of messages and objects.
- Could reuse the mechanisms which have been already defined  and deployed in 
other protocols.
- Reuses of TCP for reliable messaging, flow control, security, etc.
- Supports solicited and unsolicited communication messages.

Cheers,
Anca

Zafar Ali (zali) wrote:
> ------------------------------------------------------------------------
>