Subject: RE: [Pce] WG Last Call ended on draft-ietf-pce-architecture-02.tx t

From: "Gray, Eric" <[email-masked]>
Date: Fri, 14 Oct 2005 19:06:33 -0300

Lou,

	What would be the point?  Then it is merely a traffic
engineer application.

--
Eric

--> -----Original Message-----
--> From: Lou Berger [mailto:[email-masked]]
--> Sent: Friday, October 14, 2005 5:30 PM
--> To: Gray, Eric
--> Cc: Berger, Lou; Gray, Eric; Ash, Gerald R (Jerry), ALABS; 
--> Gray, Eric;
--> Ash, Gerald R (Jerry), ALABS; [email-masked]
--> Subject: RE: [Pce] WG Last Call ended on
--> draft-ietf-pce-architecture-02.txt
--> 
--> 
--> humm, can't it be used within a single domain?
--> 
--> Lou
--> 
--> At 05:26 PM 10/14/2005, Gray, Eric wrote:
--> 
--> >Lou,
--> >
--> >         MDPC Architecture is less misleading...
--> >
--> >--
--> >Eric
--> >
--> >--> -----Original Message-----
--> >--> From: Lou Berger 
--> [<mailto:[email-masked]>mailto:[email-masked]]
--> >--> Sent: Friday, October 14, 2005 4:31 PM
--> >--> To: Gray, Eric
--> >--> Cc: Berger, Lou; Ash, Gerald R (Jerry), ALABS; Gray, Eric;
--> >--> Ash, Gerald R
--> >--> (Jerry), ALABS; [email-masked]
--> >--> Subject: RE: [Pce] WG Last Call ended on
--> >--> draft-ietf-pce-architecture-02.txt
--> >-->
--> >-->
--> >--> At 04:25 PM 10/14/2005, Gray, Eric wrote:
--> >-->
--> >--> >Uh, PC (Path Computation)?  MDPC (multi-domain path 
--> computation)?
--> >--> >
--> >--> >What do you think PCE itself stands for in this - 
--> larger - context?
--> >--> >Certainly nothing intuitive.
--> >-->
--> >--> precisely the point!
--> >-->
--> >--> >Rather than change an intuitively meaningful acronym 
--> to accommodate
--> >--> >an arbitrary (and intuitively meaningless) misuse, why not
--> >--> stop using
--> >--> >the acronym in the larger sense?
--> >-->
--> >--> I'm completely fine with this.  So does the "PCE Architecture"
--> >--> document become  "PC Architecture"?
--> >-->
--> >--> Lou
--> >-->
--> >--> >--
--> >--> >Eric
--> >--> >
--> >--> >--> -----Original Message-----
--> >--> >--> From: Lou Berger
--> >--> 
--> >[<<mailto:[email-masked]>mailto:[email-masked]>mailto
:[email-masked]]
--> >--> >--> Sent: Friday, October 14, 2005 4:14 PM
--> >--> >--> To: Ash, Gerald R (Jerry), ALABS
--> >--> >--> Cc: Gray, Eric; Berger, Lou; Ash, Gerald R (Jerry), ALABS;
--> >--> >--> [email-masked]
--> >--> >--> Subject: RE: [Pce] WG Last Call ended on
--> >--> >--> draft-ietf-pce-architecture-02.txt
--> >--> >-->
--> >--> >-->
--> >--> >--> Gerry,  Eric,
--> >--> >-->          So what term do you use when referring to the
--> >--> >--> identification
--> >--> >--> of paths using PCCs and PCEs?  The architecture
--> >--> document seems to
--> >--> >--> also call this PCE.
--> >--> >-->
--> >--> >--> Having PCE refer to the whole process and also to a
--> >--> >--> component in the
--> >--> >--> process seems to be very confusing, and it'll only get
--> >--> >--> worse as time
--> >--> >--> goes on and the amount of material and discussions
--> >--> increase. IMO it
--> >--> >--> would be better to endure the small pain now to fix
--> >--> the limited set
--> >--> >--> of documents we have now rather than having to endure
--> >--> all the pain
--> >--> >--> and confusion for years to come.
--> >--> >-->
--> >--> >--> Lou
--> >--> >-->
--> >--> >--> At 02:07 PM 10/14/2005, Ash, Gerald R \(Jerry\), 
--> ALABS wrote:
--> >--> >-->
--> >--> >--> >Eric,
--> >--> >--> >Lou,
--> >--> >--> >
--> >--> >--> > > PCE stands for "Path Computation Engine"
--> >--> >--> >
--> >--> >--> >'PCE' stands for 'Path Computation Element'.
--> >--> >--> >
--> >--> >--> > > PCS when talking the computing/server component.
--> >--> >--> >
--> >--> >--> >'PCS' was the old name for 'PCE', however 'PCS'
--> >--> connotes too much a
--> >--> >--> >separate 'server' implementation of 'PCE' (which doesn't
--> >--> >--> have to be a
--> >--> >--> >separate network element, but can be 'composite'), so
--> >--> >--> 'PCS' terminology
--> >--> >--> >was replaced by 'PCE'.
--> >--> >--> >
--> >--> >--> >Thanks,
--> >--> >--> >Jerry
--> >--> >-->
--> >-->
--> 

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: Lou Berger <[email-masked]>
Date: Sat, 15 Oct 2005 10:57:01 -0400

>         What would be the point?  Then it is merely a traffic

Eric,
         The PCE Architecture doesn't limit PCE to multi-domain 
networks.  to quote:
    "... Path computation in large, multi-domain, multi-region or
    multi-layer networks is complex and may require special
    computational components and cooperation between the different
    network domains."

Lou

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 16 Oct 2005 23:22:21 +0100

Hello,

Nice to see some bandwidth being used.

"PCE Architecture" -- an architecture that includes a PCE.

"PCE" -- something that performs path computation.

"PCC" -- something that requests path computation.

In the Abstract...
   This document specifies the architecture for a Path Computation
   Element (PCE)-based model.

Is it really necessary to then state... "We will term this architecture
the PCE Architecture" ?

I believe that at no other point in the architecture document is there a
reference to "PCE" that means "PCE architecture" except it says explicitly
"PCE architecture". I would be happy for you to point out places where
this is a problem.

In other documents (such as draft-ietf-pce-comm-protocol-gen-reqs-02.txt)
appear to make exactly the same distinction.

Thus, there is no use of the term "PCE" to mean an architecture. It is
always used to mean a network element. There is no need to (re-)introduce
the term "PCS" because it is isomorphic to "PCE" as currently defined.

Thanks,
Adrian

----- Original Message ----- 
From: "Lou Berger" <[email-masked]>
To: "Gray, Eric" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Saturday, October 15, 2005 3:57 PM
Subject: RE: [Pce] WG Last Call ended on
draft-ietf-pce-architecture-02.txt

---

From: Lou Berger <[email-masked]>
Date: Sun, 16 Oct 2005 19:07:50 -0400

Sure, but we have many existence proofs that having a name to refer 
to a technology that isn't simply a piece of the instantiation of the 
technology is goodness, routing!=ospf architecture, MPLS != routing 
architecture, signaling != rsvp/ldp architecture...

I can live with what we have but think we're going to have more 
confusion and terminology arguments as a result.

Lou

PS so what do you call the architecture of a device that is a PCE, 
PCE device architecture?

At 06:22 PM 10/16/2005, Adrian Farrel wrote:

> <https://www1.ietf.org/mailman/listinfo/pce>https://www1.ietf.org/mailman/listinfo/pce 
>
> >
> >

---

From: "Igor Bryskin" <[email-masked]>
Date: Mon, 17 Oct 2005 09:21:05 -0400

Adrian,

My personal preferrences:

PCE - Path Computation Entity - entity involved in PCE Architecture, a
common term for PCS and PCC
PCC - Path Computation Client - entity requesting path computation
PCS - Path Computation Server - entity that can satisfy path computation
request

In your view PCE = PCS, and hence PCE Architecture is still mostly about
servers. Yes, you did put a section about PCC, but PCC is still kind of a
step-son compared to PCS. I beileve PCC is as important as PCS, and PCE
architecture is about PCCs as about PCSs. Therefore, PCS is a tighter and
less confusing term for the path computation server than PCE.

Igor

---

From: JP Vasseur <[email-masked]>
Date: Mon, 17 Oct 2005 09:34:48 -0400

Hi Igor,

> less confusing term for the path computation server than PCE.

I fully agree with Adrian: there is no need to re-introduce the term  
PCS here which by the way did generate a lot a confusion several  
years ago.

Thanks.

JP.