Subject: RE: [Pce] comments on draft-ietf-pce-pcecp-interarea-reqs-00.txt

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Mon, 13 Feb 2006 18:44:31 +0100

Hi Dimitri

Please see inline, 

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de dimitri 
> papadimitriou
> Envoyé : lundi 13 février 2006 17:11
> À : [email-masked]
> Objet : [Pce] comments on draft-ietf-pce-pcecp-interarea-reqs-00.txt
> 
> folks,
> 
> the document mentions
> 
>    "A solution for computing inter-area TE-LSP path relies on a per
>     domain path computation ([PD-COMP]). It is based on loose 
> hop routing
>     with an ERO expansion on each ABR. This can allow setting up a
>     constrained path, but faces two major limitations:
>          -This does not allow computing an optimal constrained path
>          -This may lead to several signalling crankback messages and
>           hence delay the LSP setup, and invoke routing activities. "
> 
> optimal computation does not imply resource reservation, 
> hence a PCE functionality does not prevent from crankback

Sure, but it drastically reduces crankback probability.
Btw, the above text never say that a PCE prevents from crankback...

> 
> section 5 present two models, would it be possible to 
> consider that homogeneity is not necessarily verified, e.g. 
> an area having a single ABR does not a PCE to reach the local 
> exit point

Could you clarify please?

> 
> section 7.13 should discuss scaling wrt to the TEDB wrt to 
> single PCE model it is stated that such consideration is 
> beyond the scope of the document i would more than certainly 
> re-consider this since this a necessary condition for 
> supporting the "all area" PCE model (is this not a single 
> point of failure ? or are specifics in terms of resilience 
> outside the scope of this document)

Note that this draft discusses PCECP requirements and hence this section is dedicated to PCECP scalability. This is why TEDB size is out of the scope.
By the way, please note that we are going to move models description (section 5) to an applicability statement draft to be posted soon.

Thanks

JL

> 
> thanks,
> - dimitri.
> 
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pce
> 

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: dimitri papadimitriou <[email-masked]>
Date: Mon, 13 Feb 2006 19:41:01 +0100

hi jean-louis

LE ROUX Jean-Louis RD-CORE-LAN wrote:

> Hi Dimitri
> 
> Please see inline,
> 
> 
>> -----Message d'origine----- De : [email-masked] 
>> papadimitriou Envoyé : lundi 13 février 2006 17:11 À : [email-masked]
>>  Objet : [Pce] comments on
>> draft-ietf-pce-pcecp-interarea-reqs-00.txt
>> 
>> folks,
>> 
>> the document mentions
>> 
>> domain path computation ([PD-COMP]). It is based on loose hop
>> routing with an ERO expansion on each ABR. This can allow setting
>> up a constrained path, but faces two major limitations: -This does
>> not allow computing an optimal constrained path -This may lead to
>> several signalling crankback messages and hence delay the LSP
>> setup, and invoke routing activities. "
>> 
>> optimal computation does not imply resource reservation, hence a
>> PCE functionality does not prevent from crankback
> 
> Sure, but it drastically reduces crankback probability. Btw, the
> above text never say that a PCE prevents from crankback...

just wanted to avoid confusion in one way or the other, i guess slight
rephrasing may help here

>> section 5 present two models, would it be possible to consider that
>> homogeneity is not necessarily verified, e.g. an area having a
>> single ABR does not a PCE to reach the local exit point
> 

the proposed models assume that there are always multiple exit points
per area (two) ... hence the question even if there is only ABR hence
not much to do in terms of selection the exit point, is the path comp.
sequence identical ?

>> section 7.13 should discuss scaling wrt to the TEDB wrt to single
>> PCE model it is stated that such consideration is beyond the scope
>> of the document i would more than certainly re-consider this since
>> this a necessary condition for supporting the "all area" PCE model
>> (is this not a single point of failure ? or are specifics in terms
>> of resilience outside the scope of this document)
> 
> Note that this draft discusses PCECP requirements and hence this
> section is dedicated to PCECP scalability. This is why TEDB size is
> out of the scope.  By the way, please note that we are going to move
> models description (section 5) to an applicability statement draft to
> be posted soon.

does it mean you are going to discuss the scalability issues in the 
latter document ?

thanks,
- dimitri.

> Thanks
> 
> JL
> 
> 
>> thanks, - dimitri.
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> _______________________________________________ Pce mailing list 
>> [email-masked] https://www1.ietf.org/mailman/listinfo/pce
>> 
> 
> 
> .
>