Subject: [Pce] RE: Objective functions in PCECP (draft-ietf-pce-comm-protocol-gen-reqs-04.txt)

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Thu, 16 Feb 2006 12:13:24 +0100

Hi Filippo
 
Please note that "MAY include" =/= "MUST support the inclusion"...
 
>As a general comment: is it really a must to include in a communication protocol information that may be common for all requests? 
>maybe something could be better done through configuration
 
No the inclusion is a MAY, but the protocol MUST allow you to do it if you want...

Regards,
 
JL

________________________________

	De : Filippo Cugini [mailto:[email-masked]] 
	Envoyé : mercredi 15 février 2006 15:59
	À : [email-masked]; LE ROUX Jean-Louis RD-CORE-LAN
	Cc : [email-masked]
	Objet : Objective functions in PCECP (draft-ietf-pce-comm-protocol-gen-reqs-04.txt)

	Hi,
	 
	In section 3 (Introduction):
	[..] The path computation request [..] MAY also include an objective function.
	In the rest of the document, MUST is always used instead of MAY
	 
	One comment about the use of "MUST" related to objective functions.
	In my view some information are request-specific (source, dest, bandwidth..),others are general (e.g., objective functions), i.e. they should be the same for every request. For example, what about the overall network resource utilization (i.e. optimization) if PCC requires different objective functions for different requests?
	 
	As a general comment: is it really a must to include in a communication protocol information that may be common for all requests? maybe something could be better done through configuration
	 
	Thank you
	  Filippo

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: "Filippo Cugini" <[email-masked]>
Date: Thu, 16 Feb 2006 16:16:54 +0100

Hi JL,

Ok for the distinction, however, I still think objective functions should not be included in PCECP. 

It is not clear to me why PCC should require different objective functions for different requests. 

Moreover, in case of PCE-PCE request, a PCE could affect TE optimization also within other domains.

Thank you 

  Filippo

  ----- Original Message ----- 
  From: LE ROUX Jean-Louis RD-CORE-LAN 
  To: Filippo Cugini ; [email-masked] 
  Cc: [email-masked] 
  Sent: Thursday, February 16, 2006 12:13 PM
  Subject: RE: Objective functions in PCECP (draft-ietf-pce-comm-protocol-gen-reqs-04.txt)

  Hi Filippo

  Regards,

  JL

----------------------------------------------------------------------------

    Hi,

    Thank you
      Filippo