Subject: [PCE]Comments about draft-ietf-pce-architecture-05

From: Mach Chen <[email-masked]>
Date: Sat, 27 May 2006 10:38:37 +0800

Hi,Adrian,Vasseur,Ash
    I just have finished read the draft,it's good.

    Here I have a question about section "5.5 Management-Based PCE Usage".NMS as the PCC sends service request to PCE and gets the response,then supplies the head-end LSR with computed path.why not PCE sends the response with service request direct to the head-end? AS it just looks like the figure as below:
    
                                 -----------
                                |   -----   |
            Service             |  | TED |<-+----------->
            Request             |   -----   |  TED synchronization
               |                |     |     |  mechanism (for example,
               v                |     |     |  routing protocol)
         -------------          |     v     |
        |             | Request |   -----   |
        |     NMS     |---------+> | PCE |  |
        |             |         |   -----   |
         -------------           -----------
                              Service |Response
                              Request |
                                      v
                               ----------  Signaling  -----------
                              | Head-End | Protocol  | Adjacent  |
                              |   Node   |<--------->|   Node    |
                               ----------             -----------

If so ,we can reduce the complication and burden of NMS,and increase the efficiency (NMS don't need  to transfer respone between PCE and head-end).

Regards,

Mach Chen

Huawei Technologies, Beijing,China
_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: JP Vasseur <[email-masked]>
Date: Sat, 27 May 2006 09:29:43 -0400

Hi,

On May 26, 2006, at 10:38 PM, Mach Chen wrote:

>     Here I have a question about section "5.5 Management-Based PCE  
> Usage".NMS as the PCC sends service request to PCE and gets the  
> response,then supplies the head-end LSR with computed path.why not  
> PCE sends the response with service request direct to the head-end?

Because the architecture defines the interaction between a PCC and a  
PCE and in this case the NMS acts as a PCC. If A asks a question to  
B, B may answer to C but the dialogue may quickly be confusing.

Thanks.

JP.

> AS it just looks like the figure as below:
>
>                                  -----------
>                                 |   -----   |
> If so ,we can reduce the complication and burden of NMS,and  
> increase the efficiency (NMS don't need  to transfer respone  
> between PCE and head-end).
>
> Regards,
>
> Mach Chen
>