Subject: [Pce] a question about draft-vasseur-ccamp-ce-ce-te-01

From: xiahongmiao <[email-masked]>
Date: Tue, 15 Aug 2006 18:01:10 +0800

Hi, JP,

In your draft draft-vasseur-ccamp-ce-ce-te-01, CE-to-CE LSP compute as follows:

>   Step 1: The ingress CE (e.g.  CE1) selects a PCE (say PE1).

>   Step 2: Upon receiving the PCReq message from CE1, PE1 (acting as a
>   PCE) determines the set S of PEs with a PE-CE link to the destination
>   CE (e.g.  CE2).  The following VSPT is then computed:

>   VSPT computed by the ingress PE acting as a PCE

>                 CE2
>               /    \
>              PE1  PE2

>   Step 3: The shortest constrained path is then returned to CE1 in the
>   form of a PCRep message (with loose hop).

Here, I have a question and I think the PE should know just membership of PE-CE
link, instead of PE-CE link TE attribute. Ingress PE looks for egress PE with 
this information. Could you tell me the truth?

Thanks,
xiahongmiao
_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: JP Vasseur <[email-masked]>
Date: Thu, 17 Aug 2006 09:42:55 +0200

Hi,

> this information. Could you tell me the truth?

The ingress PE computes the shortest constrained TE LSP from CE to  
CE, thus the PE-CE TE Link attribute is required, not just the MPLS  
VPN membership.

Thanks.

JP.