Subject: [Pce] a question on BRPC

From: XingFeng Jiang <[email-masked]>
Date: Fri, 04 Aug 2006 16:38:45 +0800

Hi, JP:

I have read your draft, draft-vasseur-pce-brpc-01.txt, and I have a
question.

In Draft:

   Step 2: PCE(n) computes VSPT(n) made of the list of shortest

   constrained path(s) between every BR-en(j,n) and the TE LSP

   destination using a suitable path computation algorithm (e.g.  CSPF)

   and returns the computed VSPT(n) to PCE(n-1).

 My question is: How does PCE know who are the entry nodes or exit nodes of
a domain? Lack of this information, PCE can not compute the path in the
domain. If the information is included in the predetermined domain path set?

Maybe the question is naïve and simple; could you give me some explanations?

Thanks

 XingFeng Jiang

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: JP Vasseur <[email-masked]>
Date: Thu, 17 Aug 2006 09:27:55 +0200

Hi,

On Aug 4, 2006, at 10:38 AM, XingFeng Jiang wrote:

>  My question is: How does PCE know who are the entry nodes or exit  
> nodes of a domain? Lack of this information, PCE can not compute  
> the path in the domain. If the information is included in the  
> predetermined domain path set?
>
Sure, for inter-area, the answer is pretty straightforward (you can  
easily monitor the set of ABR/L1L2 announcing a route for the  
destination) and a similar approach can be used for Inter-AS (BGP).  
Alternatively, the set of BN can be locally configured on the PCE  
(note that some BN can be excluded by policy, providing that this may  
prevent from finding the shortest constrained inter-domain path).

Thanks.

JP.

---

From: JiangXingFeng <[email-masked]>
Date: Fri, 18 Aug 2006 11:46:39 +0800

Hi，JP：

   Thanks for your clarifications. With regard to BRPC, I have other questions inline, please enlighten me. 

1. <<  Note that PCE(i) only considers the entry BNs that provide connectivity from domain(i-1).  

Comment: What does the *only* means? How does the PCE(i) learn the entry BNs connected to domain(i-1)? 

Is it locally configured on PCE(i)?

2.<< That is, the set BN-en(k,i-1) is only made of those BNs that provide connectivity from domain (i-1) to  domain(i).  

Comments: Maybe there should be BN-en(k,i),not BN-en(k,i-1); BN-en(k,i-1)  provide connectivity from domain(i-2) to domain(i-1);

3. there is a scenario below.

     <-- AS 1 ---> <------- AS 2 -----><--- AS 4 ---->

     R0----ASBR1-----ASBR2—R2---ASBR4----ASBR9----R6

             \                          /

              \                        /

                 \                      / 

\ ASBR3--R3-R4-ASBR5/

<------- AS 3 ----->

In the above figure, a TE-LSP tunnel between RO and R6 is requested. The figure intends to illustrate. The relationship between ASs is more complicated than it.

Between RO and R6, there are two different domain path, AS1<->AS2<->AS4 and AS1<->AS3<->AS4. Before the path computation, the domain path should be determined.

If the PCE choose any path among them, maybe the result of BRPC is not the optimal path. In my opinion, all domain paths should be involved in the computation process, if the policy is not considered.

Maybe, a dynamically mechanism is required to facilitate the computation of the optimal path. 

Thanks!

JiangXingFeng

  _____  

发件人: JP Vasseur [mailto:[email-masked]] 
发送时间: 2006年8月17日 15:28
收件人: XingFeng Jiang
抄送: [email-masked]
主题: Re: a question on BRPC

Hi,

I have read your draft, 

Â Â  Step 2: PCE(n) computes VSPT(n) made of the list of shortest

Â Â  destination using a suitable path computation algorithm (e.g.Â  CSPF)

Â 

Maybe the question is naÃ¯ve and simple; could you give me some explanations?

Sure, for inter-area, the answer is pretty straightforward (you can easily monitor the set of ABR/L1L2 announcing a route for the destination) and a similar approach can be used for Inter-AS (BGP). Alternatively, the set of BN can be locally configured on the PCE (note that some BN can be excluded by policy, providing that this may prevent from finding the shortest constrained inter-domain path).

Thanks.

JP.

Â 

Â XingFeng Jiang

Â