Subject: [Pce] comments on draft-vijay-somen-pce-disco-proto-bgp-00.txt

From: JiangXingFeng <[email-masked]>
Date: Mon, 14 Aug 2006 16:35:18 +0800

Hi, Vijayanand:

   I have read your draft, here are some comments.

1.

>>  The PCE information can be distributed across AS boundaries 

>> using E-BGP sessions. BGP policy can be used to control the import 

>> and export of PCE information similar to existing controls over the 

>> distribution of normal BGP routes. The normal BGP decision process 

>> will not be applied to the received PCE information.

Comments: From the above, I can conclude that I-BGP sessions are not used to
distribute information in one AS. 

It only depends on IGP extensions to redistribute the remote PCE information
into the ASBR, and then it is the duty of ASBR to distribute it further.

Do I understand correctly? Could you give me some clarifications? 

2. antother question is :  Up to now, the methods of path computation are
mostly based on a predetermined domain path. The PCEs taking part in the
computation mostly are statically configured. PCC or PCE may learn the pce
information out of the AS, but I think the most important problem is to
determine which PCEs will coooperate to achieve the computation. Could you
give me some explanations about how to integrate your idea into the path
computation process? 

Thanks.

JiangXingFeng

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: "Vijayanand C - TLS, Chennai." <[email-masked]>
Date: Thu, 17 Aug 2006 12:13:32 +0530

Hi.

To answer your questions:

1.	BGP is intended to carry the discovery information across IGP
domains so usually it should get redistributed into the IGP, however, the
operator may decide when and how to effect this redistribution ( may be
policy controlled)
2.	 The discovery mechanism provides information that 'this PCE can
compute paths on behalf of this AS' and the other capabilities. Based on
that the appropriate PCE has to be chosen. The destination or next AS on the
path should be known for this ( from configuration or other routing
information)

Regards,

Vijay

-----Original Message-----
From: JiangXingFeng [mailto:[email-masked]] 
Sent: Monday, August 14, 2006 2:05 PM
To: [email-masked]
Cc: [email-masked]
Subject: comments on draft-vijay-somen-pce-disco-proto-bgp-00.txt

Hi, Vijayanand:

1.

Thanks.

JiangXingFeng

DISCLAIMER 
The contents of this e-mail and any attachment(s) are confidential and intended for the 

named recipient(s) only. It shall not attach any liability on the originator or HCL or its 

affiliates. Any views or opinions presented in this email are solely those of the author and 

may not necessarily reflect the opinions of HCL or its affiliates. Any form of reproduction, 

dissemination, copying, disclosure, modification, distribution and / or publication of this 

message without the prior written consent of the author of this e-mail is strictly 

prohibited. If you have received this email in error please delete it and notify the sender 

immediately. Before opening any mail and attachments please check them for viruses and 

defect.