Subject: [Pce] Fwd: ID Monitoring

From: JP Vasseur <[email-masked]>
Date: Tue, 3 Apr 2007 08:30:49 -0400

Begin forwarded message:

> From: JP Vasseur <[email-masked]>
> Date: March 29, 2007 3:32:18 PM EDT
> To: PAPADIMITRIOU Dimitri <[email-masked]>
> Cc: [email-masked]
> Subject: ID Monitoring
>
> Hi Dimitri,
>
> In order to move forward here ...
>
> Could you list the set of items for which you'd like a clarification ?
>
> Thanks.
>
> JP.

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: "fabien.verhaeghe" <[email-masked]>
Date: Thu, 26 Apr 2007 08:26:04 +0200

>Hi, 
>
>
>On Apr 25, 2007, at 3:53 AM, fabien.verhaeghe wrote:
>
>
>>Hello All,
>>
>>Quick question about PCEP section 7.1 Common object header:
>>
>>   "If the PCE does not understand an object with the P flag set or
>>   understands the object but decides to ignore the object, the entire
>>   PCEP message MUST be rejected and the PCE MUST send a PCErr message
>>   with Error-Type="Unknown Object" or "Not supported Object"."
>>
>>Why rejecting the entire PCReq message? Why not just rejecting the request that contains the 
>>unknown/not supported object and send a PCErr with the rejected Request Id?
>>
>>

>
>
>You mean in case the message would contain more than one requests ?
>

Yes exactly.
I understand it makes sense for synchronized requests listed in an SVEC object.
But for independent requests I'm not sure why we should reject all requests because one
of them has an "unknown/not supported" object.

>>Regards
>>Fabien