Subject: [Pce] I-D Action: draft-ietf-pce-pcep-mib-04.txt

From: [email-masked]
Date: Tue, 19 Feb 2013 07:15:04 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Path Computation Element Working Group of the IETF.

	Title           : PCE communication protocol (PCEP) Management Information Base
	Author(s)       : A S Kiran Koushik
                          Stephan Emile
                          Quintin Zhao
                          Daniel King
                          Jonathan Hardwick
	Filename        : draft-ietf-pce-pcep-mib-04.txt
	Pages           : 43
	Date            : 2013-02-19

Abstract:
   This memo defines an experimental portion of the Management
   Information Base for use with network management protocols in the
   Internet community.  In particular, it describes managed objects for
   modeling of Path Computation Element communication Protocol (PCEP)
   for communications between a Path Computation Client (PCC) and a Path
   Computation Element (PCE), or between two PCEs.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-mib

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-pce-pcep-mib-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pcep-mib-04

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jonathan Hardwick <[email-masked]>
Date: Tue, 19 Feb 2013 15:17:40 +0000

Here is a new version of the PCEP MIB.  There have been a number of changes since the last revision.  Here is a run-down of the most important ones.

1. The MIB is now read-only and is used to report status.  I believe that this brings it in line with current practice for new MIBs.

2. There has been a structural change to the PCEP session MIB to reflect the possibility that two PCEP sessions may transiently exist between a pair of PCEP speakers, before one of the sessions reaches the 'up' state.  This has been accommodated by adding a new index field "pcePcepSessInitiator" to the session MIB, indicating which side initiated the TCP connection.

There is a simpler alternative, which is to ban sessions from appearing in this MIB until they are 'up', but I came down on the side of wanting to see all sessions in the MIB including those not yet established.

3. A load of statistics have been added to the peer and session MIBs.  These are mostly counts of messages, requests, errors and so on.  The values in the peer MIB track statistics across all sessions to a given peer, whereas the values in the session MIB track statistics for this session only.

I decided that the possibility of short-lived sessions meant that we should have both sets of statistics available.  However, this causes a high degree of duplication between the MIBs.

Please let me have any comments, particularly if you disagree with any of directions we are .

Regards
Jon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 19 February 2013 15:15
To: [email-masked]
Cc: [email-masked]
Subject: [Pce] I-D Action: draft-ietf-pce-pcep-mib-04.txt

Abstract:

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce