Subject: Re: [Pce] New version of the stateful pce applicability draft - draft-zhang-pce-stateful-pce-app-04

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 2 Jun 2013 16:36:47 +0100

Ina, WG,
 
Pleased to see people thinking about applicability and use cases. IMHO, not
enough attention is paid to why we are doing things and how they will be used. 
 
Thanks for the work, and hope people will review it (especially service
providers!)
 
Adrian
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ina Minei
Sent: 26 May 2013 22:52
To: [email-masked]
Subject: [Pce] New version of the stateful pce applicability draft -
draft-zhang-pce-stateful-pce-app-04
 
A new version of the stateful pce applicability draft was posted yesterday. 
 
In the interest of making progress on this document, the authors would like to
solicit review, comments and discussion from the working group, before the next
IETF meeting. 

URL:
http://www.ietf.org/internet-drafts/draft-zhang-pce-stateful-pce-app-04.txt
Status:
http://datatracker.ietf.org/doc/draft-zhang-pce-stateful-pce-app
Htmlized:        http://tools.ietf.org/html/draft-zhang-pce-stateful-pce-app-04
Diff:
http://www.ietf.org/rfcdiff?url2=draft-zhang-pce-stateful-pce-app-04

Ina and Xian on behalf of all the authors

---

From: Ravi Torvi <[email-masked]>
Date: Tue, 4 Jun 2013 12:31:44 -0400

Hi Ina & Authors,
Now that we have new WG charter, I think it is a good time to clarify
applicability of PCE-Stateful.

Following are some of my observations that can be considered in your next
revisions of draft:

1. We need to scope the PCE-Stateful applicability, i.e., clarify
explicitly where vanilla PCE can be sufficient or PCE-Stateful could be an
overkill.
    - Similarly, it would be nice to describe deployments of Passive
Stateful PCE and  with Active Stateful PCE separately

I think draft describes goodness of Stateful well, however, it should
provide guidelines for choosing right set of PCE-stateful features.

Few basic applications (I am not sure this draft covers them explicitly)
from PCC Scale point of view:

2. I think draft should describe on performance w/ PCE-Stateful
    i.e., How PCE Stateful helps in dynamic changes compared to NMS based.

3. One obvious applicability of Active PCE-Stateful would be : config
scaling. Operators do not have to maintain tons of LSP configuration on the
box.

4. LSP monitoring is less expensive with PCE Stateful, as PCE is expected
to maintain complete state.
This reduces burden on routers.

Thanks,
Ravi

http://www.google.com/profiles/pratiravi

On Sun, Jun 2, 2013 at 11:36 AM, Adrian Farrel <[email-masked]> wrote:

> Ina, WG,****
>
> ** **
>
> Pleased to see people thinking about applicability and use cases. IMHO,
> not enough attention is paid to why we are doing things and how they will
> be used. ****
>
> ** **
>
> providers!)****
> ** **
> Adrian****
> ** **
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Ina
> Minei
> *Sent:* 26 May 2013 22:52
> *To:* [email-masked]
> *Subject:* [Pce] New version of the stateful pce applicability draft -
> draft-zhang-pce-stateful-pce-app-04****
>
> ** **
>
> A new version of the stateful pce applicability draft was posted
> yesterday. ****
>
>  ****
>
> In the interest of making progress on this document, the authors would
> like to solicit review, comments and discussion from the working group,
> before the next IETF meeting. ****
>
>  ****
>
>  ****
>
> URL:
> ****
> http://datatracker.ietf.org/doc/draft-zhang-pce-stateful-pce-app****
>
> Htmlized:
> http://tools.ietf.org/html/draft-zhang-pce-stateful-pce-app-04****
>
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-zhang-pce-stateful-pce-app-04****
>
>  ****
>
>  ****
>
> Ina and Xian on behalf of all the authors****
>
>  ****
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>
>

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 5 Jun 2013 01:26:01 +0000

Hi, Ravi,

   Thank you very much for the useful suggestions. Please find my reply inline:

Regards,
Xian

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ravi Torvi
Sent: 2013年6月5日 0:32
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Pce] New version of the stateful pce applicability draft - draft-zhang-pce-stateful-pce-app-04

Hi Ina & Authors,
Now that we have new WG charter, I think it is a good time to clarify applicability of PCE-Stateful.

Following are some of my observations that can be considered in your next revisions of draft:
1. We need to scope the PCE-Stateful applicability, i.e., clarify explicitly where vanilla PCE can be sufficient or PCE-Stateful could be an overkill.
    - Similarly, it would be nice to describe deployments of Passive Stateful PCE and  with Active Stateful PCE separately
I think draft describes goodness of Stateful well, however, it should provide guidelines for choosing right set of PCE-stateful features.
###: In this version, we did explicitly describe these two different kinds of stateful PCEs in a variety of use cases since they have different capabilities. If you have look at the use cases we have from Section 5, you should be able to find such update. If there are still things missing , please let us know.
###: As for where the stateful PCE is applicable, I think the whole document is trying to say its necessity, I do not see why we need to name examples where it is not needed. However, we do state the pros and cons of stateful PCEs here and there as well as in the use cases so as to make it less advertising as JP suggested in last IETF.

Few basic applications (I am not sure this draft covers them explicitly) from PCC Scale point of view:

2. I think draft should describe on performance w/ PCE-Stateful
    i.e., How PCE Stateful helps in dynamic changes compared to NMS based.
###: In this document, we are comparing with a stateless PCE, not NMS. Why do you think there is such a need to compare with the latter? IMHO,  stateful PCEs are not trying to replace NMS since they have different utilities. Just as you mentioned that stateful PCEs can help with dynamic changes, which I do not think it is what NMS is mainly used for.
3. One obvious applicability of Active PCE-Stateful would be : config scaling. Operators do not have to maintain tons of LSP configuration on the box.
###: I do not get your point, are you comparing NMS-based configuration with stateful PCE-based configuration?
4. LSP monitoring is less expensive with PCE Stateful, as PCE is expected to maintain complete state.
This reduces burden on routers.
###: Again, what entity are you comparing stateful PCE with? Could you elaborate more? I haven’t thought about this before. BTW, this draft works for both MPLS-TE and GMPLS controlled networks. So I wonder when you say “this reduces burden on routers”, do you mean this applications are only possible with MPLS-TE networks?
Thanks,
Ravi

On Sun, Jun 2, 2013 at 11:36 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:
Ina, WG,

Pleased to see people thinking about applicability and use cases. IMHO, not enough attention is paid to why we are doing things and how they will be used.

Thanks for the work, and hope people will review it (especially service providers!)

Adrian

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ina Minei
Sent: 26 May 2013 22:52
To: [email-masked]<mailto:[email-masked]>
Subject: [Pce] New version of the stateful pce applicability draft - draft-zhang-pce-stateful-pce-app-04

In the interest of making progress on this document, the authors would like to solicit review, comments and discussion from the working group, before the next IETF meeting.

URL:             http://www.ietf.org/internet-drafts/draft-zhang-pce-stateful-pce-app-04.txt
Status:          http://datatracker.ietf.org/doc/draft-zhang-pce-stateful-pce-app
Htmlized:        http://tools.ietf.org/html/draft-zhang-pce-stateful-pce-app-04
Diff:            http://www.ietf.org/rfcdiff?url2=draft-zhang-pce-stateful-pce-app-04

_______________________________________________
Pce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pce

---

From: Ina Minei <[email-masked]>
Date: Fri, 14 Jun 2013 21:50:01 +0000

Ravi,

Thank you for the careful review.

I think you bring up very good points on the opportunities active stateful PCE opens. In particular, the ability to simplify the routers and scale various components, simplify operations, etc.  Although this may not directly translate to a specific use case, I think there is value in discussing these issues in the next version of the draft and will work on adding specific text.

Thank you,

Ina

From: [email-masked] [mailto:[email-masked]] On Behalf Of Zhangxian (Xian)
Sent: Tuesday, June 04, 2013 6:26 PM
To: Ravi Torvi; [email-masked]
Cc: [email-masked]
Subject: Re: [Pce] New version of the stateful pce applicability draft - draft-zhang-pce-stateful-pce-app-04

Hi, Ravi,

Regards,
Xian

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ravi Torvi
Sent: 2013年6月5日 0:32
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Pce] New version of the stateful pce applicability draft - draft-zhang-pce-stateful-pce-app-04

Hi Ina & Authors,

Adrian