Subject: [Pce] Next steps for draft-farrkingel-pce-questions

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 12 Jun 2013 15:27:04 +0100

Hi chairs and working group,

Dan and I are wondering what to do with this draft.

It seems that a number of people have been reading it and have found it useful
or at least stimulating.

At the moment, it represents just the rambling thoughts of two individuals, so
my question is really whether the WG thinks this would be something that could
be usefully published as an RFC or should be judged to have served its purpose
now and allowed to die.

If published as an RFC there would be a number of ways to go forward: adoption
by the WG and subsequent edits; publication of the individual I-D under the care
of the WG (still review and edit, but faster); publication as an individual I-D
(under the care of an AD with review by the PCE working group).

We'd be interested to know what you think before we decide what action to
request for the document.

And, of course, any issues or thoughts on the document would be very welcome.

Thanks,
Adrian

---

From: Ramon Casellas <[email-masked]>
Date: Wed, 12 Jun 2013 16:35:50 +0200

> be usefully published as an RFC or should be judged to have served its purpose
Dear Adrian, all,

Just thinking out loud, I don't have (yet) an opinion on this ... I find 
the draft useful, and I wouldn't want it to dissapear but, on the other 
hand, I also think of it as of something "alive" and which could, 
potentially, be updated more-or-less "regularly" depending on the 
working group progress. What would be in this case the best way to 
proceed? refresh it as I-D  -01,02,03... "ad infinitum", publish as RFC 
and then submit -bis -ter if need be, or update it via RFC errata?

thanks, R.

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 13 Jun 2013 17:45:26 +0100

Hi Ramon,

> > my question is really whether the WG thinks this would be something that
> > could be usefully published as an RFC or should be judged to have served
> > its purpose now and allowed to die.
> 

I suppose the question might be:
Could we get to a position where we have covered 90% of the questions that might
arise in subsequent two years?
If so, then it would sound like an RFC might be useful. Just like we published
the original framework RFC without keeping it alive for ever as a
regularly-updated I-D.

But if we don't think we can get this stable (perhaps the field is expanding too
fast) then maybe a wiki? 
I don't like a wiki for this because it doesn't register consensus or become
more widely visible.

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 14 Jun 2013 03:13:11 +0000

Hi Adrian,

I prefer an informational RFC, where people can get much valuable information by reading this document quickly. 

Best Regards

Fatai

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Friday, June 14, 2013 12:45 AM
To: 'Ramon Casellas'
Cc: [email-masked]
Subject: Re: [Pce] Next steps for draft-farrkingel-pce-questions

Hi Ramon,

Cheers,
Adrian

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: Ina Minei <[email-masked]>
Date: Fri, 14 Jun 2013 21:18:46 +0000

Adrian, 

I think there is value in this document, and it seems to fit well with an informational document. While I share your concern that some areas are rapidly changing, the process of progressing documents is not very fast either, so there is time and opportunity to update it :-)

Ina  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, June 13, 2013 9:45 AM
To: 'Ramon Casellas'
Cc: [email-masked]
Subject: Re: [Pce] Next steps for draft-farrkingel-pce-questions

[snip]

I suppose the question might be:
Could we get to a position where we have covered 90% of the questions that might arise in subsequent two years?
If so, then it would sound like an RFC might be useful. Just like we published the original framework RFC without keeping it alive for ever as a regularly-updated I-D.

But if we don't think we can get this stable (perhaps the field is expanding too
fast) then maybe a wiki? 
I don't like a wiki for this because it doesn't register consensus or become more widely visible.

Cheers,
Adrian

---

From: Leeyoung <[email-masked]>
Date: Fri, 14 Jun 2013 21:35:49 +0000

I agree with Fatai and Ina on that this draft might be worthy of the consideration for an informational RFC. 

Regards,
Young

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ina Minei
Sent: Friday, June 14, 2013 4:19 PM
To: [email-masked]; 'Ramon Casellas'; Fatai Zhang
Cc: [email-masked]
Subject: Re: [Pce] Next steps for draft-farrkingel-pce-questions

Adrian, 

Ina  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, June 13, 2013 9:45 AM
To: 'Ramon Casellas'
Cc: [email-masked]
Subject: Re: [Pce] Next steps for draft-farrkingel-pce-questions

[snip]

Cheers,
Adrian

---

From: Julien Meuric <[email-masked]>
Date: Mon, 17 Jun 2013 17:43:41 +0200

Hi all.

As individual, I share the views expressed on the list: now that the I-D 
exists, it would be a pity to let it die. Contrary to elephants, human 
beings forget, so I would say: "go for an RFC!"

Chair hat on, I thinks that:
- RFC errata is out of scope: it is supposed to be used for document 
fixes, not updates;
- the choice between WG stream and individual streams remains in 
authors' hands (just note that, based on the feedback seen on the list, 
it would make sense to poll for WG adoption);
- I am not really comfortable with the option refered to as "publication 
of the individual I-D under the care of the WG" because "under the care 
of the WG" is not clear to me in that context;
- in any case, once published as an RFC, nothing prevents from 
submitting a volume 2 later ("PCE FAQ: the pachyderm returns [for 
peanuts]").

Regards,

Julien

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Fri, 21 Jun 2013 20:36:57 +0000

Support! 

Thanks

Regards Š Zafar