Subject: [Pce] FW: Supplementary question on draft-ietf-pce-gmpls-aps-req

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 7 Jun 2013 13:34:31 +0100

Strangely I sent this email to CCAMP not PCE. 

Here is the thread for your information.

Adrian

> -----Original Message-----
> From: Ogaki, Kenichi [mailto:[email-masked]]
> Sent: 06 June 2013 08:59
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [CCAMP] Supplementary question on draft-ietf-pce-gmpls-aps-req
> 
> Dear Adrian,
> 
> > Just talking about this I-D with someone and we wondered where and how you
> > see the RSVP-TE ASSOCIATION object with your work.
> 
> IMHO, ASSOCIATION object should be handled by RSVP-TE handling process on
> an
> LSP head-end node, separated from PCC process on this node.
> However, PCC should indicate a protection type how a protecting LSP protects
> the protected one in PCReq as described in 3.1(7) and 3.2(3). In this case,
> the PCC process receives both calculated protecting and protected routes
> from PCE, then informs the RSVP-TE process of these routes. After that,
> RSVP-TE process should appropriately add ASSOCIATION object to Path messages
> for these LSPs.
> 
> If we touch on ASSOCIATION object in this draft, a sentence may be added to
> 3.2(3)Roles of the routes as follows.
> 
> When a PCC specifies the protection type of an LSP, the PCE should compute
> the working route and the corresponding protection route(s). Therefore, the
> PCRep should allow to distinguish the working (nominal) and the protection
> routes. According to these routes, RSVP-TE procedure appropriately creates
> both the working and the protection LSPs for example with ASSOCIATION object
> [RFC6689].
> 
> Is this reasonable answer?
> 
> Thanks,
> Kenichi
> --
> Kenichi Ogaki
> KDDI | IP Transport Network Development Dept.
> +81-(0)80-5945-9138 | www.kddi.com
> 
> 
> > -----Original Message-----
> > From: Adrian Farrel [mailto:[email-masked]]
> > Sent: Tuesday, June 04, 2013 9:03 PM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: [CCAMP] Supplementary question on draft-ietf-pce-gmpls-aps-req
> >
> > Hi,
> >
> > Just talking about this I-D with someone and we wondered where and how you
> > see the RSVP-TE ASSOCIATION object with your work.
> >
> > Thanks,
> > Adrian
> >
> > _______________________________________________
> > CCAMP mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 7 Jun 2013 13:38:47 +0100

Hello again,

> an LSP head-end node, separated from PCC process on this node.

I think that covers the protection use case for the Association object. And it
would be good to add it to the document.

There are many other uses of the object for associating LSPs with each other.
However, if those use cases are not showing up in PCE requirements at the
moment, that is fine and we do not need to discuss the object any further in the
document.

Thanks,
Adrian