Subject: [Pce] Comments on draft-wu-pce-dns-pce-discovery-00

From: "Claire Bi" <[email-masked]>
Date: Mon, 15 Jul 2013 15:57:18 +0800

Hi Qin,
 
I’ve reviewed this draft. I think one of the advantages of DNS based PCE discovery is its query-response mechanism. Compared with OSPF based or ISIS based PCE discovery, which uses advertisement mechanism, using query-response mechanism can avoid unnecessary advertisement and reduce a large amount of unwanted traffic, especially when PCE information needs frequent changes. 
 
It would be good to further explain the query-response mechanism of DNS based PCE discovery in the draft.

Thanks and Regards,
 
Claire

---

From: Qin Wu <[email-masked]>
Date: Mon, 15 Jul 2013 09:30:42 +0000

Hi,Claire:
You raise a good point.  We will try to highlight this in the draft. Thank you very much!
Regards!
-Qin
From: Claire Bi [mailto:[email-masked]]
Sent: Monday, July 15, 2013 3:57 PM
To: Qin Wu
Cc: pce
Subject: Comments on draft-wu-pce-dns-pce-discovery-00

Hi Qin,

I've reviewed this draft. I think one of the advantages of DNS based PCE discovery is its query-response mechanism. Compared with OSPF based or ISIS based PCE discovery, which uses advertisement mechanism, using query-response mechanism can avoid unnecessary advertisement and reduce a large amount of unwanted traffic, especially when PCE information needs frequent changes.

Thanks and Regards,

Claire

---

From: "Daniel King" <[email-masked]>
Date: Fri, 19 Jul 2013 17:27:03 +0100

Hi Qin, 

Interesting proposal, I think you need to focus a little more on the
motivation and use cases. Do you see/have PCE deployments where non-IGP
discovery is required, and static configuration is not suitable? Also did
you consider other methods of PCE discovery before you selected DNS, if so,
why is DNS better? 

Actually, we (Adrian and I) did consider PCE discovery in the PCE Questions
I-D, which recently became a WG document:

http://tools.ietf.org/html/draft-ietf-pce-questions-00

Maybe you want to reference it in your document.

Br, Dan. 

From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: 15 July 2013 10:31
To: Claire Bi
Cc: pce
Subject: Re: [Pce] Comments on draft-wu-pce-dns-pce-discovery-00

Hi,Claire:
You raise a good point.  We will try to highlight this in the draft. Thank
you very much!
Regards!
-Qin

Hi Qin,

I’ve reviewed this draft. I think one of the advantages of DNS based PCE
discovery is its query-response mechanism. Compared with OSPF based or ISIS
based PCE discovery, which uses advertisement mechanism, using
query-response mechanism can avoid unnecessary advertisement and reduce a
large amount of unwanted traffic, especially when PCE information needs
frequent changes. 

It would be good to further explain the query-response mechanism of DNS
based PCE discovery in the draft.

Thanks and Regards,

Claire

---

From: Qin Wu <[email-masked]>
Date: Mon, 22 Jul 2013 08:31:07 +0000

Hi,Dan:
Thank you for reviewing draft-wu-pce-dns-pce-discovery and sharing your views.
Please see my rely inline below.

Regards!
-Qin
-----Original Message-----
>From: Daniel King [mailto:[email-masked]] 
>Sent: Saturday, July 20, 2013 12:27 AM
>To: Qin Wu
>Cc: 'pce'
>Subject: RE: [Pce] Comments on draft-wu-pce-dns-pce-discovery-00

>motivation and use cases.

[Qin]: Agree, we need to justify more on why DNS based mechanism is needed.
We will post a update to bring these justifications in.

> Do you see/have PCE deployments where non-IGP
>discovery is required, and static configuration is not suitable?

[Qin]: Good questions, yes, we do see such PCE deployments exist:
e.g.,
a.In Inter-AS PCE discovery, BRPC is used to Cooperate PCEs to compute inter-domain path,
However in some cases, the PCEs do not participate in a common IGP, in such case, IGP based
PCE discovery is difficult to be used.

b.In Hierarchy PCE case, parent PCE and child PCE also may participant in different IGP,
handling changes in parent PCE identities and coping with failure events is very challenging for
Configuration system, In such case,DNS based PCE discovery bring a lot of benefit.

c.In the case when NMS/OSS is used, PCE server may gain topology info from OSS/NMS and do not run IGP 
PCC may not be a router and instead be a management system and do not run IGP, in such case, we 
also can resort to DNS based PCE discovery.

d.So does inter-layer PCE discovery, PCEs in different layer may participant in different IGP. 

>Also did

[Qin]:Good question again. The other methods in my mind are DHCP based mechanism and XMPP based mechanism,
However I don't think they are competing with DNS based PCE discovery:
e.g.,DHCP based PCE discovery
it could be Part of DNS process. We can use DHCP to discover search path of the resolver 
As for XMPP based PCE discovery,
It Still relies on DNS to discover URI of XMPP Proxy
XMPP Proxy can be used to translate PCE discovery information 
in IGP into info in the XMPP message and advertise it to the XMPP client.
However deploying such XMPP Proxy is very costly and doesn't scale very well comparing with DNS based PCE discovery.

>Maybe you want to reference it in your document.

[Qin]: Agree, that is something which motivates us to write this draft.
 we will add this reference in the next version. Thanks for your good suggestions.

Hi,Claire:

Hi Qin,

I've reviewed this draft. I think one of the advantages of DNS based PCE

Thanks and Regards,

Claire