Subject: Re: [Pce] I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

From: "Xialiang (C)" <[email-masked]>
Date: Thu, 11 Jul 2013 08:13:22 +0000

Hi,
I have reviewed draft-wu-pce-dns-pce-discovery-00 and think it is a very interesting draft.
Two comments I have:
1. Why DNS based PCE discovery should be coupled with DHCP? Can DHCP be used to discover all the information needed?
2. How to use DNS to know PCE scope and PCE neighboring domain?

B.R.
Frank
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, July 05, 2013 10:44 AM
To: [email-masked]
Subject: [Pce] FW: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Hi, folks:
This is an initial draft (-v00) about DNS based PCE discovery.
Here is the overview of this draft:
"
   Discovery of the (Path Computation Element (PCE) within an IGP area
   or domain is possible using OSPF [RFC5088] and IS-IS [RFC5089].
   However, in some deployment scenarios PCEs may not wish, or be able,
   to participate within the IGP process.  Therefore it would be
   beneficial for the Path Computation Client (PCC) to discover PCEs via
   an alternative mechanism to those proposed in [RFC5088] and
   [RFC5089].

   This document specifies the requirements, use cases, procedures and
   extensions to support DNS for PCE discovery.
"

I like to solicit some feedback to see if there is interest in working out more details about DNS based discovery. Thanks!

Regards!
-Qin
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 05, 2013 10:37 AM
To: [email-masked]
Subject: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Path Computation Element (PCE) Discovery using DNS
	Author(s)       : Qin Wu
	Filename        : draft-wu-pce-dns-pce-discovery-00.txt
	Pages           : 14
	Date            : 2013-07-04

Abstract:
   Discovery of the (Path Computation Element (PCE) within an IGP area
   or domain is possible using OSPF [RFC5088] and IS-IS [RFC5089].
   However, in some deployment scenarios PCEs may not wish, or be able,
   to participate within the IGP process.  Therefore it would be
   beneficial for the Path Computation Client (PCC) to discover PCEs via
   an alternative mechanism to those proposed in [RFC5088] and
   [RFC5089].

   This document specifies the requirements, use cases, procedures and
   extensions to support DNS for PCE discovery.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-wu-pce-dns-pce-discovery

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-wu-pce-dns-pce-discovery-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: Qin Wu <[email-masked]>
Date: Thu, 11 Jul 2013 08:57:45 +0000

Hi,Frank
Thank for your review and quick question, please see my reply inline below.

Regards!
-Qin
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Xialiang (C)
Sent: Thursday, July 11, 2013 4:13 PM
To: [email-masked]
Subject: Re: [Pce] I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Hi,

[Qin]: DHCP does not need to be mandatory support. However in some case, DHCP provides dynamic mechanism for deciding search path.
Otherwise, we may rely on pre-configuration on the PCC.

Regarding your question on whether DHCP can be used to discover all the PCE related information, it depends on whether your DHCP server
Can be configured to provide PCE related information. One interesting draft is related to this aspect, which discusses 
Customizing DHCP Configuration on the Basis of Network Topology
http://www.ietf.org/id/draft-lemon-dhc-topo-conf-01.txt
Therefore, in my opinion, it is possible to use DHCP to get all the information and DHCP could be one complimentary to DNS based PCE 
discovery, however not all DHCP servers can provide such capability and some network doesn't support DHCP.

[Qin]: Good question, PCE scope and PCE neighboring domain can be metadata provided by the Dynamic Delegation Discovery System (DDDS),
We can define new resource records to store these metadata. PCC can look up these resource record after knowing PCE address by performing
A and/or AAAA record lookup(s)of the domain name.
In the current draft, we haven't worked in details about this.

B.R.
Frank
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, July 05, 2013 10:44 AM
To: [email-masked]
Subject: [Pce] FW: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Hi, folks:

Regards!
-Qin
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 05, 2013 10:37 AM
To: [email-masked]
Subject: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Abstract:

---

From: "Xialiang (C)" <[email-masked]>
Date: Thu, 11 Jul 2013 09:46:19 +0000

[Qin]: Good question, PCE scope and PCE neighboring domain can be metadata provided by the Dynamic Delegation Discovery System (DDDS), We can define new resource records to store these metadata. PCC can look up these resource record after knowing PCE address by performing A and/or AAAA record lookup(s)of the domain name.
In the current draft, we haven't worked in details about this.

[Frank]: When discovering PCE neighboring domain, Do you use DNS to return OSPF area ID or ISIS area ID or not?

B.R.
Frank
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, July 05, 2013 10:44 AM
To: [email-masked]
Subject: [Pce] FW: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Hi, folks:

Regards!
-Qin
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 05, 2013 10:37 AM
To: [email-masked]
Subject: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Abstract:

---

From: Qin Wu <[email-masked]>
Date: Thu, 11 Jul 2013 09:52:39 +0000

>>[Qin]: Good question, PCE scope and PCE neighboring domain can be metadata provided by the Dynamic Delegation Discovery System (DDDS), We can define 
>>new resource records to store these metadata. PCC can look up these resource record after knowing PCE address by performing A and/or AAAA record
>>lookup(s)of the domain name.

>[Frank]: When discovering PCE neighboring domain, Do you use DNS to return OSPF area ID or ISIS area ID or not?

[Qin]: No, it doesn't need to be like this since you can use OSPF or ISIS to advertise area ID, comparing with OSPF and ISIS,
DNS is query and response mechanism, we can use DNS to return AS number or some other provide defined Identifier that can be
Used to stand for a group of endpoints, e.g., subnet or a group of subnet or a set of autonomous systems.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, July 05, 2013 10:44 AM
To: [email-masked]
Subject: [Pce] FW: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Hi, folks:

Regards!
-Qin
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 05, 2013 10:37 AM
To: [email-masked]
Subject: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Abstract:

---

From: "Xialiang (C)" <[email-masked]>
Date: Thu, 11 Jul 2013 09:55:06 +0000

Thanks, you address my comments.
-----Original Message-----
From: Qin Wu 
Sent: Thursday, July 11, 2013 5:53 PM
To: Xialiang (C); [email-masked]
Subject: RE: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

>>[Qin]: Good question, PCE scope and PCE neighboring domain can be 
>>metadata provided by the Dynamic Delegation Discovery System (DDDS), 
>>We can define new resource records to store these metadata. PCC can look up these resource record after knowing PCE address by performing A and/or AAAA record lookup(s)of the domain name.

>[Frank]: When discovering PCE neighboring domain, Do you use DNS to return OSPF area ID or ISIS area ID or not?

[Qin]: No, it doesn't need to be like this since you can use OSPF or ISIS to advertise area ID, comparing with OSPF and ISIS, DNS is query and response mechanism, we can use DNS to return AS number or some other provide defined Identifier that can be Used to stand for a group of endpoints, e.g., subnet or a group of subnet or a set of autonomous systems.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, July 05, 2013 10:44 AM
To: [email-masked]
Subject: [Pce] FW: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Hi, folks:

Regards!
-Qin
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, July 05, 2013 10:37 AM
To: [email-masked]
Subject: I-D Action: draft-wu-pce-dns-pce-discovery-00.txt

Abstract: