Subject: [Pce] comment on draft-zhx-pce-stateful-lsp-sync-00

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Wed, 31 Jul 2013 17:50:22 +0000

Dear Authors,

here an engineer (not necessarily a network engineer) comment. It comes to my mind during today presentation so ...  tossing to the list hope help discussion.

Looks to me you are adding an optimisation that actually may add more problems than the one you are trying to solve.

I first wonder if the PCC state is so big that could not be transferred in one shot (not necessarily one packet or one datagram).  In case first request fails wound't be better just retry instead of adding the complexity of incremental updates?

Second, you have to pay the price of partially synchronised DB. What you can do with a partial state? My first feeling you have to just consider your  DB as not synchronised. 

Third, You also imply there's more state to maintain at the PCC side as well...  e.g. "A PCC SHOULD remember the deleted LSP as well" .

Cheers
G

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 31 Jul 2013 21:14:55 +0000

Hi, 

   Thank you for questions. 

  I do not understand your statement "if the PCC state is so big that could not be transferred in one shot (not necessarily one packet or one datagram). " When we are talking here is to synchronize the LSP-DB, which consists of LSPs of manageable message size. Actually, it is possible to combine multiple LSP states together. 

 Secondly, for what you mentioned "first request fails", what do you mean by that? Since PCEP is based on TCP, so there should be mechanisms to support reliable delivery (outside of PCEP). So, NO MATTER if it is full sync. or partial sync., the DB will be incomplete anyway even if your assumption holds. So it does not invalidate our proposal. 

 As for the last comment, if you read (or may be interested to) the WG draft carefully, the function you mentioned below as "A PCC SHOULD remember the deleted LSP as well" is already supported there. So, I do not see how it is an issue at all. 

Regards,
Xian

________________________________________
发件人: [email-masked] [[email-masked]] 代表 Giovanni Martinelli (giomarti) [[email-masked]]
发送时间: 2013年8月1日 1:50
到: [email-masked]
主题: [Pce] comment on draft-zhx-pce-stateful-lsp-sync-00

Dear Authors,

Cheers
G

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Wed, 31 Jul 2013 22:30:52 +0000

Hi Xian,

>  I do not understand your statement "if the PCC state is so big that could not be transferred in one shot (not necessarily one packet or one datagram). " When we are talking here is to synchronize…

GM> In  section 1.1 "Motivation" you provide some numbers. Could you estimate the the LSP-DB size & bandwidth available? Do you agree that optimisation suggested here has some costs?   

> Secondly, for what you mentioned "first request fails", what do you mean by that? Since PCEP is based on TCP, so there should be mechanisms to support reliable delivery (outside of PCEP). So, NO MA…

GM> I guess I meant a state syncronization operation (or sequence ) as per section 5.4 "State Synchronisation"  of the bible.  In general operations may fails for different reasons ... anyway TCP should help you in avoiding further mechanism 

> As for the last comment, if you read (or may be interested to) the WG draft carefully, the function you mentioned below as "A PCC SHOULD remember the deleted LSP as well" is already supported there…

GM>  could you provide a pointer where is already supported?

Cheers
G