Subject: [Pce] Clarification/Comment on draft-ietf-pce-wson-rwa-ext-01.txt

From: Ramon Casellas <[email-masked]>
Date: Thu, 01 Aug 2013 09:33:29 +0200

All,

Following Young presentation,  a question was raised regarding the WA 
object, and the Wavelength restriction TLV, and how it related to the 
use of XRO and IRO objects.

We believe that the use of the WA object and one (or more) TLVs provides 
the flexibility to include and exclude wavelengths on a per link (set) 
basis. We acknowledge that this is quite WSON specific, given the global 
significance of labels in transparent segments. When trying to see 
whether the use of XRO/IRO would be enough, we came up with a few 
restrictions:

- Right now, there is no way to convey a labelset. We have LABEL 
sub-object for ?RO objects, but no LABEL_SET, sub-object although this 
could change in the future. A LABEL_SET would sub-object nonetheless be 
restricted by size.

- Without a LABEL_SET subobject, if we want to restrict to a set of 
labels, we are forced to list all of them in the XRO/IRO. The encoding 
is less efficient and we could reach the 8-bit ?RO subobject limit.

- There is no way in XRO to state I want to exclude these labels at a 
given link.

Comments are most welcome.

Thanks and best regards
Ramon

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Thu, 1 Aug 2013 07:44:10 +0000

Hi,

On Aug 1, 2013, at 9:33 , Ramon Casellas <[email-masked]>
 wrote:

> All,
> 
> Following Young presentation,  a question was raised regarding the WA object, and the Wavelength restriction TLV, and how it related to the use of XRO and IRO objects.
> 
> We believe that the use of the WA object and one (or more) TLVs provides the flexibility to include and exclude wavelengths on a per link (set) basis. We acknowledge that this is quite WSON specific, given the global significance of labels in transparent segments.

"local significance but global semantic" this was a sentence from a gmpls guru a while ago ... (but ,since I'm getting older, my memory MTBF increase) ;)

Anyway, first clarification question, you mention transparent segment and at the same time you need such fine wavelength assignement... am I missing something?

Cheers
G

> When trying to see whether the use of XRO/IRO would be enough, we came up with a few restrictions:
> 
> - Right now, there is no way to convey a labelset. We have LABEL sub-object for ?RO objects, but no LABEL_SET, sub-object although this could change in the future. A LABEL_SET would sub-object nonetheless be restricted by size.
> 
> - Without a LABEL_SET subobject, if we want to restrict to a set of labels, we are forced to list all of them in the XRO/IRO. The encoding is less efficient and we could reach the 8-bit ?RO subobject limit.
> 
> - There is no way in XRO to state I want to exclude these labels at a given link.
> 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: Ramon Casellas <[email-masked]>
Date: Thu, 01 Aug 2013 09:57:14 +0200

> Anyway, first clarification question, you mention transparent segment and at the same time you need such fine wavelength assignement... am I missing something?
Giovanni, all

Good point, I was quite happy to have end-to-end labels constraints in 
the "LSC LSP", but IIRC (I am also getting old) this was added to 
address the fact that, in WSON  (unlike pure OCh switching, one could 
guess..), you can have 3R allowing for label swapping and thus that the 
LSC LSP has several transparent segments so the WA should allow 
restricting wavelengths on a per segment basis (e.g. to reflect 
transceiver limitations?). Of course, this does not mean that you can 
just skip the link set object and just add the end-to-end restriction

That said, if it seems that the requirement is unneeded we could think 
about it. This still does not solve the problem of efficient encoding, 
imho. If you are still around Young and myself would be happy to talk 
about it.

R.