Subject: [Pce] Fwd: New Version Notification for draft-dhody-pce-srlg-collection-00.txt

From: Dhruv Dhody <[email-masked]>
Date: Tue, 8 Oct 2013 18:45:16 +0530

Hi,

We have a new draft to enable SRLG collection during path computation and
encoding it in the reply message.
Welcome any comments/feedback.

Regards,
Dhruv (on behalf of co-authors)

---------- Forwarded message ----------
From: <[email-masked]>
Date: Tue, Oct 8, 2013 at 6:34 PM
Subject: New Version Notification for draft-dhody-pce-srlg-collection-00.txt
To: Xian Zhang <[email-masked]>, Fatai Zhang <[email-masked]>,
Dhruv Dhody <[email-masked]>

A new version of I-D, draft-dhody-pce-srlg-collection-00.txt
has been successfully submitted by Dhruv Dhody and posted to the
IETF repository.

Filename:        draft-dhody-pce-srlg-collection
Revision:        00
Title:           PCEP Extensions for Receiving SRLG Information
Creation date:   2013-10-08
Group:           Individual Submission
Number of pages: 8
URL:
http://www.ietf.org/internet-drafts/draft-dhody-pce-srlg-collection-00.txt
Status:
http://datatracker.ietf.org/doc/draft-dhody-pce-srlg-collection
Htmlized:
http://tools.ietf.org/html/draft-dhody-pce-srlg-collection-00

Abstract:
   The Path Computation Element (PCE) provides functions of path
   computation in support of traffic engineering in networks controlled
   by Multi-Protocol Label Switching (MPLS) and Generalized MPLS
   (GMPLS).

   This document provides extensions for the Path Computation Element
   Protocol (PCEP) to support collection of Shared Risk Link Group
   (SRLG) information during path computation and encoding this
   information in the reply message.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 9 Oct 2013 19:13:16 +0000

Hi Dhruv:

Why cannot PCC use RSVP-TE signaling recording to collect the SRLG of a path (using draft-ietf-ccamp-rsvp-te-srlg-collect)? Please note that SRLG recording is NOT part of path computation service.

My worry is that we are duplicating RSVP-TE functionality into PCE without noticing that moving functionality from one protocol to another protocol does not get ride of underlaying complexity of the required solution.

Thanks

Regards … Zafar

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 8, 2013 9:15 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Pce] Fwd: New Version Notification for draft-dhody-pce-srlg-collection-00.txt

Hi,

We have a new draft to enable SRLG collection during path computation and encoding it in the reply message.
Welcome any comments/feedback.

Regards,

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 8, 2013 at 6:34 PM
Subject: New Version Notification for draft-dhody-pce-srlg-collection-00.txt
To: Xian Zhang <[email-masked]<mailto:[email-masked]>>, Fatai Zhang <[email-masked]<mailto:[email-masked]>>, Dhruv Dhody <[email-masked]<mailto:[email-masked]>>

Filename:        draft-dhody-pce-srlg-collection
Revision:        00
Title:           PCEP Extensions for Receiving SRLG Information
Creation date:   2013-10-08
Group:           Individual Submission
Number of pages: 8
URL:             http://www.ietf.org/internet-drafts/draft-dhody-pce-srlg-collection-00.txt
Status:          http://datatracker.ietf.org/doc/draft-dhody-pce-srlg-collection
Htmlized:        http://tools.ietf.org/html/draft-dhody-pce-srlg-collection-00

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 10 Oct 2013 07:45:20 +0000

Hi Zafar,

I agree that the Ingress can collect this information at the time of signaling (esp in case when PCE is not used for path computation).

But having this functionality in PCE can help too -

(1)     All the nodes in the path need to support [ietf-ccamp-rsvp-te-srlg-collect] and would need upgrade to support this feature, where as only PCC/PCE needs changing when SRLG values are collected during computation.

(2)    IMO PCE may reduce that *underlying complexity* as it is aware of the SRLG values, it just the matter of encoding it in the PCEP reply.

(3)    PCE can be utilized to generate Macro SRLG [farrel-interconnected-te-info-exchange] and because of it is generated at a central entity, it should be easier to maintain.

Regards,
Dhruv

---------------------------------------------------------------
Dhruv Dhody
System Architect,
Huawei Technologies India Pvt. Ltd.,
Banagalore
Mobile: +91-9845062422
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

From: [email-masked] [mailto:[email-masked]] On Behalf Of Zafar Ali (zali)
Sent: 10 October 2013 00:43
To: Dhruv Dhody; [email-masked]
Subject: Re: [Pce] Fwd: New Version Notification for draft-dhody-pce-srlg-collection-00.txt

Hi Dhruv:

Thanks

Regards ... Zafar

Hi,

Regards,

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 8, 2013 at 6:34 PM
Subject: New Version Notification for draft-dhody-pce-srlg-collection-00.txt
To: Xian Zhang <[email-masked]<mailto:[email-masked]>>, Fatai Zhang <[email-masked]<mailto:[email-masked]>>, Dhruv Dhody <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Fri, 11 Oct 2013 06:33:10 +0000

Dhruv:

Please see in-line.

Thanks

Regards … Zafar

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 10, 2013 3:45 AM
To: zali <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Pce] Fwd: New Version Notification for draft-dhody-pce-srlg-collection-00.txt

Hi Zafar,

Signaling solution can be worked out if only border nodes are upgraded with this functionality. Please note that a node can modify the SRLG recording list. So border nodes can assume the responsibility to add SRLG for the transit domain using IGP topology adv. it has.

Only for the case of a centerized PCE case. How did you reduce complexity when you are dealing with a typical distributed PCE deployment model.

You mentioned "central entity", are you only considering a centerized PCE case? BTW SRLG operations (aggregation, filtering, etc.) can be performed by any multilayer node.

Regards,
Dhruv

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Zafar Ali (zali)
Sent: 10 October 2013 00:43
To: Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Subject: Re: [Pce] Fwd: New Version Notification for draft-dhody-pce-srlg-collection-00.txt

Hi Dhruv:

Thanks

Regards … Zafar

Hi,

Regards,

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 8, 2013 at 6:34 PM
Subject: New Version Notification for draft-dhody-pce-srlg-collection-00.txt
To: Xian Zhang <[email-masked]<mailto:[email-masked]>>, Fatai Zhang <[email-masked]<mailto:[email-masked]>>, Dhruv Dhody <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 11 Oct 2013 13:00:19 +0000

Hi Zafar,

Hi Zafar,

Signaling solution can be worked out if only border nodes are upgraded with this functionality. Please note that a node can modify the SRLG recording list. So border nodes can assume the responsibility to add SRLG for the transit domain using IGP topology adv. it has.
[DD] Still all border nodes upgrade v/s PCE upgrade :)

Only for the case of a centerized PCE case. How did you reduce complexity when you are dealing with a typical distributed PCE deployment model.
[DD] In multi-layer-multi-PCE, the lower layer PCE which computes the lower layer path segment will reply to the higher layer PCE with the SRLG of the lower layer path-segment.
As the end to end inter-layer path computation is done, the SRLG value of the full path is known to the PCE and can be notified to the PCC.
Similarly in multi-domain, the cooperating PCEs in BRPC or HPCE model will reply the local path segment along with the SRLG information.
PCE(1) or the Parent PCE can consolidate the SRLG information of the end to end path.

You mentioned "central entity", are you only considering a centerized PCE case? BTW SRLG operations (aggregation, filtering, etc.) can be performed by any multilayer node.
[DD] I am only suggesting that *operation, policy, management* is easier if done at a centralized PCE or a few distributed PCEs instead of "all multilayer nodes".

IMHO *IF* PCE(s) are used for path computations, using PCEP to also collect the SRLG information during computation itself, seems like a reasonable idea.
The cooperating PCEs also learn the SRLG value during computation & the PCC does not have to wait for signaling to be completed to get this information.

Regards,
Dhruv

Regards,
Dhruv

Hi Dhruv:

Thanks

Regards ... Zafar

Hi,

Regards,

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 8, 2013 at 6:34 PM
Subject: New Version Notification for draft-dhody-pce-srlg-collection-00.txt
To: Xian Zhang <[email-masked]<mailto:[email-masked]>>, Fatai Zhang <[email-masked]<mailto:[email-masked]>>, Dhruv Dhody <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat