Subject: Re: [Pce] New Version Notification for draft-crabbe-pce-pce-initiated-lsp-03.txt

From: Ina Minei <[email-masked]>
Date: Fri, 11 Oct 2013 21:39:37 +0000

This version has the following changes: 

• Removed references to LSP signaling type (which was introduced in revision 02)
• Added a flag to tag LSPs that were instantiated by the PCE
• Added an implementation report section 
• Clarified error reporting
• Updated security section
• Updated RBNF for LSP deletion, to show that can send just SRP and LSP

Review and comments are welcome, 

Ina 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, October 11, 2013 2:29 PM
To: Robert Varga; Edward Crabbe; Ina Minei; Siva Sivabalan
Subject: New Version Notification for draft-crabbe-pce-pce-initiated-lsp-03.txt

A new version of I-D, draft-crabbe-pce-pce-initiated-lsp-03.txt
has been successfully submitted by Edward Crabbe and posted to the IETF repository.

Filename:	 draft-crabbe-pce-pce-initiated-lsp
Revision:	 03
Title:		 PCEP Extensions for PCE-initiated LSP Setup in a Stateful PCE Model
Creation date:	 2013-10-10
Group:		 Individual Submission
Number of pages: 17
URL:             http://www.ietf.org/internet-drafts/draft-crabbe-pce-pce-initiated-lsp-03.txt
Status:          http://datatracker.ietf.org/doc/draft-crabbe-pce-pce-initiated-lsp
Htmlized:        http://tools.ietf.org/html/draft-crabbe-pce-pce-initiated-lsp-03
Diff:            http://www.ietf.org/rfcdiff?url2=draft-crabbe-pce-pce-initiated-lsp-03

Abstract:
   The Path Computation Element Communication Protocol (PCEP) provides
   mechanisms for Path Computation Elements (PCEs) to perform path
   computations in response to Path Computation Clients (PCCs) requests.

   The extensions described in [I-D.ietf-pce-stateful-pce] provide
   stateful control of Multiprotocol Label Switching (MPLS) Traffic
   Engineering Label Switched Paths (TE LSP) via PCEP, for a model where
   the PCC delegates control over one or more locally configured LSPs to
   the PCE.  This document describes the creation and deletion of PCE-
   initiated LSPs under the stateful PCE model.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 22 Oct 2013 19:40:53 +0530

Hi,

Some comments on draft-crabbe-pce-pce-initiated-lsp-03

      - 3.2. Operation overview
        How about also updating draft-sivabalan-pce-disco-stateful-02 to
        include PCE instantiation capability in PCE-CAP-FLAGS sub-TLV?
        And adding a reference here.

      - 4.1. Stateful PCE Capability TLV
        Bit S is now moved to minei-pce-stateful-sync-optimizations

      - 5.3.1. The Create flag
        This is an important flag that can help the other PCE know about
        the PCE Initiated LSP, but I also suggest that the identity of
        the PCE that Initiated the LSP could also be useful, esp to let
        other PCE take control at the time of failure. Something like
        PCE-ID TLV (HPCE extn) can be used for this.

      - 6. LSP delegation and cleanup

            PCE-initiated LSPs are automatically delegated by the PCC to
            the PCE upon instantiation.  The PCC MUST delegate the LSP
            to the PCE by setting the delegation bit to 1 in the PCRpt
            that includes the assigned PLSP-ID.

          The first sentence says its automatic, while the second
          suggest that it needs to be explicitly done by PCC.

            To obtain control of a PCE-initiated LSP, a PCE (either the
            original or one of its backups) sends a PCInitiate message,
            including just the SRP and LSP objects, and carrying the
            PLSP-ID of the LSP it wants to take control of.

          For a backup PCE to take control over orphan PCE-initiated
          LSP, its easier if the PLSP-ID is unique across PCEP session.

Regards,
Dhruv

On Sat, Oct 12, 2013 at 3:09 AM, Ina Minei <[email-masked]> wrote:

> Subject: New Version Notification for
> draft-crabbe-pce-pce-initiated-lsp-03.txt
>
>
> URL:
> http://www.ietf.org/internet-drafts/draft-crabbe-pce-pce-initiated-lsp-03.txt
> Status:
> http://datatracker.ietf.org/doc/draft-crabbe-pce-pce-initiated-lsp
> Htmlized:
> http://tools.ietf.org/html/draft-crabbe-pce-pce-initiated-lsp-03
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-crabbe-pce-pce-initiated-lsp-03
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
>
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>