Subject: [Pce] NULL PCUpdate message

From: Ramana Yarlagadda <[email-masked]>
Date: Thu, 9 Oct 2014 18:33:05 +0000

Hi All,

I have a questions on sending the PCUpdate message to delegate an LSP from
PCE to PCC. Can somebody please help me here to understand the PCUpdate message
For delegating an LSP back to PCC.

Re-delegation section talks about empty message but the PCUpdate request message definition
Says that all  LSP parameters muse be sent.

1)      PCE requires to send an EMPTY LSP Update message to delegate an LSP  back to PCC.
What is an acceptable empty LSP message?

Please refer to section 5.5.5 of draft "PCEP extensions for stateful PCE" for procedure of returning
Delegation

2)      Section 6.2 of draft "PCEP extensions for stateful PCE" defines the PCUpd message.
-       Three mandatory objects must be included in each PCUpd message. The error codes
         Are defined to notify the sender if any of the mandatory objects missing in the PCUpdate
         Message.
-       Also, The draft says (copied text from section 6.2)
-
"An LSP Update Request MUST contain all LSP parameters that a PCE wishes to
   be set for the LSP. A PCC MAY set missing parameters from locally
   configured defaults.  If the LSP specified in the Update Request is
   already up, it will be re-signaled.

A clear definition of NULL message would help us here.

-thanks in advance
-ramana

---

From: Cyril Margaria <[email-masked]>
Date: Thu, 9 Oct 2014 15:04:22 -0400

Hi,

>From the definition, an empty PCUpd must contain an ERO, I think the
question boils down to having an empty ERO or an ERO that mirrors the last
ERO received. This is the only required parameter.

I would propose the following text to clarify:

Section 5.5.3:
Add: Upon reception of a PCUpd with D=0 a PCC MUST ignore the LSP object A
bit and  the ERO object content.

With that the Empty (I would not introduce a NULL message) PCUpd contains
SRP, LSP with PLSP-ID, all flags to 0, and an empty ERO.

Br
Cyril

On 9 October 2014 14:33, Ramana Yarlagadda <[email-masked]> wrote:

>     1. PCE requires to send an EMPTY LSP Update message to delegate an
>    LSP  back to PCC.
>
> Please refer to section 5.5.5 of draft “PCEP extensions for stateful PCE”
> for procedure of returning
> Delegation
>
>
>     1. Section 6.2 of draft “PCEP extensions for stateful PCE” defines
>    the PCUpd message.
>
>
> “An LSP Update Request MUST contain all LSP parameters that a PCE wishes to
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>
>

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 10 Oct 2014 04:46:57 +0000

Hi Cyril, Ramana,

I agree with this, during returning delegation –
On the receiving side, we ignore the content.
On the sending side, we put empty ERO object with no subobject.

The same principle is also applicable to the admin down as per my mail earlier: http://www.ietf.org/mail-archive/web/pce/current/msg04000.html

It should also to be noted that this is applicable to PCRpt message as well where in some case we would not have the ERO object (for ex. Delegation of just configured, not-signaled LSP ; admin down of LSP etc).
In these cases as well -
On the receiving side, we ignore the content.
On the sending side, we put empty ERO object with no subobject.

Thus, apart for cyril’s suggested text, we can add generic text in PCRpt/PcUpd message section (6.1, 6.2) -

In case of an LSP that is not yet signaled or administratively/
operationally down on receiving such status via PCRpt message the
content of ERO object is ignored at PCE, while the PCC SHOULD
send an empty ERO object with no sub-objects in PCRpt message.

In case of an LSP that is administratively down or returning of
delegation via PCUpd message the content of ERO object is
ignored at PCC, while the PCE SHOULD send an empty ERO object
with no sub-objects in PCUpd message.

What does the WG think about this?

Regards,
Dhruv

From: Pce [mailto:[email-masked]] On Behalf Of Cyril Margaria
Sent: 10 October 2014 00:34
To: Ramana Yarlagadda
Cc: [email-masked]
Subject: Re: [Pce] NULL PCUpdate message

Hi,
From the definition, an empty PCUpd must contain an ERO, I think the question boils down to having an empty ERO or an ERO that mirrors the last ERO received. This is the only required parameter.
I would propose the following text to clarify:

Section 5.5.3:
Add: Upon reception of a PCUpd with D=0 a PCC MUST ignore the LSP object A bit and  the ERO object content.
With that the Empty (I would not introduce a NULL message) PCUpd contains SRP, LSP with PLSP-ID, all flags to 0, and an empty ERO.

Br
Cyril

On 9 October 2014 14:33, Ramana Yarlagadda <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

1.       PCE requires to send an EMPTY LSP Update message to delegate an LSP  back to PCC.
What is an acceptable empty LSP message?

Please refer to section 5.5.5 of draft “PCEP extensions for stateful PCE” for procedure of returning
Delegation

2.       Section 6.2 of draft “PCEP extensions for stateful PCE” defines the PCUpd message.
·         Three mandatory objects must be included in each PCUpd message. The error codes
Are defined to notify the sender if any of the mandatory objects missing in the PCUpdate
Message.
·         Also, The draft says (copied text from section 6.2)
·
“An LSP Update Request MUST contain all LSP parameters that a PCE wishes to
   be set for the LSP. A PCC MAY set missing parameters from locally
   configured defaults.  If the LSP specified in the Update Request is
   already up, it will be re-signaled.

-thanks in advance
-ramana

_______________________________________________
Pce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pce

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 29 Oct 2014 09:43:23 +0000

Hi Ina,

What is the position of the author’s on this issue?
I hope this can be clarified in the next revision of draft-ietf-pce-stateful-pce.

*This is an interoperability issue, we would really benefit from a clarification in the specification*

Regards,
Dhruv

From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: 10 October 2014 10:17
To: Cyril Margaria; Ramana Yarlagadda
Cc: [email-masked]
Subject: Re: [Pce] NULL PCUpdate message

Hi Cyril, Ramana,

Regards,
Dhruv

From: Pce [mailto:[email-masked]] On Behalf Of Cyril Margaria
Sent: 10 October 2014 00:34
To: Ramana Yarlagadda
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Pce] NULL PCUpdate message

Hi,

Section 5.5.3:

Br
Cyril

-thanks in advance
-ramana