Subject: [Pce] A query regarding PCUpd - admin down

From: Dhruv Dhody <[email-masked]>
Date: Thu, 9 Oct 2014 04:13:43 +0000

Hi All,

For a delegated LSP, the stateful PCE may choose to make the LSP down and use the A bit in the LSP object in the PCUpd message, as per section 7.3 [http://tools.ietf.org/html/draft-ietf-pce-stateful-pce-09#page-31] -

A(Administrative - 1 bit):  On PCRpt messages, the A Flag indicates
      the PCC's target operational status for this LSP.  On PCUpd
      messages, the A Flag indicates the LSP status that the PCE desires
      for this LSP.  In both cases, a value of '1' means that the
      desired operational state is active, and a value of '0' means that
      the desired operational state is inactive.

What should be the ERO during this operation in PCUpd message?  [http://tools.ietf.org/html/draft-ietf-pce-stateful-pce-09#section-6.2]

   The format of a PCUpd message is as follows:

   <PCUpd Message> ::= <Common Header>

                       <update-request-list>

Where:

   <update-request-list> ::= <update-request>[<update-request-list>]

   <update-request> ::= <SRP>

                        <LSP>

                        <path>

Where:

   <path>::= <ERO><attribute-list>

IMHO it should be an empty ERO (i.e. ERO object with no sub-objects) as this is the state that the PCE desire for this delegated LSP.

What do you think? Should the desired behavior be noted in the draft to avoid misinterpretation and inter-operability issues?

Dhruv

---

From: Ramana Yarlagadda <[email-masked]>
Date: Fri, 10 Oct 2014 18:04:33 +0000

Hi,

It helps to implement the draft and inter-operate with others, with a description of  desired
behavior  in the draft.

-regards
-ramana
From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Wednesday, October 08, 2014 9:14 PM
To: [email-masked]
Subject: [Pce] A query regarding PCUpd - admin down

Hi All,

                       <update-request-list>

Where:

                        <LSP>

                        <path>

Where:

Dhruv