Subject: [Pce] Poll on draft-dhody-pce-iro-update-02

From: <[email-masked]>
Date: Mon, 12 Jan 2015 12:43:51 +0100

Dear PCE WG,

Following our previous discussions on IRO within PCEP, do you agree with 
the adoption of draft-dhody-pce-iro-update-02 as a PCE WG I-D? Please 
share your comments using the mailing list, justifying as much as 
possible in case you are opposed.

Thanks,

JP & Julien

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 12 Jan 2015 22:32:58 +0530

Stating the obvious... support!

Regards,
Dhruv (Author)

On Mon, Jan 12, 2015 at 5:13 PM,  <[email-masked]> wrote:
> Dear PCE WG,
>
> Following our previous discussions on IRO within PCEP, do you agree with the
> adoption of draft-dhody-pce-iro-update-02 as a PCE WG I-D? Please share your
> comments using the mailing list, justifying as much as possible in case you
> are opposed.
>
> Thanks,
>
> JP & Julien
>
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu
> ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 12 Jan 2015 17:10:21 +0000

Support.

Best Regards,
Huaimo
-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, January 12, 2015 6:44 AM
To: [email-masked]
Subject: [Pce] Poll on draft-dhody-pce-iro-update-02

Dear PCE WG,

Following our previous discussions on IRO within PCEP, do you agree with the adoption of draft-dhody-pce-iro-update-02 as a PCE WG I-D? Please share your comments using the mailing list, justifying as much as possible in case you are opposed.

Thanks,

JP & Julien

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Leeyoung <[email-masked]>
Date: Mon, 12 Jan 2015 17:45:13 +0000

Support.

Young

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, January 12, 2015 5:44 AM
To: [email-masked]
Subject: [Pce] Poll on draft-dhody-pce-iro-update-02

Dear PCE WG,

Thanks,

JP & Julien

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Tue, 13 Jan 2015 03:39:07 +0000

Support.

A very straightforward draft, just one suggestion:

Should the last paragraph of Section 2 be written in RFC2119 language? I notice the first sentence in this section uses MUST for providing background information. Other than that, no RFC2119 language is used. 

Regards,
Xian

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 2015年1月12日 19:44
To: [email-masked]
Subject: [Pce] Poll on draft-dhody-pce-iro-update-02

Dear PCE WG,

Thanks,

JP & Julien

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 13 Jan 2015 04:19:01 +0000

Hi Xian, 

Thanks for your support and suggestion. 

How about these changes - 

OLD: 
   The content of an IRO object is an ordered list of subobjects
   representing a series of abstract nodes.
NEW: 
   The content of an IRO object MUST be an ordered list of subobjects
   representing a series of abstract nodes.

OLD:
   Further each subobject has an attribute
   called 'L bit', which is set if the subobject represents a loose hop.
   If the bit is not set, the subobject represents a strict hop.  
NEW:
   Further, the loose or strict property of the subobject MUST be 
   interpreted based on an attribute called 'L bit', which is set 
   if the subobject represents a loose hop. If the bit is not set, the 
   subobject represents a strict hop.  

Regards,
Dhruv

> From: Pce [mailto:[email-masked]] On Behalf Of Zhangxian (Xian)
> Sent: 13 January 2015 09:09
> To: [email-masked]; [email-masked]
> Subject: Re: [Pce] Poll on draft-dhody-pce-iro-update-02
> 
> Support.
> 
> Should the last paragraph of Section 2 be written in RFC2119 language?
> I notice the first sentence in this section uses MUST for providing
> background information. Other than that, no RFC2119 language is used.
> 
> Regards,
> Xian
> 
> Following our previous discussions on IRO within PCEP, do you agree
> with the adoption of draft-dhody-pce-iro-update-02 as a PCE WG I-D?
> Please share your comments using the mailing list, justifying as much
> as possible in case you are opposed.
> 
> Thanks,
> 
> JP & Julien
> 
> 
> _____________________________________________________________________
> ____________________________________________________
> 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> que les pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or
> privileged information that may be protected by law; they should not
> be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender
> and delete this message and its attachments.

---

From: Udayasree palle <[email-masked]>
Date: Wed, 14 Jan 2015 04:53:40 +0000

Support!

Regards,
Udaya

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 12 January 2015 17:14
To: [email-masked]
Subject: [Pce] Poll on draft-dhody-pce-iro-update-02

Dear PCE WG,

Thanks,

JP & Julien

---

From: Ramon Casellas <[email-masked]>
Date: Wed, 14 Jan 2015 12:45:00 +0100

> as possible in case you are opposed. 
All,

Imho it can be adopted. It clarifies RFC5440 to state that IRO is 
ordered and the role of L bit. Being involved in the domain sequence 
draft that triggered this, and contributed to the survey, I am ok with 
the outcome. That said, and for completeness, I remember someone 
(Adrian?) mentioned in the past that not assuming ordering in IRO could 
mean more flexibility to the PCE. Maybe this can be addressed in the future?

thanks
Ramon

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 14 Jan 2015 13:34:52 +0000

Hi, Dhruv,

   Look fine to me. just a really minor comment, up to you to decide whether to update or not, :): instead of saying " an attribute called L bit ", maybe just state "L bit", coz i believe it is introduced earlier in the draft?

Cheers,
Xian

________________________________________
发件人: Dhruv Dhody
发送时间: 2015年1月13日 12:19
收件人: Zhangxian (Xian); [email-masked]; [email-masked]
主题: RE: [Pce] Poll on draft-dhody-pce-iro-update-02

Hi Xian,

OLD:

OLD:

Regards,
Dhruv