Subject: Re: [Pce] Experimental Codepoint allocation in PCEP registry

From: Jeff Tantsura <[email-masked]>
Date: Fri, 10 Jun 2016 02:00:17 -0700

Hi Dhruv,

Support, very much needed!

Thanks,
Jeff

On 6/9/16, 5:09 AM, "Pce on behalf of Dhruv Dhody" <[email-masked] on behalf of [email-masked]> wrote:

>Hi WG, 
>
>In PCE IANA registry [http://www.iana.org/assignments/pcep] we do not have any codepoints for experimental usage. As we work on some new experiments with PCEP (sometimes in open source platform), it would be wise to use experimental codepoints to avoid any conflict. For this purpose we have written a small draft to carve out some codepoints for experimental usage for PCEP messages, objects and TLVs. 
>
>https://tools.ietf.org/html/draft-dhody-pce-pcep-exp-codepoints-00
>
>Please provide your feedback.
>
>Thanks,
>Dhruv & Daniel
>
>-----
>
>Name:           draft-dhody-pce-pcep-exp-codepoints
>Revision:       00
>Title:          Experimental Codepoint Allocation for Path Computation Element communication Protocol (PCEP)
>Document date:  2016-06-09
>Group:          Individual Submission
>Pages:          5
>URL:            https://www.ietf.org/internet-drafts/draft-dhody-pce-pcep-exp-codepoints-00.txt
>Status:         https://datatracker.ietf.org/doc/draft-dhody-pce-pcep-exp-codepoints/
>Htmlized:       https://tools.ietf.org/html/draft-dhody-pce-pcep-exp-codepoints-00
>
>
>Abstract:
>   IANA assigns values to the Path Computation Element (PCE)
>   communication Protocol (PCEP) parameters (messages, objects, TLVs).
>   IANA established a new top-level registry to contain all PCEP
>   codepoints and sub-registries.  The allocation policy for each new
>   registry is by IETF Consensus.
>
>   This document seeks to mark some codepoints for experimental usage of
>   PCEP.
>
>_______________________________________________
>Pce mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pce

---

From: Ramon Casellas <[email-masked]>
Date: Fri, 10 Jun 2016 11:12:26 +0200

Hi Dhruv, Jeff, all

Indeed. Having been involved in PCE-related experimental and research 
activities I would welcome this and could be very helpful. It will not 
solve the issues but at least it defines the ranges.

I can't provide much feedback, just curious about the rationale to 
allocate a given range e.g. 224-255 > 30 messages, etc.

Best regards
Ramon

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 10 Jun 2016 10:02:53 +0000

Hi Ramon, 

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of Ramon Casellas
> Sent: 10 June 2016 14:42
> To: [email-masked]
> Subject: Re: [Pce] Experimental Codepoint allocation in PCEP registry
> 
> Hi Dhruv, Jeff, all
> 
> activities I would welcome this and could be very helpful. It will not solve
> the issues but at least it defines the ranges.
> 
> I can't provide much feedback, just curious about the rationale to allocate
> a given range e.g. 224-255 > 30 messages, etc.

[Dhruv] You hit the jackpot.... we wanted to get the feedback of the WG about this. 

IMHO we need to strike a right balance that there are enough codepoints set aside for multiple parallel experimentations at a given time, and not to give up a big chunk out for experimentation that it hinders IANA allocation. 

We currently have 9 messages set by IANA, some 4 new messages in queue to be sent to IANA, 13/255 ... so we do not have to worry about running out any time soon :)

BTW I could find one instance in MANET where a similar range is allocated - https://tools.ietf.org/html/rfc5444#section-6.2 

We do need to reach a consensus on what range to set aside. 

Regards,
Dhruv

> > On 6/9/16, 5:09 AM, "Pce on behalf of Dhruv Dhody" <[email-masked]
> on behalf of [email-masked]> wrote:
> >
> >> Hi WG,
> >>
> >> In PCE IANA registry [http://www.iana.org/assignments/pcep] we do not
> have any codepoints for experimental usage. As we work on some new experiments
> with PCEP (sometimes in open source platform), it would be wise to use
> experimental codepoints to avoid any conflict. For this purpose we have
> written a small draft to carve out some codepoints for experimental usage
> for PCEP messages, objects and TLVs.
> >>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 15 Jun 2016 19:22:05 +0100

To Ramon's point...

> We do need to reach a consensus on what range to set aside.

Yes, we do. Both to satisfy ourselves and to get past the current IESG (not the
one that approved the MANET registry).

I think you captured the essence. There should be enough code points to run the
parallel experiments that need to be run together, but not so many that
experiments that don't need to be run at the same time can grab values and
expect to keep them. Essentially, before running an experiment all participants
should get together to agree what values to use, and then when the experiment is
over they should consider the values to have no meaning (until the next and
completely different experiment).

As far as I can see, 30 messages looks like a complete orgy of experimentation!
Four times more active experimentation in one experimental network than in the
whole of the standardised and soon-to-be standardised history of PCEP.

How would you all feel about 8? (My instinct is to push for 4, but I can
pre-emptively compromise :-)

Adrian

> From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
> Sent: 10 June 2016 11:03
> To: Ramon Casellas; [email-masked]
> IMHO we need to strike a right balance that there are enough codepoints set
> aside for multiple parallel experimentations at a given time, and not to give
up a
> big chunk out for experimentation that it hinders IANA allocation.
> 
> We currently have 9 messages set by IANA, some 4 new messages in queue to be
> sent to IANA, 13/255 ... so we do not have to worry about running out any time
> soon :)
> 
> BTW I could find one instance in MANET where a similar range is allocated -
> https://tools.ietf.org/html/rfc5444#section-6.2
>