Subject: [Pce] Alvaro Retana's No Objection on draft-ietf-pce-stateful-pce-app-07: (with COMMENT)

From: "Alvaro Retana" <[email-masked]>
Date: Tue, 25 Oct 2016 06:02:02 -0700

Alvaro Retana has entered the following ballot position for
draft-ietf-pce-stateful-pce-app-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-stateful-pce-app/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

This document mostly presents application scenarios, which (by reference)
serve as motivation for draft-ietf-pce-stateful-pce.  However, there are
a couple of places (in Section 4) where the operation defined in
draft-ietf-pce-stateful-pce is used as part of the considerations.  For
example (from 4.1):

   Stateless and stateful PCEs can co-exist in the same network and be
   in charge of path computation of different types.  To solve the
   problem of distinguishing between the two types of PCEs, either
   discovery or configuration may be used.  The capability negotiation
   in [I-D.ietf-pce-stateful-pce] ensures correct operation when the PCE
   address is configured on the PCC.

I see a circular dependency between this document and
draft-ietf-pce-stateful-pce, where the considerations here are expected
to motivate the extensions, but the specific extensions are used to
discuss “generic issues with stateful PCE deployments”.

Given that draft-ietf-pce-stateful-pce is a Normative Reference, I would
rather see this document come back for IESG Evaluation with/after
draft-ietf-pce-stateful-pce.  Note that draft-ietf-pce-stateful-pce is
still (AFAICT) under consideration in the WG.

I am not making this comment a DISCUSS because I don’t think that it
raises to the appropriate level (as only some parts of the document seem
to have the dependency), and we’ll have to wait for
draft-ietf-pce-stateful-pce to be processed before publication anyway. 
However, I think that the application scenarios and motivation for future
extensions should be able to be described without referring to the
extensions themselves — I would then like the authors, Shepherd and the
responsible AD to consider whether it is possible for this document to
stand on its own, or whether we need to process it with the extensions
draft.  Given that draft-ietf-pce-stateful-pce is still in the WG, I
think it is important for us to talk about it as this point.  I noted in
the Shepherd’s writeup that this document used to be “originally included
in the base stateful PCE protocol specification” (which I assume is
draft-ietf-pce-stateful-pce).

To be clear: I am not opposing the publication of this document (even
though the content could have been part of draft-ietf-pce-stateful-pce),
I just think that in the current form it should be processed/published
*with* draft-ietf-pce-stateful-pce.

[Mechanisms from I-D.ietf-pce-stateful-sync-optimizations and
I-D.ietf-pce-pce-initiated-lsp are also mentioned in similar ways, and
those drafts are also in process in the WG.  I’m focusing on
draft-ietf-pce-stateful-pce above just to make the point.]

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 27 Oct 2016 12:26:48 +0000

Thanks!

Alvaro.

On 10/27/16, 8:09 AM, "BRUNGARD, DEBORAH A" <[email-masked]<mailto:[email-masked]>> wrote:

Thanks for the comments. I've discussed with the Chairs and Authors, and we will keep the document on the telechat for today. The Chairs and Authors think it is possible to change the language so the document can stand on its own. They believe the overall change is small (they already are scrubbing a version).

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Thu, 27 Oct 2016 12:09:52 +0000

Hi Alvaro,

Deborah

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of Alvaro Retana
> Sent: Tuesday, October 25, 2016 9:02 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]; pce-
> [email-masked]
> Subject: [Pce] Alvaro Retana's No Objection on draft-ietf-pce-stateful-pce-
> app-07: (with COMMENT)
> 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Mon, 31 Oct 2016 08:14:45 +0000

Dear Alvaro, 

   First of all, we would like to thank you for identifying the circular dependencies. After discussions among AD/chair/authors, we all agree with what you said below, i.e., " I think that the application scenarios and motivation for future extensions should be able to be described without referring to the extensions themselves". 

   So, we have worked out and uploaded a new version to remove all the dependencies that you have raised plus those we think should be cleared to make it generic/not depending on protocol extension drafts.  Could you please check the diff to see if you are happy with the latest version to proceed? (URL: https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-stateful-pce-app-08). 

Regards,
Xian 

-----邮件原件-----
发件人: Alvaro Retana [mailto:[email-masked]] 
发送时间: 2016年10月25日 21:02
收件人: The IESG
抄送: [email-masked]; Jonathan Hardwick; [email-masked]; [email-masked]; [email-masked]
主题: Alvaro Retana's No Objection on draft-ietf-pce-stateful-pce-app-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

This document mostly presents application scenarios, which (by reference) serve as motivation for draft-ietf-pce-stateful-pce.  However, there are a couple of places (in Section 4) where the operation defined in draft-ietf-pce-stateful-pce is used as part of the considerations.  For example (from 4.1):

I see a circular dependency between this document and draft-ietf-pce-stateful-pce, where the considerations here are expected to motivate the extensions, but the specific extensions are used to discuss “generic issues with stateful PCE deployments”.

Given that draft-ietf-pce-stateful-pce is a Normative Reference, I would rather see this document come back for IESG Evaluation with/after draft-ietf-pce-stateful-pce.  Note that draft-ietf-pce-stateful-pce is still (AFAICT) under consideration in the WG.

I am not making this comment a DISCUSS because I don’t think that it raises to the appropriate level (as only some parts of the document seem to have the dependency), and we’ll have to wait for draft-ietf-pce-stateful-pce to be processed before publication anyway. 
However, I think that the application scenarios and motivation for future extensions should be able to be described without referring to the extensions themselves — I would then like the authors, Shepherd and the responsible AD to consider whether it is possible for this document to stand on its own, or whether we need to process it with the extensions draft.  Given that draft-ietf-pce-stateful-pce is still in the WG, I think it is important for us to talk about it as this point.  I noted in the Shepherd’s writeup that this document used to be “originally included in the base stateful PCE protocol specification” (which I assume is draft-ietf-pce-stateful-pce).

To be clear: I am not opposing the publication of this document (even though the content could have been part of draft-ietf-pce-stateful-pce), I just think that in the current form it should be processed/published
*with* draft-ietf-pce-stateful-pce.

[Mechanisms from I-D.ietf-pce-stateful-sync-optimizations and I-D.ietf-pce-pce-initiated-lsp are also mentioned in similar ways, and those drafts are also in process in the WG.  I’m focusing on draft-ietf-pce-stateful-pce above just to make the point.]

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 31 Oct 2016 12:33:14 +0000

Xian:

Hi!

The new version looks good to me.

Thanks!!

Alvaro.

On 10/31/16, 4:14 AM, "Zhangxian (Xian)" <[email-masked]<mailto:[email-masked]>> wrote:

Could you please check the diff to see if you are happy with the latest version to proceed? (URL: https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-stateful-pce-app-08).

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Mon, 31 Oct 2016 16:47:45 +0000

Thanks Alvaro and Mirja for your comments to improve!
And Xian and authors for fast editing!
Deborah

From: Pce [mailto:[email-masked]] On Behalf Of Alvaro Retana (aretana)
Sent: Monday, October 31, 2016 8:33 AM
To: Zhangxian (Xian) <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Pce] Alvaro Retana's No Objection on draft-ietf-pce-stateful-pce-app-07: (with COMMENT)

Xian:

Hi!

Thanks!!

Alvaro.