Subject: [Pce] I-D Action: draft-ietf-pce-pcep-yang-09.txt

From: [email-masked]
Date: Mon, 15 Oct 2018 06:01:52 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Path Computation Element WG of the IETF.

        Title           : A YANG Data Model for Path Computation Element Communications Protocol (PCEP)
        Authors         : Dhruv Dhody
                          Jonathan Hardwick
                          Vishnu Pavan Beeram
                          Jeff Tantsura
	Filename        : draft-ietf-pce-pcep-yang-09.txt
	Pages           : 116
	Date            : 2018-10-15

Abstract:
   This document defines a YANG data model for the management of Path
   Computation Element communications Protocol (PCEP) for communications
   between a Path Computation Client (PCC) and a Path Computation
   Element (PCE), or between two PCEs.  The data model includes
   configuration data and state data (status information and counters
   for the collection of statistics).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-pce-pcep-yang-09
https://datatracker.ietf.org/doc/html/draft-ietf-pce-pcep-yang-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pcep-yang-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 15 Oct 2018 18:44:11 +0530

Hi WG,

The changes in this update are -

- Use of identity instead of typedef for lsp-error
- Reusing PST, Objective function, association-types from the te-types
- Update to PCEP-SR as per the SR capability TLV
- Simplification of key (as done by other yang models)
- Alignment to explicit-route-hop in te-types

The draft does not have any other pending actions.

Thanks!
Dhruv
PS. The yang errors in the datatracker are in the imported yang modules.

On Mon, Oct 15, 2018 at 6:32 PM <[email-masked]> wrote:

> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>

---

From: tom petch <[email-masked]>
Date: Tue, 16 Oct 2018 16:52:53 +0000

---- Original Message -----
From: "Dhruv Dhody" <[email-masked]>
Sent: Monday, October 15, 2018 2:14 PM

> The draft does not have any other pending actions.

Mmm why can I not resist the challenge?

You say
   RFC Ed.: In this section, replace all occurrences of 'XXXX' with the
   actual RFC number ...
and then
    import ietf-te {    prefix "te";    reference "RFC XXXX";    }
    import ietf-te-types {     prefix "te-types";    reference "RFC
XXXX";
    import ietf-tls-server {   prefix "tls-server";    reference "RFC
XXXX";   }
    import ietf-tls-client {    prefix "tls-client";     reference "RFC
XXXX";

Mmm I think not!

And, I like all the references in the YANG module but they need to be in
the references of the I-D.  I think you are missing

3209
5088
5089
5520
5541
5557
6536
8232
8306

while
8253
is there but Informative; my preference is for such references to be
Normative.

A common practice is to have a section just prior to the module proper
which gives references to all the RFC which the module references, which
obviates the appearance of warnings about  'Unused Reference'.

Tom Petch

> >         Title           : A YANG Data Model for Path Computation
Element
> > Communications Protocol (PCEP)
> >         Authors         : Dhruv Dhody
> >                           Jonathan Hardwick
> >                           Vishnu Pavan Beeram
> >                           Jeff Tantsura

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 17 Oct 2018 06:05:59 +0000

Hi Tom, 

> Mmm why can I not resist the challenge?

[[Dhruv Dhody]] I am glad you took the challenge and pointed these out :), I will update them along with the forthcoming yangdoctor's review!

Thanks! 
Dhruv 

> > > Please note that it may take a couple of minutes from the time of
> > > submission until the htmlized version and diff are available at
> > > tools.ietf.org.
> > >

---

From: tom petch <[email-masked]>
Date: Thu, 18 Oct 2018 16:53:28 +0000

Dhruv

I will have some more in a day or so.  Meanwhile,

I note that some of the lines exceed the limit allowed for an RFC, e.g.
in the tree diagrams.

The convention (rule almost) is to use the same prefix for the same
module in all cases; here you have
       import ietf-pcep {
          prefix p;
and
module ietf-pcep {
...
    prefix pcep;

I find it useful for the YANG reference clauses to include the name of
the RFC as well as the RFC number e.g.
       reference
         "RFC4360: BGP Extended Communities Attribute.
          RFC5668: 4-Octet AS Specific BGP Extended Community.";

Tom Petch

----- Original Message -----
From: "Dhruv Dhody" <[email-masked]>
Sent: Wednesday, October 17, 2018 7:05 AM

Hi Tom,

> Mmm why can I not resist the challenge?

[[Dhruv Dhody]] I am glad you took the challenge and pointed these out
:), I will update them along with the forthcoming yangdoctor's review!

Thanks!
Dhruv

> > > This draft is a work item of the Path Computation Element WG of
the
> IETF.