Subject: [Pce] FW: New Version Notification for draft-ietf-pce-segment-routing-13.txt

From: Jonathan Hardwick <[email-masked]>
Date: Fri, 12 Oct 2018 16:49:35 +0000

This revision addresses the recent comments from the shepherd review and the 2nd WGLC.
I believe that this is now ready for the IESG.  Dhruv - please check you are happy with it.

Thanks
Jon

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Friday, 12 October, 2018 5:47 PM
To: Wim Henderickx <[email-masked]>; Siva Sivabalan <[email-masked]>; Jonathan Hardwick <[email-masked]>; Jonathan Hardwick <[email-masked]>; Jeff Tantsura <[email-masked]>; Clarence Filsfils <[email-masked]>
Subject: New Version Notification for draft-ietf-pce-segment-routing-13.txt

A new version of I-D, draft-ietf-pce-segment-routing-13.txt
has been successfully submitted by Jon Hardwick and posted to the IETF repository.

Name:		draft-ietf-pce-segment-routing
Revision:	13
Title:		PCEP Extensions for Segment Routing
Document date:	2018-10-12
Group:		pce
Pages:		31
URL:            https://www.ietf.org/internet-drafts/draft-ietf-pce-segment-routing-13.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-pce-segment-routing/
Htmlized:       https://tools.ietf.org/html/draft-ietf-pce-segment-routing-13
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-pce-segment-routing
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-segment-routing-13

Abstract:
   Segment Routing (SR) enables any head-end node to select any path
   without relying on a hop-by-hop signaling technique (e.g., LDP or
   RSVP-TE).  It depends only on "segments" that are advertised by Link-
   State Interior Gateway Protocols (IGPs).  A Segment Routed Path can
   be derived from a variety of mechanisms, including an IGP Shortest
   Path Tree (SPT), explicit configuration, or a Path Computation
   Element (PCE).  This document specifies extensions to the Path
   Computation Element Communication Protocol (PCEP) that allow a
   stateful PCE to compute and initiate Traffic Engineering (TE) paths,
   as well as a PCC to request a path subject to certain constraints and
   optimization criteria in SR networks.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dhruv Dhody <[email-masked]>
Date: Sat, 13 Oct 2018 09:25:20 +0000

Thanks Jon for this update. 
All my previous comments are handled. 

I was preparing the shepherd report, could you update these - 

(1) IDnits - https://www.ietf.org/tools/idnits?url=https://www.ietf.org/archive/id/draft-ietf-pce-segment-routing-13.txt needs an update in references. 
  == Outdated reference: A later version (-19) exists of
     draft-ietf-isis-segment-routing-msd-16

  == Outdated reference: A later version (-23) exists of
     draft-ietf-ospf-segment-routing-msd-20

(2) Could you re-evaluate the internet drafts that are listed as normative references? In my view they are informative in nature. 

Thanks! 
Dhruv  

> From: Pce [mailto:[email-masked]] On Behalf Of Jonathan Hardwick
> Sent: 12 October 2018 22:20
> To: [email-masked]; Dhruv Dhody <[email-masked]>
> Subject: [Pce] FW: New Version Notification for draft-ietf-pce-segment-
> routing-13.txt
> 
> To: Wim Henderickx <[email-masked]>; Siva Sivabalan
> <[email-masked]>; Jonathan Hardwick <[email-masked]>;
> Jonathan Hardwick <[email-masked]>; Jeff Tantsura
> <[email-masked]>; Clarence Filsfils <[email-masked]>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: Jonathan Hardwick <[email-masked]>
Date: Sat, 13 Oct 2018 14:28:46 +0000

Hi Dhruv

I will fix these.  In evaluating your comment (2) I realized that the first paragraph of the introduction is not quite correct in the way it defines a segment.  I will update that, too.

Cheers
Jon

-----Original Message-----
From: Dhruv Dhody <[email-masked]> 
Sent: Saturday, 13 October, 2018 10:25 AM
To: Jonathan Hardwick <[email-masked]>; [email-masked]; Dhruv Dhody <[email-masked]>
Subject: RE: New Version Notification for draft-ietf-pce-segment-routing-13.txt

Thanks! 
Dhruv  

> Subject: [Pce] FW: New Version Notification for 
> draft-ietf-pce-segment- routing-13.txt
>