Subject: Re: [Pce] [Lsr] I-D Action: draft-wu-lsr-pce-discovery-security-support-01.txt

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 1 Dec 2018 22:30:11 +0000

Hi Qin, 
Thanks for addressing my comment. Additionally, I think we have enough support to accept this as a WG document (even w/o the formal endorsement of the PCE WG __
Thanks,
Acee

On 11/29/18, 1:34 AM, "Lsr on behalf of Qin Wu" <[email-masked] on behalf of [email-masked]> wrote:

    v-01 has just been posted to address received comments so far.
    The diff is:
    https://www.ietf.org/rfcdiff?url2=draft-wu-lsr-pce-discovery-security-support-01
    
    -Qin
    -----邮件原件-----
    发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
    发送时间: 2018年11月29日 14:29
    收件人: [email-masked]
    主题: I-D Action: draft-wu-lsr-pce-discovery-security-support-01.txt

    A New Internet-Draft is available from the on-line Internet-Drafts directories.

            Title           : IGP extension for PCEP security capability support in the PCE discovery
            Authors         : Diego R. Lopez
                              Qin Wu
                              Dhruv Dhody
                              Michael Wang
                              Daniel King
    	Filename        : draft-wu-lsr-pce-discovery-security-support-01.txt
    	Pages           : 10
    	Date            : 2018-11-28
    
    Abstract:
       When a Path Computation Element (PCE) is a Label Switching Router
       (LSR) participating in the Interior Gateway Protocol (IGP), or even a
       server participating in IGP, its presence and path computation
       capabilities can be advertised using IGP flooding.  The IGP
       extensions for PCE discovery (RFC 5088 and RFC 5089) define a method
       to advertise path computation capabilities using IGP flooding for
       OSPF and IS-IS respectively.  However these specifications lack a
       method to advertise PCEP security (e.g., Transport Layer
       Security(TLS), TCP Authentication Option (TCP-AO)) support
       capability.
    
       This document proposes new capability flag bits for PCE-CAP-FLAGS
       sub-TLV that can be announced as attribute in the IGP advertisement
       to distribute PCEP security support information.  In addition, this
       document updates RFC 5088 and RFC 5089 to allow advertisement of Key
       ID or Key Chain Name Sub-TLV to support TCP AO security capability.

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-wu-lsr-pce-discovery-security-support/
    
    There are also htmlized versions available at:
    https://tools.ietf.org/html/draft-wu-lsr-pce-discovery-security-support-01
    https://datatracker.ietf.org/doc/html/draft-wu-lsr-pce-discovery-security-support-01
    
    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-wu-lsr-pce-discovery-security-support-01

    Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
    
    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/
    
    _______________________________________________
    I-D-Announce mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/i-d-announce
    Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
    _______________________________________________
    Lsr mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lsr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 1 Dec 2018 22:32:12 +0000

Forgot to add, please republish as draft-ietf-lsr-pce-discovery-security-support-00... 
Thanks,
Acee

On 12/1/18, 5:30 PM, "Pce on behalf of Acee Lindem (acee)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Qin, 

        
        -Qin
        -----邮件原件-----
        发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
        发送时间: 2018年11月29日 14:29
        收件人: [email-masked]
        主题: I-D Action: draft-wu-lsr-pce-discovery-security-support-01.txt

        
        Abstract:

        

        

    _______________________________________________
    Pce mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/pce