Subject: Re: [Pce] Rtgdir last call review of draft-farrel-pce-stateful-flags-02

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Mon, 4 Nov 2019 19:18:46 +0000

Hi Mike,

Much thanks for your review!

Adrian, I'm also a bit confused on the intention of the draft. While the tools are not error checking a draft with intended status of PS against a title indicating an individual submission, the title does indicate the source of the document. With the current title, this document is an individual submission to the IETF stream. If this is a product of the working group, the title needs to reflect it. As it is requested to be "PS", it does need to reflect the associated working group.

While it is a bit surprising this was not raised in WG Last Call (hopefully folks have read the document), it will definitely be flagged with the other Area Directorate reviews and IESG review. While the working group cycle was very short, the resulting publication cycle will be very long.

As the WG LC was based on PS status, I would conclude the group is ok with PS. Either you can change the title to reflect a product of the pce working group or change the status to Informational and I'll take it forward as an individual submission. If you change the title to a product of the pce working group, I'll follow up with a note to the list to double check if anyone has any concerns. And then we can move ahead.

Looking forward to your choice😊
Deborah

-----Original Message-----
From: Adrian Farrel <[email-masked]> 
Sent: Thursday, October 31, 2019 4:25 AM
To: 'Mike McBride' <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Rtgdir last call review of draft-farrel-pce-stateful-flags-02

Hi Mike,

Thanks for taking the time to read this.

> Great job on the easy to understand draft. I probably don't want to 
> know the history of why this is an individual draft but I am curious. 
> I'll ask Adrian over a drink sometime.

Not rejecting the idea of a drink, but just sharing with the wider community...

It is fun to exercise the full range of IETF process options from time to time.
The chairs did not think it was necessary to delay the draft by putting it into the adoption queue and going through all that piece of process when all that was needed was a last call.

> Nits for your consideration:
>
> Abstract:
> "Extensions to the Path Computation Element communications Protocol"
> -capitalize "communications" as you do in the Introduction.

Oh look! Officially there is no 's' on Communication. (Also right in the Introduction) Thanks.

> 4. Compatibility Considerations
> ..
> "It should be noted that common behavior for flags fields is as 
> described by the updated text presented in Section 3 so many 
> implementations, lacking guidance from RFC 8231, will still have 
> implemented a consistent and future-proof approach."
>
> For better readability change to:
> "It should be noted that common behavior for flags fields is as 
> described by the updated text presented in Section 3. Therefore, many 
> implementations, lacking guidance from RFC 8231, will still have 
> implemented a consistent and future-proof approach." Or something similar.
>
> Consider removing all instances of the word "so".

So, you think 'so' is so so-so?

Yup. Caught a couple of equally ambiguous cases.

Best,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 4 Nov 2019 21:46:35 -0000

Hello Deborah,

I wonder whether something has changed in the IETF process that I'm not aware of. That is possible.

> Adrian, I'm also a bit confused on the intention of the draft. While
> the tools are not error checking a draft with intended status of PS
> against a title indicating an individual submission, the title does 
> indicate the source of the document. With the current title, this
> document is an individual submission to the IETF stream. If this
> is a product of the working group, the title needs to reflect it. As
> it is requested to be "PS", it does need to reflect the associated
> working group.

The document has not been adopted by the working group, but it has been last called by the working group.
While the WG chairs are allowed to adopt a document off their own bat, they prefer to use an adoption poll whenever they do an adoption. That can add a two week poll, but there is also a queue in many working groups, so a document can end up dying of boredom.

If you can point me at the process rule that says that document emerging from a WG must have a specific name format then I guess we can change the document (and also write a draft to change the rule ;-) 

If you can point me at the rule that says Standards Track documents must be the product of a working group (not, for example, AD sponsored) I'll be surprised.

> While it is a bit surprising this was not raised in WG Last Call (hopefully
> folks have read the document), 

The chairs did call out the direct progression of this draft to WG last call in a mail to the list prior to starting the last call.

> it will definitely be flagged with the other
> Area Directorate reviews and IESG review.

I shall delight in helping them to understand the processes of which they are guardians :-)

> While the working group cycle was very short, the resulting publication
> cycle will be very long.

Oh, I have long ago given up on doing things to simply follow the path of least resistance. The IESG needs to recognise that they are supposed to facilitate publication (of good documents) not get in the way! If the resulting cycle is long we will at least know why.

> As the WG LC was based on PS status, I would conclude the group is 
> ok with PS. Either you can change the title to reflect a product of the
> pce working group or change the status to Informational and I'll take
> it forward as an individual submission. If you change the title to a
> product of the pce working group, I'll follow up with a note to the list
> to double check if anyone has any concerns. And then we can move
> ahead.

I do hope that we will not get hung up on any misunderstandings of process. As you observe, the publication cycle for drafts has become long. Many times they leave the WG and don't hit the RFC Editor Queue for four months.. I see the process including:
- Shepherd review
- Directorate review
- AD review
- IETF last call
- Late directorate reviews
- IESG review
Each of these has three steps:
- Queued for action
- Review period
- Update period

Even when the authors are immediately responsive to any review comments raised, this can drag on a long time. If each review is scheduled for two weeks, that's 12 weeks burned. If the "silent" time to queue for action is also a week or two, you can quickly see why the tail of our process has become a burden. Suddenly the RFC Editor's 8 week queue seems short!

> Looking forward to your choice😊

My choice as author is to follow IETF process.
You've had a publication request, from the PCE working group to publish an Internet-Draft on the Standards Track.
I hope we can proceed with that without further delay.

Thanks,
Adrian

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 5 Nov 2019 19:55:53 +0000

Hi Adrian,

What you say is all correct. But it doesn't help with the confusion. I just need to know if this is an individual draft requesting to be PS or is it requested by a working group and (for whatever reason) the filename was not changed to reflect it. There's several guideline documents on filenames:
ftp://ftp.ietf.org/ietf/1id-guidelines.txt
https://tools.ietf.org/html/rfc6174

There is no need for chairs to spend "weeks" adopting or last calling. What is needed though is for the filename to reflect the correct "source". RFC6174 provides the logistics. Uploading with a wg filename takes seconds (if all is working correctly😊).

As you say, you are an author hoping to quickly progress your document. I'll talk with the PCE chairs as they requested the publication and unless I'm mis-interpreting this can be quickly fixed.

Thanks-
Deborah

-----Original Message-----
From: Adrian Farrel <[email-masked]> 
Sent: Monday, November 04, 2019 4:47 PM
To: BRUNGARD, DEBORAH A <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: Rtgdir last call review of draft-farrel-pce-stateful-flags-02

Hello Deborah,

> document is an individual submission to the IETF stream. If this is a 
> product of the working group, the title needs to reflect it. As it is 
> requested to be "PS", it does need to reflect the associated working 
> group.

> While it is a bit surprising this was not raised in WG Last Call 
> (hopefully folks have read the document),

> it will definitely be flagged with the other Area Directorate reviews 
> and IESG review.

> While the working group cycle was very short, the resulting 
> publication cycle will be very long.

> As the WG LC was based on PS status, I would conclude the group is ok 
> with PS. Either you can change the title to reflect a product of the 
> product of the pce working group, I'll follow up with a note to the 
> list to double check if anyone has any concerns. And then we can move 
> ahead.

Thanks,
Adrian

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 6 Nov 2019 17:37:41 +0000

Hi PCE WG,

I've talked with your Chairs and my fellow ADs (Martin and Alvaro). The intent for this document was to be a working group document as it is updating a PCE PS document. It was felt there was no need for renaming to reflect a working group document.

RFC6174 defines Working Group document states. Datatracker uses the filenames to determine the status and the I-D repository. For a document to reflect the source being a working group, the filename needs to reflect it as draft-ietf-wgname.

Martin, Alvaro, and myself agree the filename needs to reflect the wg. It only takes seconds to upload a revised filename. While Adrian is concerned on delays, there is no need for a Chair to poll for "adoption" or "Last Call" a document. What is critical is that a PS document has the appropriate visibility and adequate review for folks to raise concerns/comments. In IETF, the filename is used to identify and it is questionable if an individual filename document receives the appropriate visibility. It only takes seconds to post a new filename.

On this specific document, I noted -00 was posted in June, there were no comments before WG Last Call poll in September. On poll for WG Last Call, only the author responded supporting. Dhruv asked a second time on the list, there were 4 responses. This draft identifies a lack of specification in RFC8231, the proposed change is not backward compatible. A private poll was done and indicates existing implementations are ok with this modification. While among the PCE working group, there often are a small number of respondents, I am concerned the filename itself may not have provided the necessary visibility. Before IETF Last Calling, I have returned the document to the working group to allow the Chairs to change the filename. If anyone in the working group has any concerns/comments on the document, let the Chairs know and also there will be an opportunity to comment during IETF Last Call.

A note to all of you, for the Chairs to judge consensus it is critical for folks to be involved in discussions - support or not support. Do not be shy! The working group mailing lists are looked at by the IESG, IAB, and others (internal and external to IETF) to determine interest/participation level in our standards process. The IAB is evaluating now the process including RFC value (implementations):
https://www.ietf.org/id/draft-huitema-rfc-eval-project-02.txt

The conclusion is the working group process itself introduces the most delays - there are multiple reasons. Let's not have lack of interest by the working group be a delay.

And of course - do not be shy if any questions/concerns on my (or Alvaro's, Martin's) decisions-
Deborah 

-----Original Message-----
From: BRUNGARD, DEBORAH A <[email-masked]> 
Sent: Tuesday, November 05, 2019 2:56 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; <[email-masked]> ([email-masked]) <[email-masked]>
Subject: RE: Rtgdir last call review of draft-farrel-pce-stateful-flags-02

Hi Adrian,

What you say is all correct. But it doesn't help with the confusion. I just need to know if this is an individual draft requesting to be PS or is it requested by a working group and (for whatever reason) the filename was not changed to reflect it. There's several guideline documents on filenames:
https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_ietf_1id-2Dguidelines.txt&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=8qrvlOQg1GT4q_O677NusZSTqgkju7l-dX4uZotGXPw&s=qmvYdzxgPAjTZT9nVsMNJsjIhqGg9T9onROYLCEr07Y&e=
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc6174&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=8qrvlOQg1GT4q_O677NusZSTqgkju7l-dX4uZotGXPw&s=jIQEYvuJDL88KaOl6eDBZM5x75ZOcFDjdKo0C9ao0Rw&e=

Thanks-
Deborah

-----Original Message-----
From: Adrian Farrel <[email-masked]>
Sent: Monday, November 04, 2019 4:47 PM
To: BRUNGARD, DEBORAH A <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: Rtgdir last call review of draft-farrel-pce-stateful-flags-02

Hello Deborah,

Thanks,
Adrian