Subject: Re: [Pce] I-D Action: draft-ietf-pce-pcep-yang-12.txt

From: tom petch <[email-masked]>
Date: Tue, 12 Nov 2019 12:15:52 +0000

Dhruv

I note that -13 has appeared and wondered what significance I should
read into this.

Tom Petch

----- Original Message -----
From: "Dhruv Dhody" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 01, 2019 1:14 PM

> Hi WG,
>
> This update includes -
>
> * Pending issues as pointed out by Tom Petch
>      - Use the right prefix for imported modules
>      - Removed [] around the reference I-Ds in YANG modules
>      - Updated IANA
> * Added lsp-id as an additional key for LSP-DB
>      - Useful in case of MBB
> * Added implementation section
>      - If you are aware of an implementation of this YANG module,
please
>        reach out.
>
>
> Diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pcep-yang-12
>
> Thanks!
> Dhruv (on behalf of co-authors)
>
> On Mon, Jul 1, 2019 at 4:54 PM <[email-masked]> wrote:
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> > This draft is a work item of the Path Computation Element WG of the
IETF.
> >
> >         Title           : A YANG Data Model for Path Computation
Element Communications Protocol (PCEP)
> >         Authors         : Dhruv Dhody
> >                           Jonathan Hardwick
> >                           Vishnu Pavan Beeram
> >                           Jeff Tantsura
> >         Filename        : draft-ietf-pce-pcep-yang-12.txt
> >         Pages           : 113
> >         Date            : 2019-07-01
> >
> > Abstract:
> >    This document defines a YANG data model for the management of
Path
> >    Computation Element communications Protocol (PCEP) for
communications
> >    between a Path Computation Client (PCC) and a Path Computation
> >    Element (PCE), or between two PCEs.  The data model includes
> >    configuration and state data.
> >
> >
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-yang/
> >
> > There are also htmlized versions available at:
> > https://tools.ietf.org/html/draft-ietf-pce-pcep-yang-12
> > https://datatracker.ietf.org/doc/html/draft-ietf-pce-pcep-yang-12
> >
> > A diff from the previous version is available at:
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pcep-yang-12
> >
> >
> > Please note that it may take a couple of minutes from the time of
submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > _______________________________________________
> > Pce mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/pce
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 12 Nov 2019 16:21:32 +0000

Hi Tom, 

The -13 version does not have any technical change, it handles a few yang guideline statement ordering and tree depth change. 

https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pcep-yang-13

We are awaiting movement of some dependent yang models before moving ahead with this one! 

Thanks! 
Dhruv

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of tom petch
> Sent: 12 November 2019 17:46
> To: Dhruv Dhody <[email-masked]>; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Pce] I-D Action: draft-ietf-pce-pcep-yang-12.txt
> 
> Dhruv
> 
> I note that -13 has appeared and wondered what significance I should read
> into this.
> 
> Tom Petch
> 
>

---

From: tom petch <[email-masked]>
Date: Tue, 12 Nov 2019 16:44:34 +0000

----- Original Message -----
From: "Dhruv Dhody" <[email-masked]>
Sent: Tuesday, November 12, 2019 4:21 PM

Hi Tom,

The -13 version does not have any technical change, it handles a few
yang guideline statement ordering and tree depth change.

We are awaiting movement of some dependent yang models before moving
ahead with this one!

<tp>

If you are waiting for what I think you are waiting for, it could be a
long wait.  Quote from a recent post on another list talking generally
about a large cluster of I-D, one of which is in the Normative
References here

"
> I think it is quite clear that the WG doesn't want more delays.

Is it?   I only know that Balazs K. wishes to have the first three
drafts (crypto-types, truststore, and keystore) completed soon.  The
Nokia/BBF folks were interested in netconf-server, but forked long ago.
Otherwise, I'm unaware of anyone stating a preference.   For myself, I
only hope to achieve a good result.
"

Keep waiting:-(

Tom Petch

Thanks!
Dhruv

> I note that -13 has appeared and wondered what significance I should
read
>pce