Subject: [Pce] Please confirm whose name the SR Policy Name TLV carries in the draft

From: huruizhao <[email-masked]>
Date: Tue, 19 May 2020 02:08:01 +0000

Hi authors,
  In the section 5.2 of [draft-barth-pce-segment-routing-policy-cp-05], SR Policy Name TLV is defined to carry Policy name. Policy name and Candidate Path name have different definitions in [draft-ietf-spring-segment-routing-policy-06#section 2.1/2.6]. And there MAY be ambiguity here, I think this TLV carries name to Candidate Path instead of name to Policy.  The reasons are :

(1) There are multiple sources for the SR Policy of the head node. There will be multiple different Names to the same Policy if the PCE is allowed to deliver the Policy Name, which is difficult to manage.
(2) In [draft-ietf-idr-segment-routing-te-policy-08#section-2.4.6],  the draft clearly states "the Policy Name sub-TLV to attach a symbolic name to the SR Policy candidate path". The realization of BGP for SR Policy has reference value for PCEP.

  Please confirm whose name the SR Policy Name TLV carries in the draft.

Kind regards,
Ruizhao

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Tue, 19 May 2020 14:17:31 +0000

Hi Ruizhao,

The intent of SRPOLICY-POL-NAME TLV is to carry the *policy* name. We didn't define a TLV to carry the CPATH name in this draft, we assumed the PCEP symbolic-name can be used for that purpose. If required, we can definitely add another TLV to carry the CPATH name, if you want it to be separate from the PCEP symbolic name.

Regarding your points:

  1.  It is true that different CPATHs of the same policy can potentially contain different policy-name values. To ease debugging, it's much easier if all CPATHs of the same policy have the same policy-name. Regardless, policy-name is useful because the SR Policy Architecture does say that the policy-name (or names) MAY be used to identify an SR Policy. So we need to have a way to encode the policy-name(s) in PCEP.

2.1<https://tools.ietf.org/html/draft-ietf-spring-segment-routing-policy-07#section-2.1>.  Identification of an SR Policy

...

   An implementation MAY allow assignment of a symbolic name comprising

   of printable ASCII characters to an SR Policy to serve as a user-

   friendly attribute for debug and troubleshooting purposes.  Such

   symbolic names may identify an SR Policy when the naming scheme

   ensures uniqueness.

  1.  I will follow up with the authors of the IDR draft to clarify that there are two names: policy-name and cpath-name. I believe the wording needs to be corrected.

Thanks,
Mike.

From: huruizhao <[email-masked]>
Sent: Monday, May 18, 2020 10:08 PM
To: [email-masked]; [email-masked]
Cc: Lihanlin <[email-masked]>; Tanren <[email-masked]>
Subject: Please confirm whose name the SR Policy Name TLV carries in the draft

Hi authors,

Kind regards,
Ruizhao