Subject: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

From: Dhruv Dhody <[email-masked]>
Date: Thu, 5 Nov 2020 12:28:57 +0530

Hi Authors,

In
https://tools.ietf.org/html/draft-ietf-pce-segment-routing-policy-cp-01#section-4.2
,  you state -

   The Association Source MUST be set to the PCC's address.  This
>    applies for both PCC-initiated and PCE-initiated candidate paths.
>    The reasoning for this is that if different PCEs could set their own
>    Association Source, then the candidate paths instantiated by
>    different PCEs would by definition be in different PCEP Associations,
>    which contradicts our requirement that the SR Policy is represented
>    by an Association.

>
>    The Association ID MUST be chosen by the PCC when the SR policy is
>    allocated.  In PCRpt messages from the PCC, the Association ID MUST
>    be set to the unique value that was allocated by the PCC at the time
>    of policy creation.  In PCInit messages from the PCE, the Association
>    ID MUST be set to the reserved value 0, which indicates that the PCE
>    is asking the PCC to choose an ID value.  The PCE MUST NOT send the
>    Extended Association ID TLV in the PCInit messages.

But the base RFC 8697
https://www.rfc-editor.org/rfc/rfc8697.html#section-6.1.3 gave quite a bit
of leeway while setting the association source.

Consider 2 PCEs - PCE1 & PCE2, I am assuming if candidate paths are created
via two different PCEs both will be aware of SR Policy identifiers (color,
end-point, etc). When PCE1 initiates CP1, it could use the association
source as Virtual-IP or NMS (instead of PCE1). The PCE2 will learn about
the association and the corresponding SR policy parameters via the PCRpt
message which is sent to both PCEs. So when the PCE2 initiates CP2, it
could use the same association!

This was the very reason to include the flexibility in setting the
association source in RFC 8697.

Julien and I discussed this and we feel you are trying to solve the issue
of sharing an association ID between several PCEs by using a new mean than
the one in RFC 8697. If you have other reasons then please state them,
otherwise, RFC 8697 should take precedence.

Thanks!
Dhruv & Julien

PS. I quickly drew a figure if that helps (see attached)!

On Tue, Oct 27, 2020 at 8:42 PM <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Path Computation Element WG of the IETF.
>
>         Title           : PCEP extension to support Segment Routing Policy
> Candidate Paths
>         Authors         : Mike Koldychev
>                           Siva Sivabalan
>                           Colby Barth
>                           Shuping Peng
>                           Hooman Bidgoli
>         Filename        : draft-ietf-pce-segment-routing-policy-cp-01.txt
>         Pages           : 20
>         Date            : 2020-10-27
>
> Abstract:
>    This document introduces a mechanism to specify a Segment Routing
>    (SR) policy, as a collection of SR candidate paths.  An SR policy is
>    identified by <headend, color, end-point> tuple.  An SR policy can
>    contain one or more candidate paths where each candidate path is
>    identified in PCEP via an PLSP-ID.  This document proposes extension
>    to PCEP to support association among candidate paths of a given SR
>    policy.  The mechanism proposed in this document is applicable to
>    both MPLS and IPv6 data planes of SR.
>
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-pce-segment-routing-policy-cp/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-pce-segment-routing-policy-cp-01
>
> https://datatracker.ietf.org/doc/html/draft-ietf-pce-segment-routing-policy-cp-01
>
> A diff from the previous version is available at:
>
> https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-segment-routing-policy-cp-01
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Thu, 5 Nov 2020 14:21:03 +0000

Hi Dhruv,

Thanks for bringing this up.

By setting ASSO_SOURCE = PCC_ADDRESS, we guarantee that:

  1.  all 3 parties: PCC, PCE1 and PCE2 agree on the same source, AND
  2.  they agree without talking to each other.

In your proposal below, if we set ASSO_SOURCE = NMS_ADDRESS, it seems that condition 1 may be fulfilled, but it requires exchange of PCRupt/PCUpd messages between the 3 entities, which violates condition 2. Please correct me if I misunderstood something. In the picture that you drew, you say that “Policy Endpoint=X” and “Association Source=X”, are you suggesting to use the policy endpoint as the ASSO_SOURCE? That would satisfy both conditions, but I’m not sure if you intended that?

I believe condition 2 is important to satisfy, because otherwise there could be race conditions where the 3 parties have different ASSOC_SOURCE for the same policy. Consider what happens when all 3 parties try to create the same policy at the same time.

I’m open to any proposal, but IMO we should respect the above two requirements.

Thanks,
Mike.

From: Dhruv Dhody <[email-masked]>
Sent: Thursday, November 5, 2020 1:59 AM
To: [email-masked]
Cc: [email-masked]; pce-chairs <[email-masked]>
Subject: Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Authors,

In https://tools.ietf.org/html/draft-ietf-pce-segment-routing-policy-cp-01#section-4.2,  you state -

But the base RFC 8697 https://www.rfc-editor.org/rfc/rfc8697.html#section-6.1.3 gave quite a bit of leeway while setting the association source.

Consider 2 PCEs - PCE1 & PCE2, I am assuming if candidate paths are created via two different PCEs both will be aware of SR Policy identifiers (color, end-point, etc). When PCE1 initiates CP1, it could use the association source as Virtual-IP or NMS (instead of PCE1). The PCE2 will learn about the association and the corresponding SR policy parameters via the PCRpt message which is sent to both PCEs. So when the PCE2 initiates CP2, it could use the same association!

This was the very reason to include the flexibility in setting the association source in RFC 8697.

Julien and I discussed this and we feel you are trying to solve the issue of sharing an association ID between several PCEs by using a new mean than the one in RFC 8697. If you have other reasons then please state them, otherwise, RFC 8697 should take precedence.

Thanks!
Dhruv & Julien

On Tue, Oct 27, 2020 at 8:42 PM <[email-masked]<mailto:[email-masked]>> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Path Computation Element WG of the IETF.

        Title           : PCEP extension to support Segment Routing Policy Candidate Paths
        Authors         : Mike Koldychev
                          Siva Sivabalan
                          Colby Barth
                          Shuping Peng
                          Hooman Bidgoli
        Filename        : draft-ietf-pce-segment-routing-policy-cp-01.txt
        Pages           : 20
        Date            : 2020-10-27

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
Pce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pce

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 5 Nov 2020 21:13:02 +0530

Hi Mike,

On Thu, Nov 5, 2020 at 7:51 PM Mike Koldychev (mkoldych) <[email-masked]>
wrote:

> In your proposal below, if we set ASSO_SOURCE = NMS_ADDRESS, it seems that
> condition 1 may be fulfilled, but it requires exchange of PCRupt/PCUpd
> messages between the 3 entities, which violates condition 2. Please correct
> me if I misunderstood something. In the picture that you drew, you say that
> “Policy Endpoint=X” and “Association Source=X”, are you suggesting to use
> the policy endpoint as the ASSO_SOURCE? That would satisfy both conditions,
> but I’m not sure if you intended that?
>
>
>

No, I did not!

> I believe condition 2 is important to satisfy, because otherwise there
> could be race conditions where the 3 parties have different ASSOC_SOURCE
> for the same policy. Consider what happens when all 3 parties try to create
> the same policy at the same time.
>
>
>

The SR-Policy association is "dynamic" in nature, and we need to go by the
association parameters we receive from the PCEP peer. Condition 2 of
talking to each other is the very nature of a dynamic association!

If the race condition is the issue to solve, we can use the SR-Policy
parameters (color, endpoint, source). And make sure there is only
one SR-Policy-association-group with a given set of SR-Policy parameters
(and generate an error otherwise). The other PCE would learn about the
association and can use it subsequently!

> I’m open to any proposal, but IMO we should respect the above two

I feel the requirement 2 is not compatible with a dynamic association.

Thanks!
Dhruv

> Thanks,
>
> Mike.
>
>
>
> *From:* Dhruv Dhody <[email-masked]>
> *Sent:* Thursday, November 5, 2020 1:59 AM
> *To:* [email-masked]
> *Cc:* [email-masked]; pce-chairs <[email-masked]>
> *Subject:* Association Source in
> draft-ietf-pce-segment-routing-policy-cp-01
>
>
>
> Hi Authors,
>
> In
> https://www.rfc-editor.org/rfc/rfc8697.html#section-6.1.3 gave quite a
> bit of leeway while setting the association source.
>
> Consider 2 PCEs - PCE1 & PCE2, I am assuming if candidate paths are
> created via two different PCEs both will be aware of SR Policy identifiers
> (color, end-point, etc). When PCE1 initiates CP1, it could use the
> association source as Virtual-IP or NMS (instead of PCE1). The PCE2 will
> learn about the association and the corresponding SR policy parameters via
> the PCRpt message which is sent to both PCEs. So when the PCE2 initiates
> CP2, it could use the same association!
>

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Thu, 5 Nov 2020 16:04:28 +0000

Hi Dhruv,

Perhaps we can avoid this by letting PCE send PCInitiate message with Association Source set to some reserved value, like 0. This can mean that the PCE is basically requesting the PCC to allocate an Association Source and to “own” that Association. We already do this with the Association ID. PCE sets the ID to 0 in PCInitiate and PCC chooses an Association ID and reports it back.

Thanks,
Mike.

From: Dhruv Dhody <[email-masked]>
Sent: Thursday, November 5, 2020 10:43 AM
To: Mike Koldychev (mkoldych) <[email-masked]>
Cc: [email-masked]; [email-masked]; pce-chairs <[email-masked]>
Subject: Re: Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike,

On Thu, Nov 5, 2020 at 7:51 PM Mike Koldychev (mkoldych) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Dhruv,

No, I did not!

The SR-Policy association is "dynamic" in nature, and we need to go by the association parameters we receive from the PCEP peer. Condition 2 of talking to each other is the very nature of a dynamic association!

If the race condition is the issue to solve, we can use the SR-Policy parameters (color, endpoint, source). And make sure there is only one SR-Policy-association-group with a given set of SR-Policy parameters (and generate an error otherwise). The other PCE would learn about the association and can use it subsequently!

Thanks!
Dhruv

Thanks,
Mike.

From: Dhruv Dhody <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, November 5, 2020 1:59 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; pce-chairs <[email-masked]<mailto:[email-masked]>>
Subject: Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Authors,

Thanks!
Dhruv & Julien

Abstract:

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 5 Nov 2020 21:46:10 +0530

Hi Mike,

> Perhaps we can avoid this by letting PCE send PCInitiate message with Association Source set to some reserved value, like 0. This can mean that the PCE is basically requesting the PCC to allocate a…

The comment was applicable for association-id as well as
association-source! The use of 0 as association ID is being introduced
by your draft and not part of the base RFC 8697 and that triggered the
original email. Julien and I were uncomfortable with that and wanted
to understand what is new here for SR policy association that requires
a new procedure and cant be handled by RFC 8697.

Thanks,
Dhruv

> On Thu, Nov 5, 2020 at 7:51 PM Mike Koldychev (mkoldych) <[email-masked]> wrote:
>
> Hi Dhruv,
>
>
>
> all 3 parties: PCC, PCE1 and PCE2 agree on the same source, AND
> they agree without talking to each other.
>
>
>

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Thu, 5 Nov 2020 16:25:17 +0000

Hi Dhruv,

Yes, I think we should standardize this mechanism - allowing PCE to request PCC to allocate Association ID and Source.

Thanks,
Mike.

-----Original Message-----
From: Dhruv Dhody <[email-masked]> 
Sent: Thursday, November 5, 2020 11:16 AM
To: Mike Koldychev (mkoldych) <[email-masked]>
Cc: [email-masked]; [email-masked]; pce-chairs <[email-masked]>
Subject: Re: Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike,

> Perhaps we can avoid this by letting PCE send PCInitiate message with Association Source set to some reserved value, like 0. This can mean that the PCE is basically requesting the PCC to allocate a…

The comment was applicable for association-id as well as association-source! The use of 0 as association ID is being introduced by your draft and not part of the base RFC 8697 and that triggered the original email. Julien and I were uncomfortable with that and wanted to understand what is new here for SR policy association that requires a new procedure and cant be handled by RFC 8697.

Thanks,
Dhruv

> Subject: Re: Association Source in 
> all 3 parties: PCC, PCE1 and PCE2 agree on the same source, AND they 
> agree without talking to each other.
>
>
>
> Subject: Association Source in 
> https://tools.ietf.org/html/draft-ietf-pce-segment-routing-policy-cp-0
> 1#section-4.2,  you state -
>
> submission until the htmlized version and diff are available at tools.ietf.org.
>

---

From: Cyril Margaria <[email-masked]>
Date: Thu, 5 Nov 2020 16:35:20 +0000

I have a related question: how do you define the "PCC address", PCEP
session address , one router id?

For the association source race condition, the race condition will result
in a "Conflicting SRPAG TLV" from a PCInitiate/PCUpd, the PCE can use the
correct SRPAG.

On Thu, 5 Nov 2020 at 16:16, Dhruv Dhody <[email-masked]> wrote:

> > Perhaps we can avoid this by letting PCE send PCInitiate message with
> Association Source set to some reserved value, like 0. This can mean that
> the PCE is basically requesting the PCC to allocate an Association Source
> and to “own” that Association. We already do this with the Association ID.
> PCE sets the ID to 0 in PCInitiate and PCC chooses an Association ID and
> reports it back.
> >
> >
>
> > In your proposal below, if we set ASSO_SOURCE = NMS_ADDRESS, it seems
> that condition 1 may be fulfilled, but it requires exchange of PCRupt/PCUpd
> > The SR-Policy association is "dynamic" in nature, and we need to go by
> the association parameters we receive from the PCEP peer. Condition 2 of
> parameters (color, endpoint, source). And make sure there is only one
> SR-Policy-association-group with a given set of SR-Policy parameters (and
> generate an error otherwise). The other PCE would learn about the
> https://tools.ietf.org/html/draft-ietf-pce-segment-routing-policy-cp-01#section-4.2,
> you state -
> >
> > Julien and I discussed this and we feel you are trying to solve the
> issue of sharing an association ID between several PCEs by using a new mean
> than the one in RFC 8697. If you have other reasons then please state them,

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 5 Nov 2020 22:05:00 +0530

Hi Mike,

And if you want to do that, please explain the scenario that requires
the new procedure (and explain why not use RFC 8697 mechanisms
itself). That was the original ask in the first email.

Thanks!
Dhruv
PS. IMHO the race condition scenario can be solved by RFC 8697 and the
SR Policy parameter check.

On Thu, Nov 5, 2020 at 9:55 PM Mike Koldychev (mkoldych)
<[email-masked]> wrote:
> > 1

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Thu, 5 Nov 2020 16:57:51 +0000

Hi Dhruv,

The scenario is when the same SR Policy is created on the PCC and the PCE at the same time (or from multiple PCEs at the same time). If we follow RFC 8697 procedures, it can result in each entity generating its own Association ID and Source.

It's not a good protocol design to use Error messages to resolve timing/race conditions. IMO it's not acceptable that PCError messages can appear at random, even when every party is complying to the protocol.

So I propose to enhance the RFC 8697 procedures to allow a PCEP speaker to request Association ID/Source to be allocated from the remote peer, by sending a 0 value, which is reserved today.

Thanks,
Mike.

-----Original Message-----
From: Dhruv Dhody <[email-masked]> 
Sent: Thursday, November 5, 2020 11:35 AM
To: Mike Koldychev (mkoldych) <[email-masked]>
Cc: [email-masked]; [email-masked]; pce-chairs <[email-masked]>
Subject: Re: Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike,

And if you want to do that, please explain the scenario that requires the new procedure (and explain why not use RFC 8697 mechanisms itself). That was the original ask in the first email.

Thanks!
Dhruv
PS. IMHO the race condition scenario can be solved by RFC 8697 and the SR Policy parameter check.

On Thu, Nov 5, 2020 at 9:55 PM Mike Koldychev (mkoldych) <[email-masked]> wrote:
> > https://datatracker.ietf.org/doc/draft-ietf-pce-segment-routing-poli
> > cy
> > -cp/
> >
> > https://datatracker.ietf.org/doc/html/draft-ietf-pce-segment-routing
> > -p
> > olicy-cp-01
> >
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-segment-routing-pol
> > ic
> > y-cp-01
> >
> >

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Thu, 5 Nov 2020 18:30:32 +0000

Hi Cyril,

See inline with [MK]

From: Cyril Margaria <[email-masked]>
Sent: Thursday, November 5, 2020 11:35 AM
To: Dhruv Dhody <[email-masked]>
Cc: Mike Koldychev (mkoldych) <[email-masked]>; [email-masked]; pce-chairs <[email-masked]>; [email-masked]
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

I have a related question: how do you define the "PCC address", PCEP session address , one router id?
[MK] By PCC Address, I meant the IP address of the PCEP session. I believe a better approach is actually to set Association Source in PCInitiate message to 0.0.0.0 or 0::0 and let the PCC allocate the correct Source, same as how Association ID allocation is proposed in the draft.

For the association source race condition, the race condition will result in a "Conflicting SRPAG TLV" from a PCInitiate/PCUpd, the PCE can use the correct SRPAG.
[MK] It’s not a good protocol design to allow PCError messages to appear randomly when all the parties are following the protocol. Would really like to avoid that.

On Thu, 5 Nov 2020 at 16:16, Dhruv Dhody <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mike,

Thanks,
Dhruv

> To: Mike Koldychev (mkoldych) <[email-masked]<mailto:[email-masked]>>
> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; pce-chairs <[email-masked]<mailto:[email-masked]>>

---

From: "Stone, Andrew (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 5 Nov 2020 20:48:08 +0000

Hi Mike, Dhruv, Cyril:

We do use errors on initiate messages during race conditions, for example, symbolic name uniqueness on pce-initiated vanilla LSPs. So error based protection to enforce uniqueness and protect race conditions is manageable/done today.

However: would it make sense for the SRPAG definition, to be defined by the ‘first’ entity which created the candidate path? when it’s a shared construct with other entities which are now forced to re-use that value? Using a Virtual IP on the PCE(s) would certainly help, but wouldn’t work correctly with mixed use PCC/PCE init candidate paths (would anyone do that?), or different vendor PCE/clusters/different virtual IPs would add more complexity.  The common element I see is the uniqueness on PCC and the fact that SRPAG==SRPolicy. Since Association Source is ‘scoping for the association ID’, and there is no association scoping used/needed, then the value is essentially unused – therefore just a dummy value assigned by PCC?

I think there is a bit of ambiguity as mentioned (PCEP session? Router ID? ), and still run the risk that PCEP is terminating on different addresses towards different PCEs / different view of the ‘PCC address’.  Requesting the PCC to just assign the (unused?) value seems to like a way to avoid all of the above.  With that said, I could be missing other implications/usage of the Association Source field.

Cheers
Andrew

From: Pce <[email-masked]> on behalf of "Mike Koldychev (mkoldych)" <mkoldych=[email-masked]>
Date: Thursday, November 5, 2020 at 1:30 PM
To: Cyril Margaria <[email-masked]>, Dhruv Dhody <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, pce-chairs <[email-masked]>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Cyril,

See inline with [MK]

Thanks,
Dhruv

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Fri, 6 Nov 2020 01:53:08 +0000

Hi Andrew,

See inline with [MK]

From: Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>
Sent: Thursday, November 5, 2020 3:48 PM
To: Mike Koldychev (mkoldych) <[email-masked]>; Cyril Margaria <[email-masked]>; Dhruv Dhody <[email-masked]>
Cc: [email-masked]; [email-masked]; pce-chairs <[email-masked]>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike, Dhruv, Cyril:

We do use errors on initiate messages during race conditions, for example, symbolic name uniqueness on pce-initiated vanilla LSPs. So error based protection to enforce uniqueness and protect race conditions is manageable/done today.
[MK] The chances of symbolic-names being the same is much less than the chance of Association Sources being different. Also the symbolic-name actually has an important meaning, the Association Source has no meaning. Getting a flood of PCError messages about a field that has no meaning would be bad. If we can eliminate these error messages completely, why not do that?

However: would it make sense for the SRPAG definition, to be defined by the ‘first’ entity which created the candidate path? when it’s a shared construct with other entities which are now forced to re-use that value? Using a Virtual IP on the PCE(s) would certainly help, but wouldn’t work correctly with mixed use PCC/PCE init candidate paths (would anyone do that?), or different vendor PCE/clusters/different virtual IPs would add more complexity.  The common element I see is the uniqueness on PCC and the fact that SRPAG==SRPolicy. Since Association Source is ‘scoping for the association ID’, and there is no association scoping used/needed, then the value is essentially unused – therefore just a dummy value assigned by PCC?
[MK] Yes it’s unused! I like the idea of PCC choosing it.

I think there is a bit of ambiguity as mentioned (PCEP session? Router ID? ), and still run the risk that PCEP is terminating on different addresses towards different PCEs / different view of the ‘PCC address’.  Requesting the PCC to just assign the (unused?) value seems to like a way to avoid all of the above.  With that said, I could be missing other implications/usage of the Association Source field.
[MK] Yes, requesting the PCC to assign a value would resolve this issue. But the question is what value would the PCE send in PCInit message when first creating a policy? I propose that PCE can send just 0.0.0.0 or 0::0 in PCInit messages to indicate to the PCC to pick a value. Alternatively, PCE can send any value of Association Source/ID, but the PCC will not honor it and just choose its own Association Source/ID.

Cheers
Andrew

From: Pce <[email-masked]<mailto:[email-masked]>> on behalf of "Mike Koldychev (mkoldych)" <mkoldych=[email-masked]<mailto:mkoldych=[email-masked]>>
Date: Thursday, November 5, 2020 at 1:30 PM
To: Cyril Margaria <[email-masked]<mailto:[email-masked]>>, Dhruv Dhody <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, pce-chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Cyril,

See inline with [MK]

From: Cyril Margaria <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, November 5, 2020 11:35 AM
To: Dhruv Dhody <[email-masked]<mailto:[email-masked]>>
Cc: Mike Koldychev (mkoldych) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; pce-chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Thanks,
Dhruv

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 6 Nov 2020 15:44:57 +0530

Hi Mike, Andrew, Cyril,

Thanks for a great discussion, more inline...

> [MK] The chances of symbolic-names being the same is much less than the chance of Association Sources being different. Also the symbolic-name actually has an important meaning, the Association Sour…

[DD] First, the flood of errors is a stretch by any means :)
And I agree with Andrew about the 'initiate' case.

> [MK] Yes it’s unused! I like the idea of PCC choosing it.

[DD] For a dynamic association, the default is for the local PCEP
speaker to be the association source unless local policy says
otherwise.

Anyways, based on the requirement that you had in the earlier email -

Mike> 1. all 3 parties: PCC, PCE1 and PCE2 agree on the same source, AND
Mike> 2. they agree without talking to each other.

One can make the SRPolicy association to be considered as an
operator-configured association (i.e. association parameters
configured by the operator beforehand on the PCEP peers).

Hear me out, we anyway have the SR Policy configuration happening at
all peers, could we say that the PCEP association parameters
(type/id/source..) need also be set by the operator. If you are
worried that it would be extra configuration, there could be rules set
by the operator for filling the association parameters using SRPolicy
such as Assoc-type=SR-Policy, Assoc-ID/Extended Association ID=Color,
Assoc-source=headend/special value.

Note that allowing SRPolicy to be both dynamic and operator-configured
is also a possiblity.

> [MK] Yes, requesting the PCC to assign a value would resolve this issue. But the question is what value would the PCE send in PCInit message when first creating a policy? I propose that PCE can sen…

I would like us (as a WG) to explore if we can use existing mechanisms
first (the very reason we have common association groupings).
As of now, I am not sold that the use of error in a 'rare'
race-condition is such a bad protocol design that we need to update
RFC8697 and introduce new rules for dynamic associations, esp when
other ways exist.

What do others think?

Thanks!
Dhruv

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Fri, 6 Nov 2020 11:38:32 +0000

Hi Dhruv,

I don't think it's valid to dismiss race conditions in the protocol because they are "rare". If they can happen at all means that implementations need to have extra logic to handle these race conditions. 

What is rare today in your deployment, may not be rare tomorrow in another deployment. I can think of a case where a PCC connects simultaneously to many PCEs which create many thousands of SR CPs on it. If they all send PCInit messages before the head-end replies to them with PCRpt, then you will have this "rare" race condition repeated thousands of times. Each PCE will choose different Source/ID in PCInit and PCC will have to send PCError back to them. Furthermore, you need logic on the PCC to choose the right Association out of many.

There are also undesirable security/privacy implications of putting PCE/NMS IP address into the Source. It means that if two PCEs are controlling different CPs of the same policy, then one of the PCEs can learn the IP address of the other by reading the Association Source of the PCRpt messages from the PCC. This is especially bad, because this Association Source has no semantic meaning in SR Policy and may be hidden in normal show commands. Furthermore, this IP address of the PCE/NMS that created the policy will be associated to the Policy even after PCE disconnects from the PCC, as long as any CP remains in that Policy.

All of this can be avoided if we just allow Source/ID to be 0 in PCInit messages. Is that really such a big change?

Thanks,
Mike.

-----Original Message-----
From: Dhruv Dhody <[email-masked]> 
Sent: Friday, November 6, 2020 5:15 AM
To: Mike Koldychev (mkoldych) <[email-masked]>
Cc: Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>; Cyril Margaria <[email-masked]>; [email-masked]; [email-masked]; pce-chairs <[email-masked]>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike, Andrew, Cyril,

> [MK] The chances of symbolic-names being the same is much less than the chance of Association Sources being different. Also the symbolic-name actually has an important meaning, the Association Sour…

[DD] First, the flood of errors is a stretch by any means :) And I agree with Andrew about the 'initiate' case.

> [MK] Yes it’s unused! I like the idea of PCC choosing it.

[DD] For a dynamic association, the default is for the local PCEP speaker to be the association source unless local policy says otherwise.

One can make the SRPolicy association to be considered as an operator-configured association (i.e. association parameters configured by the operator beforehand on the PCEP peers).

Hear me out, we anyway have the SR Policy configuration happening at all peers, could we say that the PCEP association parameters
(type/id/source..) need also be set by the operator. If you are worried that it would be extra configuration, there could be rules set by the operator for filling the association parameters using SRPolicy such as Assoc-type=SR-Policy, Assoc-ID/Extended Association ID=Color, Assoc-source=headend/special value.

Note that allowing SRPolicy to be both dynamic and operator-configured is also a possiblity.

> [MK] Yes, requesting the PCC to assign a value would resolve this issue. But the question is what value would the PCE send in PCInit message when first creating a policy? I propose that PCE can sen…

I would like us (as a WG) to explore if we can use existing mechanisms first (the very reason we have common association groupings).
As of now, I am not sold that the use of error in a 'rare'
race-condition is such a bad protocol design that we need to update
RFC8697 and introduce new rules for dynamic associations, esp when other ways exist.

What do others think?

Thanks!
Dhruv

>
> Cheers
> Andrew
>
>
>
> From: Pce <[email-masked]> on behalf of "Mike Koldychev 
> (mkoldych)" <mkoldych=[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, 
> "[email-masked]" 
> <[email-masked]>, pce-chairs 
> <[email-masked]>
> Subject: Re: [Pce] Association Source in 
> Cc: Mike Koldychev (mkoldych) <[email-masked]>; [email-masked]; 
> pce-chairs <[email-masked]>; 
> [email-masked]
> Subject: Re: [Pce] Association Source in 
> > https://tools.ietf.org/html/draft-ietf-pce-segment-routing-policy-cp
> > -01#section-4.2,  you state -
> >
> > cy-cp/
> > -policy-cp-01
> > icy-cp-01

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 6 Nov 2020 18:57:17 +0530

Hi Mike,

> I don't think it's valid to dismiss race conditions in the protocol because they are "rare". If they can happen at all means that implementations need to have extra logic to handle these race condi…

Doesn't this "extra" logic exist anyway, as you must make sure there
is only one SR policy association with a given set of SR Policy
parameters under normal operations.

> What is rare today in your deployment, may not be rare tomorrow in another deployment. I can think of a case where a PCC connects simultaneously to many PCEs which create many thousands of SR CPs on it. If they all send PCInit messages before the head-end replies to them with PCRpt, then you will have this "rare" race condition repeated thousands of times. Each PCE will choose different Source/ID in PCInit and PCC will have to send PCError back to them.
>

You make a good point here! What you describe is "possible"!

> Furthermore, you need logic on the PCC to choose the right Association out of many.

The logic is the first association created for a given SR policy at
the PCC and that's it!

> There are also undesirable security/privacy implications of putting PCE/NMS IP address into the Source. It means that if two PCEs are controlling different CPs of the same policy, then one of the P…

If any of this is really an issue, we got to update RFC 8697! I am not
advocating for that BTW :)
Privacy of one PCE from another in an SR domain  (under same
administrative control) is quite a stretch IMHO.

BTW, what are your thoughts on the operator-configured association in
the previous email? Not viable?

> All of this can be avoided if we just allow Source/ID to be 0 in PCInit messages. Is that really such a big change?

No, but the WG worked on RFC 8697 to make sure all the associations
can be handled in a common way as much as possible. When deviating
from that, IMHO a higher bar should be met. The WG should ponder if it
is met here based on the scenario described above, that's all.

Thanks!
Dhruv

PS. Process comment - If the WG decides this is needed (and I am in
rough), the procedure needs to be generic and outside the SR policy
draft in a separate I-D, so that other associations can also use it.

> > > -01

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Fri, 6 Nov 2020 14:09:44 +0000

Hi Dhruv,

-----Original Message-----
From: Dhruv Dhody <[email-masked]> 
Sent: Friday, November 6, 2020 8:27 AM
To: Mike Koldychev (mkoldych) <mkoldych=[email-masked]>
Cc: Dhruv Dhody <[email-masked]>; pce-chairs <[email-masked]>; [email-masked]; [email-masked]; Cyril Margaria <[email-masked]>; Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike,

> I don't think it's valid to dismiss race conditions in the protocol because they are "rare". If they can happen at all means that implementations need to have extra logic to handle these race condi…

Doesn't this "extra" logic exist anyway, as you must make sure there is only one SR policy association with a given set of SR Policy parameters under normal operations.

[MK] If the PCC allocates the Association Source/ID, then it's always going to choose a unique value, so there will never be any collision. So no, this "extra" logic won't exist if we go with my proposal.

[MK] I would say "very likely" that you would get a flood of PCError messages in that scenario under scale.

> Furthermore, you need logic on the PCC to choose the right Association out of many.

The logic is the first association created for a given SR policy at the PCC and that's it!

> There are also undesirable security/privacy implications of putting PCE/NMS IP address into the Source. It means that if two PCEs are controlling different CPs of the same policy, then one of the P…

If any of this is really an issue, we got to update RFC 8697! I am not advocating for that BTW :) Privacy of one PCE from another in an SR domain  (under same administrative control) is quite a stretch IMHO.

[MK] The two PCEs may not be under one administrative control. Network A may delegate some tunnels/policies to Network B PCE (for routing through Network B, for example). In this case, the internal NMS/PCE addresses of Network A would be leaked. An operator who is not intimate with the PCEP messaging internals might never even realize this leak is happening. I believe we should update RFC 8697, we need to at least state that a privacy violation is possible and that the operator needs to assume that internal NMS/PCE addresses are going to be leaked to other PCEs via the ASSOCIATION object.

BTW, what are your thoughts on the operator-configured association in the previous email? Not viable?

[MK] You could set AssocExtID=Color, but I’m not sure what you would set Source to? Can we just set it to 0.0.0.0/0::0 and be done? Isn't that also a "special value"?

> All of this can be avoided if we just allow Source/ID to be 0 in PCInit messages. Is that really such a big change?

No, but the WG worked on RFC 8697 to make sure all the associations can be handled in a common way as much as possible. When deviating from that, IMHO a higher bar should be met. The WG should ponder if it is met here based on the scenario described above, that's all.

[MK] I fully understand, but the value of 0 is reserved in that RFC. Can each application use 0/0.0.0.0/0::0 for its own purpose? Is that allowed/forbidden in the RFC?

Thanks!
Dhruv

PS. Process comment - If the WG decides this is needed (and I am in rough), the procedure needs to be generic and outside the SR policy draft in a separate I-D, so that other associations can also use it.

> Cc: Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>; Cyril 
> Margaria <[email-masked]>; [email-masked]; 
> [email-masked]; pce-chairs 
> <[email-masked]>
> Mike> 1. all 3 parties: PCC, PCE1 and PCE2 agree on the same source, 
> Mike> AND 2. they agree without talking to each other.
>
> > association-source! The use of 0 as association ID is being 
> > introduced by your draft and not part of the base RFC 8697 and that 
> > triggered the original email. Julien and I were uncomfortable with 
> > that and wanted to understand what is new here for SR policy 
> > association that requires a new procedure and cant be handled by RFC 8697.
> >
> > Thanks,
> > Dhruv
> >
> > >
> > > Thanks,
> > >
> > > Mike.
> > >
> > >
> > >
> > > Cc: [email-masked]; 
> > > [email-masked]; pce-chairs <[email-masked]>
> > > I feel the requirement 2 is not compatible with a dynamic 
> > > association

---

From: Cyril Margaria <[email-masked]>
Date: Fri, 6 Nov 2020 14:21:15 +0000

Hi Mike

On Fri, 6 Nov 2020 at 14:09, Mike Koldychev (mkoldych) <[email-masked]>
wrote:

> Cc: Dhruv Dhody <[email-masked]>; pce-chairs <[email-masked]>;
> [email-masked]; [email-masked]; Cyril
> Margaria <[email-masked]>; Stone, Andrew (Nokia - CA/Ottawa) <
> [email-masked]>
> > I don't think it's valid to dismiss race conditions in the protocol
> because they are "rare". If they can happen at all means that
> implementations need to have extra logic to handle these race conditions.
> >
>
> Doesn't this "extra" logic exist anyway, as you must make sure there is
> only one SR policy association with a given set of SR Policy parameters
> under normal operations.
>
> [MK] If the PCC allocates the Association Source/ID, then it's always
> going to choose a unique value, so there will never be any collision. So
> no, this "extra" logic won't exist if we go with my proposal.
>

[MC] that's assuming that the PCE always sends 0, and not the previously
returned value, at that point why bother using or tracking association ?

<cut>

> [MK] You could set AssocExtID=Color, but I’m not sure what you would set
> Source to? Can we just set it to 0.0.0.0/0::0 and be done? Isn't that
> also a "special value"?
>

AssocExtID=Color, endpoint

Source should be a valid IP address, 0.0.0.0 looks OK, but I am rusty on
that.
0 is reserved, 0xFFFF is all assocation, 1 works as a fixed number not in a
reserved range.

>
> > All of this can be avoided if we just allow Source/ID to be 0 in PCInit
> messages. Is that really such a big change?
> >
>
> No, but the WG worked on RFC 8697 to make sure all the associations can be
> handled in a common way as much as possible. When deviating from that, IMHO
> a higher bar should be met. The WG should ponder if it is met here based on
> the scenario described above, that's all.
>
> [MK] I fully understand, but the value of 0 is reserved in that RFC. Can
> each application use 0/0.0.0.0/0::0 for its own purpose? Is that
> allowed/forbidden in the RFC?
>

 <cut>

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Fri, 6 Nov 2020 14:41:31 +0000

Hi Cyril,

Yes I propose the PCE always send PCInint with 0/0.0.0.0/0::0 (for SR Policy). PCC would then allocate its own Source/ID and send that in PCRpt. That PCC allocated Source/ID would be used to track the Association, not the 0/0.0.0.0/0::0.

Associations in general are useful because they allow to refer to a grouping of PLSPs.

Thanks,
Mike.

From: Cyril Margaria <[email-masked]>
Sent: Friday, November 6, 2020 9:21 AM
To: Mike Koldychev (mkoldych) <[email-masked]>
Cc: Dhruv Dhody <[email-masked]>; Mike Koldychev (mkoldych) <[email-masked]>; Dhruv Dhody <[email-masked]>; pce-chairs <[email-masked]>; [email-masked]; [email-masked]; Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike

On Fri, 6 Nov 2020 at 14:09, Mike Koldychev (mkoldych) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Dhruv,

-----Original Message-----
From: Dhruv Dhody <[email-masked]<mailto:[email-masked]>>
Sent: Friday, November 6, 2020 8:27 AM
To: Mike Koldychev (mkoldych) <mkoldych=[email-masked]<mailto:[email-masked]>>
Cc: Dhruv Dhody <[email-masked]<mailto:[email-masked]>>; pce-chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Cyril Margaria <[email-masked]<mailto:[email-masked]>>; Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike,

[MC] that's assuming that the PCE always sends 0, and not the previously returned value, at that point why bother using or tracking association ?

<cut>

[MK] You could set AssocExtID=Color, but I’m not sure what you would set Source to? Can we just set it to 0.0.0.0/0::0<http://0.0.0.0/0::0> and be done? Isn't that also a "special value"?

Source should be a valid IP address, 0.0.0.0 looks OK, but I am rusty on that.
0 is reserved, 0xFFFF is all assocation, 1 works as a fixed number not in a reserved range.

[MK] I fully understand, but the value of 0 is reserved in that RFC. Can each application use 0/0.0.0.0/0::0<http://0.0.0.0/0::0> for its own purpose? Is that allowed/forbidden in the RFC?

 <cut>

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 6 Nov 2020 21:20:04 +0530

Hi Mike,

> [MK] If the PCC allocates the Association Source/ID, then it's always going to choose a unique value, so there will never be any collision. So no, this "extra" logic won't exist if we go with my pr…

+1 to what Cyril said. The idea that even when PCE knows about the
existing association created at the PCC and it wants a new CP to join
that association, it cannot do so and it must use association-id as
zero is weird - there is a reason we maintain associations at the PCE.
So my reading was that the use of 0 was only when the SR Policy
association was not known.
Also, you don't mention the PCUpd message in your draft, first an
existing SR-TE path (RFC 8664) can join the SR Policy association
using the PCUpd message. Also, you may want to update the existing CP
and carry the already known association in the PCUpd message. I assume
you would want to put "a non-zero PCC allocated ID''!

> [MK] The two PCEs may not be under one administrative control. Network A may delegate some tunnels/policies to Network B PCE (for routing through Network B, for example).

Delegation outside of your network domain would open you up to so much
more security concern than just knowing another PCE address! Even in
the case you mention we would assume there would be a PCEP session
between the PCEs across network domains (so hiding PCE address should
not be a concern).

> In this case, the internal NMS/PCE addresses of Network A would be leaked. An operator who is not intimate with the PCEP messaging internals might never even realize this leak is happening. I believe we should update RFC 8697, we need to at least state that a privacy violation is possible and that the operator needs to assume that internal NMS/PCE addresses are going to be leaked to other PCEs via the ASSOCIATION object.
>
>

You can set association-source as head-end IP address which is known
as part of SR-Policy tuple <headend, color, endpoint>. This rule can
be scoped under the association-type=SR-Policy (and not applicable
anywhere else).

> [MK] I fully understand, but the value of 0 is reserved in that RFC. Can each application use 0/0.0.0.0/0::0 for its own purpose? Is that allowed/forbidden in the RFC?

The issue for me is not so much the use of 0, it is the idea that it
MUST always be a PCC that allocates association information (going
against an existing standard). I feel a simple rule of association
creation at any PCEP peer such as Assoc-Type=SR-Policy, Assoc-ID=0x0,
Ext-Assoc-ID=color, Association-source=headend can solve it!

Have a good weekend everyone!

Thanks!
Dhruv

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Fri, 6 Nov 2020 19:38:41 +0000

Hi Dhruv,

Thanks again for bringing up this topic. Let's think some more about the possible solutions and also let other people provide feedback. Perhaps a side-meeting can be held as well.

Have a good weekend,
Mike.

-----Original Message-----
From: Dhruv Dhody <[email-masked]> 
Sent: Friday, November 6, 2020 10:50 AM
To: Mike Koldychev (mkoldych) <[email-masked]>
Cc: Dhruv Dhody <[email-masked]>; Mike Koldychev (mkoldych) <mkoldych=[email-masked]>; pce-chairs <[email-masked]>; [email-masked]; [email-masked]; Cyril Margaria <[email-masked]>; Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike,

On Fri, Nov 6, 2020 at 7:39 PM Mike Koldychev (mkoldych) <[email-masked]> wrote:
> Margaria <[email-masked]>; Stone, Andrew (Nokia - CA/Ottawa) 
> <[email-masked]>

+1 to what Cyril said. The idea that even when PCE knows about the
existing association created at the PCC and it wants a new CP to join that association, it cannot do so and it must use association-id as zero is weird - there is a reason we maintain associations at the PCE.
So my reading was that the use of 0 was only when the SR Policy association was not known.
Also, you don't mention the PCUpd message in your draft, first an existing SR-TE path (RFC 8664) can join the SR Policy association using the PCUpd message. Also, you may want to update the existing CP and carry the already known association in the PCUpd message. I assume you would want to put "a non-zero PCC allocated ID''!

> [MK] The two PCEs may not be under one administrative control. Network A may delegate some tunnels/policies to Network B PCE (for routing through Network B, for example).

Delegation outside of your network domain would open you up to so much more security concern than just knowing another PCE address! Even in the case you mention we would assume there would be a PCEP session between the PCEs across network domains (so hiding PCE address should not be a concern).

> [MK] You could set AssocExtID=Color, but I’m not sure what you would set Source to? Can we just set it to 0.0.0.0/0::0 and be done? Isn't that also a "special value"?

You can set association-source as head-end IP address which is known as part of SR-Policy tuple <headend, color, endpoint>. This rule can be scoped under the association-type=SR-Policy (and not applicable anywhere else).

> [MK] I fully understand, but the value of 0 is reserved in that RFC. Can each application use 0/0.0.0.0/0::0 for its own purpose? Is that allowed/forbidden in the RFC?

The issue for me is not so much the use of 0, it is the idea that it MUST always be a PCC that allocates association information (going against an existing standard). I feel a simple rule of association creation at any PCEP peer such as Assoc-Type=SR-Policy, Assoc-ID=0x0, Ext-Assoc-ID=color, Association-source=headend can solve it!

Thanks!
Dhruv

> > Cc: Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>; 
> > Cyril Margaria <[email-masked]>; [email-masked]; 
> > > introduced by your draft and not part of the base RFC 8697 and 
> > > that triggered the original email. Julien and I were uncomfortable 
> > > with that and wanted to understand what is new here for SR policy

---

From: "Mike Koldychev (mkoldych)" <[email-masked]>
Date: Mon, 23 Nov 2020 15:34:33 +0000

Hi PCE-CHAIRS,

Would like to understand how does RFC 8697 work in the following scenario:

t=1: PCE_A creates LSP_1 in Association_A (using Source=PCE_A)
t=2: PCE_B creates LSP_2 and joins Association_A
t=3: PCE_A deletes LSP_1

Now, PCE_B owns an Association that has the source address of PCE_A. Meanwhile, PCE_A may disconnect from the given PCC and may not be aware that PCE_B is using PCE_A as the Source. So PCE_A can now reuse the same Association ID somewhere else?

Thanks,
Mike.

-----Original Message-----
From: Mike Koldychev (mkoldych) 
Sent: Friday, November 6, 2020 2:39 PM
To: Dhruv Dhody <[email-masked]>
Cc: Dhruv Dhody <[email-masked]>; Mike Koldychev (mkoldych) <mkoldych=[email-masked]>; pce-chairs <[email-masked]>; [email-masked]; [email-masked]; Cyril Margaria <[email-masked]>; Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>
Subject: RE: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Dhruv,

Have a good weekend,
Mike.

-----Original Message-----
From: Dhruv Dhody <[email-masked]>
Sent: Friday, November 6, 2020 10:50 AM
To: Mike Koldychev (mkoldych) <[email-masked]>
Cc: Dhruv Dhody <[email-masked]>; Mike Koldychev (mkoldych) <mkoldych=[email-masked]>; pce-chairs <[email-masked]>; [email-masked]; [email-masked]; Cyril Margaria <[email-masked]>; Stone, Andrew (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Pce] Association Source in draft-ietf-pce-segment-routing-policy-cp-01

Hi Mike,

Thanks!
Dhruv

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 24 Nov 2020 10:29:29 +0530

Hi Mike,

> Now, PCE_B owns an Association that has the source address of PCE_A. Meanwhile, PCE_A may disconnect from the given PCC and may not be aware that PCE_B is using PCE_A as the Source. So PCE_A can no…

The stateful PCE model works with the assumption that the LSP state
from the network is synchronized to all PCEs in the domain. BTW in the
case of a temporary disconnect, synchronization between PCE is the
proposed solution. Basically, PCE_A needs to be aware of the continued
use of association at the PCC/PCE_B in your example.

Also, when RFC 8697 suggested using virtual IP as a source in case of
PCE redundancy, it was with this understanding that the state is
synchronized and one PCE would be aware of association created by
another, using the virtual IP as association source (this principle
can be applied to PCE_A as source as well). Also, in your case above
it would be a good implementation principle for PCE_A to not reuse the
same association ID immediately if it can help it :)

Anyways as a last resort, there is also a possibility for PCE_B to
remove the old association and recreate a new association in an
extreme case. Though I would not recommend you do that!

=

RFC 8697 provides a mechanism that is generic and includes the
association with LSPs with different headends. PCC based allocation
would not work in that case. Isn't it likely that implementations
would support other association types as well, and likely implement
the generic handling. To me reusing the generic techniques where we
can makes sense (that was the very reason for the WG producing RFC
8697).

=

Thanks!
Dhruv (as a WG member)