Subject: [Pce] IETF 109 PCE WG minutes

From: Dhruv Dhody <[email-masked]>
Date: Mon, 23 Nov 2020 16:14:25 +0530

Hi WG,

Please find the minutes for the PCE WG session -
https://datatracker.ietf.org/doc/minutes-109-pce/

Thanks to Hari and everyone else that contributed to the minutes.
Please reach out to [email-masked] in case any correction needs
to be made.

Thanks!
Dhruv & Julien

---

From: tom petch <[email-masked]>
Date: Mon, 23 Nov 2020 12:37:16 +0000

From: Pce <[email-masked]> on behalf of Dhruv Dhody <[email-masked]>
Sent: 23 November 2020 10:44

<tp>
I see no mention of pcep-yang which is one of the hundreds of I-D updated in the prelude to the window closing for the meeting:-(  I have looked at it briefly.

Pagination; the IETF has abolished it.  Those doing so expect us to have short sections that are easy to reference; they are of course unaware of YANG where a section can run unbroken for 50 pages.  So, it behoves us to keep sections short where that is not impossible.  My take is that a section should be half a page or less.  It would be worth looking at the first six sections to see if they can sensibly be divided.  I would suggest that wherever a page number is missing from the TOC then a change would be good (except for YANG).

There is a lot of 'if pce or pce and pcc'.  I wonder if a YANG doctor could find a more elegant expression.

Likewise but more so for me, there is a lot of must have a  value for these states or else must be zero with some fairly hard to follow IMHO combinations of 'and' 'or' 'not'.  I would have thought it simpler to have a 'when' such that the leaf is absent from the model (as opposed to present and MBZ) if the states are not suitable.

Again, for me, I find the repeated use of 'domain' confusing.  There is a YANG convention of list plural leaf singular so /domains/domain/ as opposed to /domain/domain/ but even so there is a lot of domain which I would prefer to have slightly differing names.

Finally, is PCE a routing protocol?  There are conventions for routing protocols such as OSPF about defining an identity and where to augment which this does not follow suggesting that it does not qualify.

Tom Petch

Hi WG,

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 23 Nov 2020 18:22:34 +0530

Hi Tom,

Thanks for checking on PCEP-Yang.

> I see no mention of pcep-yang which is one of the hundreds of I-D updated in the prelude to the window closing for the meeting:-(  I have looked at it briefly.

It was part of the chairs slides #15
[https://datatracker.ietf.org/meeting/109/materials/slides-109-pce-1-introduction-01].
In the PCE WG, we usually capture only the discussion points in our
minutes.

> Pagination; the IETF has abolished it.  Those doing so expect us to have short sections that are easy to reference; they are of course unaware of YANG where a section can run unbroken for 50 pages.…

I am aware of that discussion. IMHO at this stage, we can look again
at these sections and do a change only if it increases the
readability.

> Again, for me, I find the repeated use of 'domain' confusing.  There is a YANG convention of list plural leaf singular so /domains/domain/ as opposed to /domain/domain/ but even so there is a lot o…

We did an early yang doctor review some time back, the authors are
suggesting another one soon. We can point them to your email as well
and see what they suggest.

> Finally, is PCE a routing protocol?  There are conventions for routing protocols such as OSPF about defining an identity and where to augment which this does not follow suggesting that it does not…

No, PCE is not a routing protocol and thus does not follow the same convention.

Thanks!
Dhruv