Subject: Re: [Pce] WG adoption poll for draft-dugeon-pce-stateful-interdomain-04

From: Dhruv Dhody <[email-masked]>
Date: Fri, 8 Jan 2021 14:57:16 +0530

Hi WG,

Happy New Year!

Just a reminder, the WG Adoption poll ends on Monday 11th Jan, please
respond to the call with your support (or not), comments, etc.
Please be more vocal on the list [1].

Thanks!
Dhruv & Julien

[1] https://datatracker.ietf.org/meeting/109/materials/slides-109-pce-1-introduction-01
> Please be Vocal
>
> o During WG Adoption and WG LC calls, the response is less.
>
> o Please be vocal on the list to help us gauge the consensus better.
>
> o The working group mailing lists are looked at by the IESG, IAB, and others (internal and external to IETF) to determine interest/participation level in our standards process.
>
> o Please review ideas from your peers, these are community outputs of the working group as a whole.
>

On Fri, Dec 18, 2020 at 6:22 PM Dhruv Dhody <[email-masked]> wrote:
>
> Hi WG,
>
> This email begins the WG adoption poll for
> draft-dugeon-pce-stateful-interdomain-04.
>
> https://datatracker.ietf.org/doc/html/draft-dugeon-pce-stateful-interdomain-04
>
> Should this draft be adopted by the PCE WG? Please state your reasons
> - Why / Why not? What needs to be fixed before or after adoption? Are
> you willing to work on this draft? Review comments should be posted to
> the list.
>
> To accommodate for the holiday season, this adoption poll will end on
> 11th Jan 2021 (Monday).
>
> Thanks!
> Dhruv

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 8 Jan 2021 15:01:50 +0530

Hi WG, Authors,

Speaking as a WG participant...

I find the functionality described in this I-D to be very useful. But,
I have one concern that I would like to be addressed before adoption
or at least get an agreement on (to be handled post-adoption).

I am not in favor of how the PST is being used in the I-D. The PST is used -
- between PCEs to indicate inter-domain TE processing
- between PCE and the head-end (2 PST for RSVP-TE & SR each, but for
inter-domain i.e also allocate and report stitching label)

We basically need a mechanism to request allocation and reporting of
stitching labels. I strongly suggest using a flag and/or a new TLV, I
find the use of PST for this inappropriate.

A weird side-effect of the current proposal is that every time we have
a new PST defined (PCECC is post-WGLC), we would need another one for
inter-domain.

Moreover, wouldn't it be better if this I-D is independent of the
per-domain path setup type? Section 6.3 allows for mixed technologies
and the protocol procedures between cooperating PCEs can be defined
such that they are independent of the per-domain path setup type to
allow for any current or future path setup types. I see no reason to
differentiate between RSVP-TE and SR (section 6.2 is all about
forwarding on border nodes, and not about PCEP).

I discussed this with the authors earlier, where we basically pushed
the can down the road, I hope we can resolve this quickly now :)

Thanks!
Dhruv
 (As a WG participant)

On Fri, Dec 18, 2020 at 6:23 PM Dhruv Dhody <[email-masked]> wrote:
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: <[email-masked]>
Date: Fri, 8 Jan 2021 14:47:45 +0100

Hello Dhruv,

Thanks for your comment.

When we started writing this draft, our main goal was to propose a
mechanism for inter-domain tunnel setup in a coordinated way while
remaining operator independent. We chose to re-use as much as possible
existing PCEP objects and just proposed to request new IANA code points
within existing registries. Of course, this is just a matter of feature
encoding for stateful inter-domain.
You're right: multiplying the number of PSTs to add inter-domain to
each of them isn't a nice way forward. As the I-D is now considered as
a WG item, we are open to study any mechanism that fits WG expectations,
i.e. we fully agree to create a dedicated PCEP object, TLV or new flag
to implement it.

I think the best approach, if the draft is adopted, is to publish it as
a version -00 and then discuss the suitable mechanism as part of the WG
work to produce a version -01 specifying it.
Do you agree with this approach?

Regards

Olivier, on behalf of the authors

-- 
Orange logo <http://www.orange.com>

Olivier Dugeon
Orange Expert, Future Networks
Open Source Referent
Orange/IMT/OLN/WTC/IEE/iTeQ

fixe : +33 2 96 07 28 80
mobile : +33 6 82 90 37 85
[email-masked] <mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 8 Jan 2021 16:30:26 -0800

I support the adoption given points rased by Dhruv are addressed ( post adoption in fine)

Cheers,
Jeff

---

From: Zhenghaomian <[email-masked]>
Date: Mon, 11 Jan 2021 08:28:07 +0000

Yes, Support. 

This draft is proposing the approach for segment stitching, which is especially useful in cross-technology scenarios. It is possible in inter-domain case that one domain BN acts as PCC, and trigger the LSP establishment in the other technology domain (acting as PCE) with PCInitiation without knowing the details in the PCE's domain. 

Best wishes,
Haomian

-----邮件原件-----
发件人: Pce [mailto:[email-masked]] 代表 Dhruv Dhody
发送时间: 2020年12月18日 20:52
收件人: [email-masked]
抄送: pce-chairs <[email-masked]>
主题: [Pce] WG adoption poll for draft-dugeon-pce-stateful-interdomain-04

Hi WG,

This email begins the WG adoption poll for draft-dugeon-pce-stateful-interdomain-04.

Should this draft be adopted by the PCE WG? Please state your reasons
- Why / Why not? What needs to be fixed before or after adoption? Are you willing to work on this draft? Review comments should be posted to the list.

To accommodate for the holiday season, this adoption poll will end on 11th Jan 2021 (Monday).

Thanks!
Dhruv

---

From: "Boris Khasanov" <[email-masked]>
Date: Mon, 11 Jan 2021 17:19:10 +0300

Hi Dhruv and all,

Happy New Year too!
Thanks a lot for reminding.
I  support this draft. I like Stitching Label approach and especially, in
case of SR, the link towards EPE ( PeerNode/PeerAdj SIDs).

SY,
Boris

-----Original Message-----
From: Pce <[email-masked]> On Behalf Of Dhruv Dhody
Sent: Friday, January 8, 2021 12:27 PM
To: [email-masked]
Cc: pce-chairs <[email-masked]>
Subject: Re: [Pce] WG adoption poll for
draft-dugeon-pce-stateful-interdomain-04

Hi WG,

Happy New Year!

Thanks!
Dhruv & Julien

[1]
https://datatracker.ietf.org/meeting/109/materials/slides-109-pce-1-introduc
tion-01
> o The working group mailing lists are looked at by the IESG, IAB, and
others (internal and external to IETF) to determine interest/participation
level in our standards process.

---

From: <[email-masked]>
Date: Mon, 11 Jan 2021 19:33:53 +0100

Hello Adrian,

Thanks a lot for your thorough review and your suggestion.

We'll incorporate all of them. I just have a comment about the text with the proposed figure: as it describe the Backward Recursive method, I think it will preferable inverse order of explanation for point 3 i.e. start by domain C, then domain B and end with domain A.

Regards,

PS. Sorry for the late answer, my initial reply got stuck in the outbox.

Le 22/12/2020 à 14:37, Adrian Farrel a écrit :
> Hi,
>
> I've reviewed this draft and I think it is ready for adoption because
> the functionality (i.e., stitching segments without inter-domain
> signaling which means that path-key cannot be used) is valuable.
>
> There are a number of editorial comments below. I think they do not 
> need to be addressed before adoption, but I hope the authors will factor
> them into a new revision after adoption.
>
> Thanks,
> Adrian
>
> ===
>
> Need to update Young Lee's coordinates
>
> ---
>
> Abstract
>
> I think that BRPC or H-PCE are methods to achieve inter-domain paths
> not methods to be combined with inter-domain paths. How about...
> OLD
>    This document specifies how to combine a Backward Recursive or
>    Hierarchical method with inter-domain paths in the context of
>    stateful Path Computation Element (PCE).
> NEW
>    This document specifies how to use a Backward Recursive or
>    Hierarchical method to derive inter-domain paths in the context of
>    stateful Path Computation Element (PCE).
> END
>
> ---
>
> Abstract
>
> "It relies on..." comes in the sentence immediately after "This
> document..."  I think you need to be more precise. Probably
>
> s/It relies on/The mechanism relies on/
>
> ---
>
> Abstract
>
> s/enables to operate them/enables them to be operated/
>
> ---
>
> Abstract
>
>    A new Stitching Label is defined, new Path
>    Setup Types, a new Association Type and a new PCEP communication
>    Protocol (PCEP) Capability are considered for that purpose.
>
> I can't parse this. Possibly...
>
>    For this purpose, this document defines a new Stitching Label, new
>    Path Setup Types, new Association Type, and a new PCEP communication
>    Protocol (PCEP) Capability.
>
> ---
>
> The requirement language should be moved into section 1.2
>
> ---
>
> Introduction
>
> There is a *lot* of text in the Introduction. I wonder whether we need
> so much. Does every PCE document have to start with the whole history of
> PCE?
>
> I tried to boil down what this document is really about:
>
> - PCE is used to compute paths from MPLS-TE, GMPLS, and SR
> - Various mechanisms can be used to enable PCEs to cooperate to compute
>   inter-domain paths including BRPC and H-PCE
> - MPLS-TE and GMPLS depend on signaling using RSVP-TE to set up paths,
>   but it is not common to allow signaling across administrative domain
>   borders.
> - SR depends on a stack of segment identifiers, but in an inter-domain
>   path, this stack may become large, and detailed control of a path
>   within one domain by packets originating in another domain might not 
>   be supported.
> - This document describes a mechanism whereby the paths across each 
>   domain remain under the control of those domains, and the paths are
>   stitched together at domain boundaries to form a single end-to-end
>   path.
> - The mechanism relies on cooperating PCEs to determine the end-to-end
>   path with each PCE responsible for computing and initiating the paths
>   within its domain. The PCEs are assumed to be stateful active PCEs so
>   that they can instruct their networks to set up the paths. 
> - Signaling (for MPLS-TE and GMPLS) is used only within individual
>   domains.
> - Specific labels/SIDs are used to indicate which path segments should
>   be stitched together.
> - To enable this mechanism, this document defines a new Stitching
>   Label, new Path Setup Types, new Association Type, and a new PCEP
>   communication Protocol (PCEP) Capability.
>
> I think that can be converted into text that is a little easier to read
> than the current Introduction.
>
> ---
>
> 1.1
>
> s/end-o-end/end-to-end/
>
> ---
>
> I think it would be helpful to have a figure that shows the solution 
> architecture in more detail than that currently in section 1.1.  Nothing
> wrong with that figure, but we also need to see the LSPs/SR-paths and
> where the signaling stops and how the label/SID on the inter-domain link
> is used. Also, how the PCEs talk to the various nodes.
>                                          
> Something like the figure below would allow the descriptive text that
> follows.
>
>     --------------           --------------           --------------
>    |Domain-A      |         |Domain-B      |         |Domain-C      |
>    |              |         |              |         |              |
>    |     PCE------+--PCEP---+---PCE--------+--PCEP---+---PCE        |
>    |    /         |         |  /           |         |  /           |
>    |   /          |         | /            |         | /            |
>    | Src=========BNA-------BNB1===========BNB2------BNC=========Dst |
>    |              |  Inter- |              |  Inter- |              |
>     --------------   Domain  --------------   Domain  --------------
>                      Link                     Link
>
>
>    1. The PCEs in Domain-A, Domain-B, and Domain-C communicate using
>       PCEP either directly, as shown, using BRPC or with a parent PCE
>       if using BRPC.
>    2. The PCE in Domain-A selects an end-to-end domain path. It tells
>       the PCE in Domain-B that the path will be used, and that PCE
>       passes the information on to the PCE in Domain-C.
>    3. Each of the PCEs use PCEP to instruct the segment head ends.
>       a. In Domain-A, the PCE instructs the Source node with the path
>          to use to reach Border Node, BNA.  The instructions also 
>          include the label or SID to use on the inter-domain link to
>          BNB1.
>       b. In Domain-B, the PCE instructs the ingress Border Node, BNB1,
>          with the path to reach the egress Border Node, BNB2.  The
>          instructions also tell BNB1 the incoming label or SID that
>          will be stitched to the intra-domain path, and the label or
>          SID to use on the inter-domain link to BNC.
>       c. In Domain-C, the PCE instructs the ingress Border Node, BNC,
>          with the path to reach the Destination.  The instructions also
>          tell BNC the incoming label or SID that will be stitched to the
>          intra-domain path.
>
> Sent: 18 December 2020 12:52
> To: [email-masked]
> Subject: [Pce] WG adoption poll for draft-dugeon-pce-stateful-interdomain-04
>
> Hi WG,
>

Olivier Dugeon

fixe : +33 2 96 07 28 80

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 12 Jan 2021 16:08:20 +0530

Hi WG,

The response has been limited so far. Thanks to Oliver for responding
to the comments.

Since the adoption period coincided with holidays, we are extending
the adoption call for another week (i.e. Monday 18th Jan). We *need*
to hear from more of you before taking a call. Please respond with
your support (or not) for this work and if this I-D is a good basis to
be further refined under the control of the WG.

Regards,
Dhruv

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 12 Jan 2021 16:59:22 +0000

Hi Dhruv, Julien,

Thanks for extending the deadline. 
I support the adoption of the draft. Inter domain stateful PCE capabilities are extremely important in the provisioning of end to end services. (tried a work around to avoid mentioning network slicing) .

BR
Daniele  

-----Original Message-----
From: Pce <[email-masked]> On Behalf Of Dhruv Dhody
Sent: den 12 januari 2021 11:38
To: [email-masked]
Cc: pce-chairs <[email-masked]>
Subject: Re: [Pce] WG adoption poll for draft-dugeon-pce-stateful-interdomain-04

Hi WG,

The response has been limited so far. Thanks to Oliver for responding to the comments.

Since the adoption period coincided with holidays, we are extending the adoption call for another week (i.e. Monday 18th Jan). We *need* to hear from more of you before taking a call. Please respond with your support (or not) for this work and if this I-D is a good basis to be further refined under the control of the WG.

Regards,
Dhruv

On Fri, Jan 8, 2021 at 2:57 PM Dhruv Dhody <[email-masked]> wrote:
> https://datatracker.ietf.org/meeting/109/materials/slides-109-pce-1-in
> troduction-01
> > Please be Vocal
> >
> > - Why / Why not? What needs to be fixed before or after adoption? 
> > Are you willing to work on this draft? Review comments should be 
> > posted to the list.
> >

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Wed, 13 Jan 2021 08:46:41 +0000

Hi Dhruv, all,
Thanks for extending the adoption call.

Yes/support. 
I think it is very useful document addressing a usual difficult topic of inter-domain path computation and e2e service setup. 

Thanks
Sergio

-----Original Message-----
From: Pce <[email-masked]> On Behalf Of Dhruv Dhody
Sent: Tuesday, January 12, 2021 11:38 AM
To: [email-masked]
Cc: pce-chairs <[email-masked]>
Subject: Re: [Pce] WG adoption poll for draft-dugeon-pce-stateful-interdomain-04

Hi WG,

Regards,
Dhruv

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 15 Jan 2021 00:01:42 -0500

Hi Dhruv and authors

Happy New Year!!

I support WG adoption of this critical topic and complex problem for
operators of inter domain path computation using this innovative stitching
label to accomplish the task.

Kind Regards

Gyan

On Wed, Jan 13, 2021 at 3:47 AM Belotti, Sergio (Nokia - IT/Vimercate) <
[email-masked]> wrote:

> I think it is very useful document addressing a usual difficult topic of
> inter-domain path computation and e2e service setup.
>
> Thanks
> Sergio
>
> Since the adoption period coincided with holidays, we are extending the
> adoption call for another week (i.e. Monday 18th Jan). We *need* to hear
> from more of you before taking a call. Please respond with your support (or
> not) for this work and if this I-D is a good basis to be further refined
> under the control of the WG.
>
> Regards,
> Dhruv
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: "Luis M. Contreras" <[email-masked]>
Date: Sat, 16 Jan 2021 20:21:16 +0100

Hi all,

I support the adoption of the draft. It provides a suitable solution
for the very relevant topic of inter-domain constrained path setup, which
will become even more relevant in the next future.

Best regards

Luis

-- 
___________________________________________
Luis M. Contreras
[email-masked]
[email-masked]
Global CTIO unit / Telefonica

---

From: <[email-masked]>
Date: Mon, 18 Jan 2021 18:31:49 +0100

Hi all,

Co-author hat on, I support the adoption the I-D and second Olivier in
agreeing with Dhruv's point.

Cheers,

Julien

On 12/01/2021 11:38, Dhruv Dhody wrote:
> <p></p>

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 19 Jan 2021 11:34:52 +0530

Hi WG,

Thanks to all who responded to the adoption poll. We have support to
adopt this as a WG item. Please continue to provide your comments as
the document moves through the WG process.

Authors, please post a -00 version
'draft-ietf-pce-stateful-interdomain-00' with only the name/date
change, and be sure to set the "replaces" option during submission.

Looking forward to -01 that handles the comments received and move the
work forward.

Thanks!
PCE Chairs